summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Data-ICal
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Data-ICal')
-rw-r--r--dev-perl/Data-ICal/Data-ICal-0.210.0-r1.ebuild34
-rw-r--r--dev-perl/Data-ICal/Data-ICal-0.220.0.ebuild39
-rw-r--r--dev-perl/Data-ICal/Manifest2
-rw-r--r--dev-perl/Data-ICal/metadata.xml22
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-perl/Data-ICal/Data-ICal-0.210.0-r1.ebuild b/dev-perl/Data-ICal/Data-ICal-0.210.0-r1.ebuild
new file mode 100644
index 000000000000..676e9411f5d9
--- /dev/null
+++ b/dev-perl/Data-ICal/Data-ICal-0.210.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ALEXMV
+MODULE_VERSION=0.21
+inherit perl-module
+
+DESCRIPTION="Generates iCalendar (RFC 2445) calendar files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/Class-Accessor
+ dev-perl/Class-ReturnValue
+ dev-perl/Text-vFile-asData"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-LongString
+ )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i "/^auto_install();/d" "${S}"/Makefile.PL || die
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Data-ICal/Data-ICal-0.220.0.ebuild b/dev-perl/Data-ICal/Data-ICal-0.220.0.ebuild
new file mode 100644
index 000000000000..e7caf61d1ea5
--- /dev/null
+++ b/dev-perl/Data-ICal/Data-ICal-0.220.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ALEXMV
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Generates iCalendar (RFC 2445) calendar files"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Class-Accessor
+ dev-perl/Class-ReturnValue
+ dev-perl/Text-vFile-asData
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.360.0
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Warn
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-LongString
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i "/^auto_install();/d" "${S}"/Makefile.PL || die
+ perl-module_src_prepare
+}
diff --git a/dev-perl/Data-ICal/Manifest b/dev-perl/Data-ICal/Manifest
new file mode 100644
index 000000000000..08913bcce471
--- /dev/null
+++ b/dev-perl/Data-ICal/Manifest
@@ -0,0 +1,2 @@
+DIST Data-ICal-0.21.tar.gz 117530 SHA256 93c2b0b0800b52e753073094675338aa476183ea9b759872b11e44dd43c9b45d SHA512 d3c8295c043f3c39b6ff50f74031bf4949702dba3bb1013b06f98f7637f1334511ce6286c620f40133b9196bfd08dd940a31df622d05593c2a4a19cd778521b2 WHIRLPOOL ab7449a894223caa445a0d1bb91a4afdcb1b4ca3b543666cee2e7047ebed607dd0c3477b1f42d92669e41f78942ec0c13bcfd501964187711cf935985fade340
+DIST Data-ICal-0.22.tar.gz 119116 SHA256 8ae9d20af244e5a6f606c7325e9d145dd0002676a178357af860a5e156925720 SHA512 a02364dfb0a1e24efcf2efdb7240bb6c47ad5ed3a99ada51ddb9817b4e433038d57113699c6875f7d592cd3af46f5b074a1ac50cf951b7af449bde1765ed5d55 WHIRLPOOL 326a08a554a86c7e0b9a182170d467bac4ec738014ae5e4bcffb43e8d848bbe3f884d9e006cf87d45d21f1ec24a2ebcf0d5f9b9f1e28f7ce3e340a284c07e177
diff --git a/dev-perl/Data-ICal/metadata.xml b/dev-perl/Data-ICal/metadata.xml
new file mode 100644
index 000000000000..be3ca50b500e
--- /dev/null
+++ b/dev-perl/Data-ICal/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Data-ICal</remote-id>
+ <remote-id type="cpan-module">Data::ICal</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::Alarm::Audio</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::Alarm::Display</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::Alarm::Email</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::Alarm::Procedure</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::Event</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::FreeBusy</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::Journal</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::TimeZone</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::TimeZone::Daylight</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::TimeZone::Standard</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Entry::Todo</remote-id>
+ <remote-id type="cpan-module">Data::ICal::Property</remote-id>
+ </upstream>
+</pkgmetadata>