summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/DateTime-Format-Flexible
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/DateTime-Format-Flexible')
-rw-r--r--dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.250.0.ebuild26
-rw-r--r--dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.260.0.ebuild32
-rw-r--r--dev-perl/DateTime-Format-Flexible/Manifest2
-rw-r--r--dev-perl/DateTime-Format-Flexible/metadata.xml13
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.250.0.ebuild b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.250.0.ebuild
new file mode 100644
index 000000000000..f4bad9c344e9
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.250.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=THINC
+MODULE_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Flexibly parse strings and turn them into DateTime objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/DateTime
+ >=dev-perl/DateTime-Format-Builder-0.74
+ dev-perl/DateTime-TimeZone
+ dev-perl/Module-Pluggable"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-MockTime
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.260.0.ebuild b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.260.0.ebuild
new file mode 100644
index 000000000000..c675380b8c17
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/DateTime-Format-Flexible-0.260.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=THINC
+MODULE_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Flexibly parse strings and turn them into DateTime objects"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/DateTime
+ >=dev-perl/DateTime-Format-Builder-0.740.0
+ dev-perl/DateTime-TimeZone
+ dev-perl/List-MoreUtils
+ dev-perl/Module-Pluggable
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-MockTime
+ >=virtual/perl-Test-Simple-0.440.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/DateTime-Format-Flexible/Manifest b/dev-perl/DateTime-Format-Flexible/Manifest
new file mode 100644
index 000000000000..e560b0f142a7
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/Manifest
@@ -0,0 +1,2 @@
+DIST DateTime-Format-Flexible-0.25.tar.gz 71657 SHA256 cd3267e68736ece386d677289b334d4ef1f33ff2524b17b9c9deb53d20420090 SHA512 c2cdd0dc682a7ef87f006c27c3822f92db658d187748852c2079b58a08fa527f83ed810e4b737dcc3d3de26eae7b89fb173ab2ffbc25935b868d01510fab8ca6 WHIRLPOOL f58636ceea745c268d96f396bd3a6920c2a0fedde53d8e3611bdd3cb5c6680d58c5cc8ce92782f09b9846000b8c7c32d434e97007cde501d6119badde594d17a
+DIST DateTime-Format-Flexible-0.26.tar.gz 71862 SHA256 436efbc5e87cc385112e1c44336427fea32df670caf2b7d6dbb7a113ac6e693d SHA512 70f5d50fd97bede5790853b526ee8150ab86592fa3f34ee16b0f26268c190052701f16510de6465ade46c647b5d1750f5c9cccf4b48ae7eac1455d6cadc015a3 WHIRLPOOL 7a8fcd095ad0a214a7f4e8c969b28538226a480548eee751a1043e2915bab21c6eab94710fe866edeae7c83d181a82d9c036eb4b7e642494b32ffa5e399f28d1
diff --git a/dev-perl/DateTime-Format-Flexible/metadata.xml b/dev-perl/DateTime-Format-Flexible/metadata.xml
new file mode 100644
index 000000000000..178942e727d6
--- /dev/null
+++ b/dev-perl/DateTime-Format-Flexible/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">DateTime-Format-Flexible</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang::de</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang::en</remote-id>
+ <remote-id type="cpan-module">DateTime::Format::Flexible::lang::es</remote-id>
+ </upstream>
+</pkgmetadata>