summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Debug-Client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Debug-Client')
-rw-r--r--dev-perl/Debug-Client/Debug-Client-0.200.0-r1.ebuild27
-rw-r--r--dev-perl/Debug-Client/Debug-Client-0.290.0.ebuild38
-rw-r--r--dev-perl/Debug-Client/Manifest2
-rw-r--r--dev-perl/Debug-Client/metadata.xml9
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-perl/Debug-Client/Debug-Client-0.200.0-r1.ebuild b/dev-perl/Debug-Client/Debug-Client-0.200.0-r1.ebuild
new file mode 100644
index 000000000000..be11c299280e
--- /dev/null
+++ b/dev-perl/Debug-Client/Debug-Client-0.200.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BOWTIE
+MODULE_VERSION=0.20
+inherit perl-module
+
+DESCRIPTION="Client side code for perl debugger"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ test? (
+ >=dev-perl/Test-Class-0.360.0
+ dev-perl/File-HomeDir
+ >=dev-perl/PadWalker-1.920.0
+ >=dev-perl/Test-Deep-0.108.0
+ >=dev-perl/Term-ReadLine-Perl-1.30.300
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/Debug-Client/Debug-Client-0.290.0.ebuild b/dev-perl/Debug-Client/Debug-Client-0.290.0.ebuild
new file mode 100644
index 000000000000..6cd48ba6a125
--- /dev/null
+++ b/dev-perl/Debug-Client/Debug-Client-0.290.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=BOWTIE
+MODULE_VERSION=0.29
+inherit perl-module
+
+DESCRIPTION="Client side code for perl debugger"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-IO-Socket-IP-0.210.0
+ >=dev-perl/PadWalker-1.960.0
+ >=dev-perl/Term-ReadLine-Gnu-1.200.0
+ >=virtual/perl-Term-ReadLine-1.100.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? (
+ >=dev-perl/File-HomeDir-1.0.0
+ >=virtual/perl-File-Temp-0.230.100
+ >=dev-perl/Test-CheckDeps-0.6.0
+ >=dev-perl/Test-Class-0.390.0
+ >=dev-perl/Test-Deep-0.110.0
+ >=dev-perl/Test-Requires-0.70.0
+ >=virtual/perl-File-Spec-3.400.0
+ >=dev-perl/PadWalker-1.920.0
+ >=dev-perl/Term-ReadLine-Perl-1.30.300
+ >=virtual/perl-version-0.990.220
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/Debug-Client/Manifest b/dev-perl/Debug-Client/Manifest
new file mode 100644
index 000000000000..72de2670878f
--- /dev/null
+++ b/dev-perl/Debug-Client/Manifest
@@ -0,0 +1,2 @@
+DIST Debug-Client-0.20.tar.gz 38741 SHA256 a1643b3c2e9fe0a39eae975c4ca81cb0cd44dde5dc0aec07600b727ebf190913 SHA512 53193a1575fcedc9ebc14a99e8b7d1ae12542f9085b7f303d6ef72f9f473cb4ff297f25deb3f75aa13e8963e203acbb2717c059d1ac61972f7d53f91db0f00dd WHIRLPOOL 35358b7fd2df0a001b4433882ab0728144883f24a2117b0a4d66e4374a1457e296e64852dc68b5b9e3a0f54b7a073f4d9368ef1e209e03c8f3e92a58c8d39452
+DIST Debug-Client-0.29.tar.gz 41615 SHA256 51f4ea6c6991221024a08b6106d4af1455452fae3b809b0bf0a208fbddb30efa SHA512 32c5adcc11cf32d729fd027e6cc5c2129d2375391cee4321b29a508029da3054fbc84fae4e84674bf0eac2740f431c9d41d3059e48e4e4963be4bdaa29ebd17e WHIRLPOOL 8af7b98c83c136bcfb9c1759c456a7ff0e6d45344f032a5ed634f91f2d288370943a7498d262c115fba00cd1ba745aec77fd668bcf905a9ac044711d032161b9
diff --git a/dev-perl/Debug-Client/metadata.xml b/dev-perl/Debug-Client/metadata.xml
new file mode 100644
index 000000000000..c4dacdc9063d
--- /dev/null
+++ b/dev-perl/Debug-Client/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Debug-Client</remote-id>
+ <remote-id type="cpan-module">Debug::Client</remote-id>
+ </upstream>
+</pkgmetadata>