summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Email-MIME
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Email-MIME')
-rw-r--r--dev-perl/Email-MIME/Email-MIME-1.926.0.ebuild34
-rw-r--r--dev-perl/Email-MIME/Email-MIME-1.929.0.ebuild40
-rw-r--r--dev-perl/Email-MIME/Manifest2
-rw-r--r--dev-perl/Email-MIME/metadata.xml12
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-perl/Email-MIME/Email-MIME-1.926.0.ebuild b/dev-perl/Email-MIME/Email-MIME-1.926.0.ebuild
new file mode 100644
index 000000000000..176b17154640
--- /dev/null
+++ b/dev-perl/Email-MIME/Email-MIME-1.926.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=1.926
+inherit perl-module
+
+DESCRIPTION="Easy MIME message parsing"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Email-MessageID
+ >=dev-perl/Email-MIME-Encodings-1.314.0
+ >=dev-perl/Email-MIME-ContentType-1.16.0
+ >=dev-perl/Email-Simple-2.102.0
+ >=dev-perl/MIME-Types-1.180.0
+ !dev-perl/Email-MIME-Modifier
+ !dev-perl/Email-MIME-Creator
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Email-MIME/Email-MIME-1.929.0.ebuild b/dev-perl/Email-MIME/Email-MIME-1.929.0.ebuild
new file mode 100644
index 000000000000..0e4de50bee35
--- /dev/null
+++ b/dev-perl/Email-MIME/Email-MIME-1.929.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=1.929
+inherit perl-module
+
+DESCRIPTION="Easy MIME message parsing"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Email-Address
+ >=dev-perl/Email-MIME-ContentType-1.16.0
+ >=dev-perl/Email-MIME-Encodings-1.314.0
+ dev-perl/Email-MessageID
+ >=dev-perl/Email-Simple-2.102.0
+ >=virtual/perl-Encode-1.980.100
+ virtual/perl-MIME-Base64
+ >=dev-perl/MIME-Types-1.180.0
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.960.0
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Email-MIME/Manifest b/dev-perl/Email-MIME/Manifest
new file mode 100644
index 000000000000..8500d0eaf6c4
--- /dev/null
+++ b/dev-perl/Email-MIME/Manifest
@@ -0,0 +1,2 @@
+DIST Email-MIME-1.926.tar.gz 111817 SHA256 458b8dd539827a671352f4e9c759322e74e630b8e934fc942dbc06525a7d01a2 SHA512 79eb9e98dcfda1fdd023ab7c42fe151cb9fc482844648be9bd9cbb73cc9583f1a78f8aa5e056e3c45a63fbe87db2aaafd7d460481697e22e787286f929807db3 WHIRLPOOL e2c3c876df7a9852794f3c99ef346b1e0bcf8b2ae158ad05fc203576d9154414f0428e59241b12987cfe38098fd699001f3dfdf634e28b181041134ad2182470
+DIST Email-MIME-1.929.tar.gz 115105 SHA256 b0c9267bd9266e40671c2080782f7303cb17b4e93bd066b8677137f21a6dc7e9 SHA512 13a2591de92720dd3f8f798e442cf65c391d38e2a6d1e72d87c9301e8e3b2aa8fc1c8e3cfbcb829f14844bde59575a03ef7eb535741624e4dc8f3575c4089697 WHIRLPOOL bd89adfe87ea78604c860730ef76f6f69c2e97512075445264f05297d08ae977ff76c48ee6d89c05760d3811126aebe89b985dcd1246e6d2065770f774f4f709
diff --git a/dev-perl/Email-MIME/metadata.xml b/dev-perl/Email-MIME/metadata.xml
new file mode 100644
index 000000000000..b7fd347f2bd2
--- /dev/null
+++ b/dev-perl/Email-MIME/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Email-MIME</remote-id>
+ <remote-id type="cpan-module">Email::MIME</remote-id>
+ <remote-id type="cpan-module">Email::MIME::Creator</remote-id>
+ <remote-id type="cpan-module">Email::MIME::Header</remote-id>
+ <remote-id type="cpan-module">Email::MIME::Modifier</remote-id>
+ </upstream>
+</pkgmetadata>