summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Email-Simple
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Email-Simple')
-rw-r--r--dev-perl/Email-Simple/Email-Simple-2.203.ebuild28
-rw-r--r--dev-perl/Email-Simple/Email-Simple-2.206.ebuild32
-rw-r--r--dev-perl/Email-Simple/Manifest2
-rw-r--r--dev-perl/Email-Simple/metadata.xml11
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-perl/Email-Simple/Email-Simple-2.203.ebuild b/dev-perl/Email-Simple/Email-Simple-2.203.ebuild
new file mode 100644
index 000000000000..03d0a5ffb6e9
--- /dev/null
+++ b/dev-perl/Email-Simple/Email-Simple-2.203.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=2.203
+inherit perl-module
+
+DESCRIPTION="Simple parsing of RFC2822 message format and headers"
+
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-perl/Email-Date-Format"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ virtual/perl-Test-Simple
+ dev-perl/Capture-Tiny
+ )"
+RDEPEND="${RDEPEND}
+ !dev-perl/Email-Simple-Creator"
+
+SRC_TEST="do"
diff --git a/dev-perl/Email-Simple/Email-Simple-2.206.ebuild b/dev-perl/Email-Simple/Email-Simple-2.206.ebuild
new file mode 100644
index 000000000000..f5c5a43e655a
--- /dev/null
+++ b/dev-perl/Email-Simple/Email-Simple-2.206.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJBS
+MODULE_VERSION=2.206
+inherit perl-module
+
+DESCRIPTION="Simple parsing of RFC2822 message format and headers"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Email-Date-Format
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ >=virtual/perl-Test-Simple-0.960.0
+ virtual/perl-File-Spec
+ dev-perl/Capture-Tiny
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Email-Simple/Manifest b/dev-perl/Email-Simple/Manifest
new file mode 100644
index 000000000000..81e53edc3e14
--- /dev/null
+++ b/dev-perl/Email-Simple/Manifest
@@ -0,0 +1,2 @@
+DIST Email-Simple-2.203.tar.gz 34856 SHA256 a528d7531ff773e80d79e0d30b1845ee453561c5f060623397a609e315baeb43 SHA512 69dbacb379dac96d478e9fb98b11de724516e9d591b09a5f1f3866c3c3fc23458d0914271f52b2625b18cc06f229a20a7711341a88616b27c9ed5843a25786d1 WHIRLPOOL 61a4b7f3707b637f5c39cd39d174347c61c3e1ee042d75391daaa3c9d876609222d1a702d7a6ba87e340c71484b1e7ef858566468e49b21a36a8a55893ebe068
+DIST Email-Simple-2.206.tar.gz 37604 SHA256 42147dbe8ed9fbe4c8b02bc89491016880225444ec3219384e53285be4f0b7a5 SHA512 4980247a98e7192b47f7307245b66056e5e6a1fb684c262be6121d094c75e57b69884817b121ad632d515a4f06275ac91e716cbec400ce6a51a60433a0fbbbe1 WHIRLPOOL 5c33ff5ee33a016dee64740b81ca4491455183c8b324766fbd89eae3ca1a385fdd0c5a4c96992bac8c04637bce2d8a67d9ba58970144b214c7d9f0cfb617997e
diff --git a/dev-perl/Email-Simple/metadata.xml b/dev-perl/Email-Simple/metadata.xml
new file mode 100644
index 000000000000..acc7ce20bb15
--- /dev/null
+++ b/dev-perl/Email-Simple/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Email-Simple</remote-id>
+ <remote-id type="cpan-module">Email::Simple</remote-id>
+ <remote-id type="cpan-module">Email::Simple::Creator</remote-id>
+ <remote-id type="cpan-module">Email::Simple::Header</remote-id>
+ </upstream>
+</pkgmetadata>