summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Eval-Closure
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Eval-Closure')
-rw-r--r--dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild39
-rw-r--r--dev-perl/Eval-Closure/Eval-Closure-0.80.0-r1.ebuild29
-rw-r--r--dev-perl/Eval-Closure/Manifest2
-rw-r--r--dev-perl/Eval-Closure/metadata.xml9
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild b/dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild
new file mode 100644
index 000000000000..a54d5d8c7b6c
--- /dev/null
+++ b/dev-perl/Eval-Closure/Eval-Closure-0.130.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="safely and cleanly create closures via string eval"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x64-macos"
+IUSE="test minimal"
+
+# Scalar::Util -> Scalar-List-Utils
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ !minimal? (
+ >=dev-perl/Devel-LexAlias-0.50.0
+ dev-perl/perltidy
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ virtual/perl-IO
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Eval-Closure/Eval-Closure-0.80.0-r1.ebuild b/dev-perl/Eval-Closure/Eval-Closure-0.80.0-r1.ebuild
new file mode 100644
index 000000000000..c0aa6a5432f6
--- /dev/null
+++ b/dev-perl/Eval-Closure/Eval-Closure-0.80.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.08
+inherit perl-module
+
+DESCRIPTION="safely and cleanly create closures via string eval"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc ~ppc64 x86 ~x86-fbsd ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Sub-Exporter
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Output
+ dev-perl/Test-Requires
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Eval-Closure/Manifest b/dev-perl/Eval-Closure/Manifest
new file mode 100644
index 000000000000..4aed3102759b
--- /dev/null
+++ b/dev-perl/Eval-Closure/Manifest
@@ -0,0 +1,2 @@
+DIST Eval-Closure-0.08.tar.gz 16746 SHA256 738ce424d68ce1ac93c0b1539d6740ac8fff81fdd06ef7e4c8b022296922a407 SHA512 0e6edd318f52f9f324dfddb003b0825c748d688fecb041e61a8aa1645d3bfcdfc6968b782ecd7e3b0892d4db3160048a2319cbf0dc16086bf6005ffec24250bf WHIRLPOOL 6661da045a2e0e2c9f41c68becb765ac44bc55327048880a5590559a301fa13f66b1f7ccce6f416fbca1f54321b967480855d18043026cbc12c21213a8981a07
+DIST Eval-Closure-0.13.tar.gz 19735 SHA256 65bec0368e8f0631a24bf6dc6dd24d2d8d485350e406d20005db2c6aa1c0445d SHA512 f87d8aa8af5f87611f95a8f1f44f9c403ab669f944b3a63a9f8ca6a80075ed957f0050bd57b2076581bc47fa57b710712ed9e3abe5670a1881b12dd674414f89 WHIRLPOOL 7e187b94cfaaa5da2cb25cff3d7195b91f563303e7f17471dc2a22afaacd1fc382aadf7e998762f51842367d56eef8536514c3f33cb0bd2503c7cbffbee2dc8d
diff --git a/dev-perl/Eval-Closure/metadata.xml b/dev-perl/Eval-Closure/metadata.xml
new file mode 100644
index 000000000000..96ba05dc0098
--- /dev/null
+++ b/dev-perl/Eval-Closure/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Eval-Closure</remote-id>
+ <remote-id type="cpan-module">Eval::Closure</remote-id>
+ </upstream>
+</pkgmetadata>