summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Exception-Class
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Exception-Class')
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild26
-rw-r--r--dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild30
-rw-r--r--dev-perl/Exception-Class/Manifest2
-rw-r--r--dev-perl/Exception-Class/metadata.xml10
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild b/dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild
new file mode 100644
index 000000000000..fae2702f8256
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.370.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.37
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ~ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-1.200.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.310.0
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
new file mode 100644
index 000000000000..1ffe91d9d457
--- /dev/null
+++ b/dev-perl/Exception-Class/Exception-Class-1.390.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=1.39
+inherit perl-module
+
+DESCRIPTION="A module that allows you to declare real exception classes in Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Data-Inheritable-0.20.0
+ >=dev-perl/Devel-StackTrace-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Exception-Class/Manifest b/dev-perl/Exception-Class/Manifest
new file mode 100644
index 000000000000..c1659ee71a10
--- /dev/null
+++ b/dev-perl/Exception-Class/Manifest
@@ -0,0 +1,2 @@
+DIST Exception-Class-1.37.tar.gz 26457 SHA256 838b93c90a0bbd73d819dc7d3d854559880120b6878976fe2ab90a141d10cedc SHA512 611895065102e4dfb40667841af0aaec436128deba8b52627b50320ddfcc191ca1c83a5084f7c4de582137790b1527791bbcfea93b24bc5095f1150a9d6bae3e WHIRLPOOL a7ee68032f1f691053cc1eb5d7b710f4e528b1f3ba994fdd5cf3e8a3bd958bbb39fdd1ad2de7924c2a85e3a08044e1df43fca009d8297af578b4c649a9e46afe
+DIST Exception-Class-1.39.tar.gz 38936 SHA256 819c756a69a6d1e31f396eca6a508b07b0a522a035b904cd1d432353cc362083 SHA512 c290a0b87b7a5e288c6c954f7ab834204184edc81089f871f1eb994d1445e3938170c1e87119fd952177dd43a3a228522188282fb0151ae33ba3a55b29a28b50 WHIRLPOOL 35bdb9adbb2565703b42d91897d5c698b1d1d378fa7ae11547cccfa844a251644667947403994158b02bdc6e32b830d7d02c4b7d6f154e7fb0125b8030bd3d52
diff --git a/dev-perl/Exception-Class/metadata.xml b/dev-perl/Exception-Class/metadata.xml
new file mode 100644
index 000000000000..654c23483a25
--- /dev/null
+++ b/dev-perl/Exception-Class/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Exception-Class</remote-id>
+ <remote-id type="cpan-module">Exception::Class</remote-id>
+ <remote-id type="cpan-module">Exception::Class::Base</remote-id>
+ </upstream>
+</pkgmetadata>