summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/HTML-FillInForm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/HTML-FillInForm')
-rw-r--r--dev-perl/HTML-FillInForm/HTML-FillInForm-2.200.0-r1.ebuild20
-rw-r--r--dev-perl/HTML-FillInForm/HTML-FillInForm-2.210.0.ebuild27
-rw-r--r--dev-perl/HTML-FillInForm/Manifest2
-rw-r--r--dev-perl/HTML-FillInForm/metadata.xml9
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-perl/HTML-FillInForm/HTML-FillInForm-2.200.0-r1.ebuild b/dev-perl/HTML-FillInForm/HTML-FillInForm-2.200.0-r1.ebuild
new file mode 100644
index 000000000000..24bf53345918
--- /dev/null
+++ b/dev-perl/HTML-FillInForm/HTML-FillInForm-2.200.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MARKSTOS
+MODULE_VERSION=2.20
+inherit perl-module
+
+DESCRIPTION="Populates HTML Forms with data"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="dev-perl/HTML-Parser"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/HTML-FillInForm/HTML-FillInForm-2.210.0.ebuild b/dev-perl/HTML-FillInForm/HTML-FillInForm-2.210.0.ebuild
new file mode 100644
index 000000000000..966414cd9398
--- /dev/null
+++ b/dev-perl/HTML-FillInForm/HTML-FillInForm-2.210.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MARKSTOS
+MODULE_VERSION=2.21
+inherit perl-module
+
+DESCRIPTION="Populates HTML Forms with data"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/HTML-Parser
+ virtual/perl-Carp
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( dev-perl/CGI )
+"
+# the dep specs are rather incomplete
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/HTML-FillInForm/Manifest b/dev-perl/HTML-FillInForm/Manifest
new file mode 100644
index 000000000000..1d9ce0cfd97c
--- /dev/null
+++ b/dev-perl/HTML-FillInForm/Manifest
@@ -0,0 +1,2 @@
+DIST HTML-FillInForm-2.20.tar.gz 17309 SHA256 75e1125e32fb218d5aceddb7f6ffdd49edf16ff438571ab0fd4866a52fc7ec5b SHA512 d00955fae1d9602ccda79e42e4a2863cb04b7070d72bdfe383b3b68ac56cf0a629bf2cbea35aaa042a379fe1c9679d7905407454d0e6c19433f6821dfbd27ebd WHIRLPOOL d60f5118b2e16115e5e1316c72b41a9583334261e18fa1299ba78b9d5fa641fa775283ae734e11f099e43a850fba403d817f679b183332dbc48a47f04e4d82b3
+DIST HTML-FillInForm-2.21.tar.gz 17823 SHA256 d3af183cc8327614f1192929f4f0919b6e9725fc19c6f3730ce556a8daea6cf6 SHA512 05a755635478a797c4711e812a7fbd0428e61b4a4dbb3f8b62ed929122bb4b138aa3d86f2d99ace01d9e7f9486663e64b2c50490d0084c861cbdf8c25645be96 WHIRLPOOL 2f89df5e337e11ea9c327de5afaeca18b845b77d437f1fa139681ccb3be1495fe58852728a94debedee3f36483a2b30f3f5a14733b7f3c90b391a021a416ec0e
diff --git a/dev-perl/HTML-FillInForm/metadata.xml b/dev-perl/HTML-FillInForm/metadata.xml
new file mode 100644
index 000000000000..521ac2789563
--- /dev/null
+++ b/dev-perl/HTML-FillInForm/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">HTML-FillInForm</remote-id>
+ <remote-id type="cpan-module">HTML::FillInForm</remote-id>
+ </upstream>
+</pkgmetadata>