summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/JavaScript-Packer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/JavaScript-Packer')
-rw-r--r--dev-perl/JavaScript-Packer/JavaScript-Packer-1.6.3.ebuild23
-rw-r--r--dev-perl/JavaScript-Packer/JavaScript-Packer-2.0.0.ebuild23
-rw-r--r--dev-perl/JavaScript-Packer/Manifest2
-rw-r--r--dev-perl/JavaScript-Packer/metadata.xml9
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-perl/JavaScript-Packer/JavaScript-Packer-1.6.3.ebuild b/dev-perl/JavaScript-Packer/JavaScript-Packer-1.6.3.ebuild
new file mode 100644
index 000000000000..59fd2d038ebc
--- /dev/null
+++ b/dev-perl/JavaScript-Packer/JavaScript-Packer-1.6.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=NEVESENIN
+MODULE_VERSION=1.006003
+inherit perl-module
+
+DESCRIPTION="Perl version of Dean Edward's Packer.js"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Regexp-RegGrp-1.1.1_rc
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.560.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/JavaScript-Packer/JavaScript-Packer-2.0.0.ebuild b/dev-perl/JavaScript-Packer/JavaScript-Packer-2.0.0.ebuild
new file mode 100644
index 000000000000..a097a4953301
--- /dev/null
+++ b/dev-perl/JavaScript-Packer/JavaScript-Packer-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=LEEJO
+MODULE_VERSION=2.00
+inherit perl-module
+
+DESCRIPTION="Perl version of Dean Edward's Packer.js"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Regexp-RegGrp-1.1.1_rc
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.590.0
+ test? ( virtual/perl-Test-Simple )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/JavaScript-Packer/Manifest b/dev-perl/JavaScript-Packer/Manifest
new file mode 100644
index 000000000000..2bfde6b17979
--- /dev/null
+++ b/dev-perl/JavaScript-Packer/Manifest
@@ -0,0 +1,2 @@
+DIST JavaScript-Packer-1.006003.tar.gz 38203 SHA256 296b67d1fd8ec9c56bea97d54b8830b24511f9a238f5379d1aa928418c127f82 SHA512 c1d43d25a5e2bdc4476d7c1643d5edc7dc5f63a488759fcf0168e43b072f0504c8520341e8d13d406135d1d46cb5622cae687ddfaa5013ee34732b1aaf4b6762 WHIRLPOOL ce1814586ff809d3598d9b73737a4e4100a984a83074c051e1fdf5d9a7cb424aba9b7ca301e402a6305b3a8c437e9fc8b397047fe65bb93b0b51e95d13f7b021
+DIST JavaScript-Packer-2.00.tar.gz 39926 SHA256 cad4a84ecd2e5d59275d38b9f305c29582a48614cc35a8c871c0cf22356c5b7e SHA512 7989741ed291bf1b695e742aba88db051246d8e3410128ee8e4b297c80b207c171f708ebc9693773373db41fc90b515a416fc2ecf6de3584b5d1dcd5df2c65dc WHIRLPOOL fa9fdcd7c4df464585312e1b89f9cdece143a3d0944a2c63a76235691cbf90342daa472f9c81ebafda7a4be71ed91ad9c28678e941a19391f55173d2026ed926
diff --git a/dev-perl/JavaScript-Packer/metadata.xml b/dev-perl/JavaScript-Packer/metadata.xml
new file mode 100644
index 000000000000..ad2c6dd3face
--- /dev/null
+++ b/dev-perl/JavaScript-Packer/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">JavaScript-Packer</remote-id>
+ <remote-id type="cpan-module">JavaScript::Packer</remote-id>
+ </upstream>
+</pkgmetadata>