summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Module-Build-Tiny
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Module-Build-Tiny')
-rw-r--r--dev-perl/Module-Build-Tiny/Manifest2
-rw-r--r--dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.37.0.ebuild45
-rw-r--r--dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.39.0.ebuild45
-rw-r--r--dev-perl/Module-Build-Tiny/metadata.xml9
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-perl/Module-Build-Tiny/Manifest b/dev-perl/Module-Build-Tiny/Manifest
new file mode 100644
index 000000000000..b0c2a7c452d9
--- /dev/null
+++ b/dev-perl/Module-Build-Tiny/Manifest
@@ -0,0 +1,2 @@
+DIST Module-Build-Tiny-0.037.tar.gz 20507 SHA256 25dd7246b071d7a4e62a410ca3fc18c3e2cfb82440324fa97d472b493dd60ec0 SHA512 8cabff83ad84f2d5ba8444ae9f4928ce82d1a375baf524d1eab9e00fef10b7e3f5c72dd0a76ccae85c2b165048037fa9714d94d4a3ad88e66193449a7e8285c9 WHIRLPOOL b52c16df071ee7fe3c783407f60955a7c799842a5aba3608f960083b5cc9400a9c1151783e6267cc62a0106925f3f4caa4a01132cbe130b4a5f8c23ba5f2accb
+DIST Module-Build-Tiny-0.039.tar.gz 20663 SHA256 7d580ff6ace0cbe555bf36b86dc8ea232581530cbeaaea09bccb57b55797f11c SHA512 26ca6fe4c1792b26bb2b4711035847f4215ea7c37234fbe24fc07432682fd9d3b6016dbdb2ecb455a7b13f6bea13994826c7f84f21075f0a6e575fa74672903a WHIRLPOOL d63374b589ccd71b0b78e6aaa7f93c2c5a439f10e127b0fba8544e394a1bce8ed32c54b50ce0d8fd5165ebd25ef3d58dc8910d2db89390c9edfbc3b55f4f8774
diff --git a/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.37.0.ebuild b/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.37.0.ebuild
new file mode 100644
index 000000000000..c0c8dc29aa44
--- /dev/null
+++ b/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.37.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.037
+inherit perl-module
+
+DESCRIPTION='A tiny replacement for Module::Build'
+LICENSE=" || ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-CPAN-Meta
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Config-0.3.0
+ >=dev-perl/ExtUtils-Helpers-0.20.0
+ virtual/perl-ExtUtils-Install
+ >=dev-perl/ExtUtils-InstallPaths-0.2.0
+ virtual/perl-ExtUtils-ParseXS
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ >=virtual/perl-Getopt-Long-2.360.0
+ >=virtual/perl-JSON-PP-2.0.0
+ virtual/perl-podlators
+ virtual/perl-Test-Harness
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.88
+ virtual/perl-XSLoader
+ )
+"
+
+SRC_TEST="do parallel"
+
+mytargets="install"
diff --git a/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.39.0.ebuild b/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.39.0.ebuild
new file mode 100644
index 000000000000..df654b581a37
--- /dev/null
+++ b/dev-perl/Module-Build-Tiny/Module-Build-Tiny-0.39.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.039
+inherit perl-module
+
+DESCRIPTION='A tiny replacement for Module::Build'
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-CPAN-Meta
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-ExtUtils-CBuilder
+ >=dev-perl/ExtUtils-Config-0.3.0
+ >=dev-perl/ExtUtils-Helpers-0.20.0
+ virtual/perl-ExtUtils-Install
+ >=dev-perl/ExtUtils-InstallPaths-0.2.0
+ virtual/perl-ExtUtils-ParseXS
+ virtual/perl-File-Path
+ virtual/perl-File-Spec
+ >=virtual/perl-Getopt-Long-2.360.0
+ >=virtual/perl-JSON-PP-2.0.0
+ virtual/perl-podlators
+ virtual/perl-Test-Harness
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ >=virtual/perl-Test-Simple-0.88
+ virtual/perl-XSLoader
+ )
+"
+
+SRC_TEST="do parallel"
+
+mytargets="install"
diff --git a/dev-perl/Module-Build-Tiny/metadata.xml b/dev-perl/Module-Build-Tiny/metadata.xml
new file mode 100644
index 000000000000..f6a12b7bed2e
--- /dev/null
+++ b/dev-perl/Module-Build-Tiny/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Module-Build-Tiny</remote-id>
+ <remote-id type="cpan-module">Module::Build::Tiny</remote-id>
+ </upstream>
+</pkgmetadata>