summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Module-Runtime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Module-Runtime')
-rw-r--r--dev-perl/Module-Runtime/Manifest2
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.13.0-r1.ebuild27
-rw-r--r--dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild27
-rw-r--r--dev-perl/Module-Runtime/metadata.xml9
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-perl/Module-Runtime/Manifest b/dev-perl/Module-Runtime/Manifest
new file mode 100644
index 000000000000..c54446f18249
--- /dev/null
+++ b/dev-perl/Module-Runtime/Manifest
@@ -0,0 +1,2 @@
+DIST Module-Runtime-0.013.tar.gz 15849 SHA256 ec37e03d90dc905679dab62a82f42cf0897ed79244b87fd9d531438dc3c31023 SHA512 4e8ad61d27d9e269a26a7da4905fcfb2bcc4d775ca1bcddd96f14e8238c725ff8c916dfc8e6faebad5d42c3a0a8eb7d264298471b0cc65d972b5d344a6b9a339 WHIRLPOOL 2d81c860868e44df0f791f6f59d0efdf7d998c364ea7dbbea1673dfe2ea5eef93719001514979dbc90c7c561a59019e3d08e2f797b9f9abd6237925b161c96f5
+DIST Module-Runtime-0.014.tar.gz 17396 SHA256 4c44fe0ea255a9fd00741ee545063f6692d2a28e7ef2fbaad1b24a92803362a4 SHA512 5431d9aeb092bb357bafed4e4cf216e9eda4bbbdd0c27547a1729adbb2f6f5a114ac25580a814f2d07844d6b742b9df3ca8d5972668bcacab2f791d617c1d32b WHIRLPOOL 3a790f8db9061a24941c6a61781f1f53c176f8d3a92ac327290296400454ba2605e09c3efeef24ed0a3c62428af14f287baea46661a3ce16e6e7ac5fcee99d6c
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.13.0-r1.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..b7b95451bbed
--- /dev/null
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.13.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ZEFRAM
+MODULE_VERSION=0.013
+inherit perl-module
+
+DESCRIPTION="Runtime module handling"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild b/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
new file mode 100644
index 000000000000..1844ccc7fbaf
--- /dev/null
+++ b/dev-perl/Module-Runtime/Module-Runtime-0.14.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ZEFRAM
+MODULE_VERSION=0.014
+inherit perl-module
+
+DESCRIPTION="Runtime module handling"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Module-Runtime/metadata.xml b/dev-perl/Module-Runtime/metadata.xml
new file mode 100644
index 000000000000..335785b16068
--- /dev/null
+++ b/dev-perl/Module-Runtime/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Module-Runtime</remote-id>
+ <remote-id type="cpan-module">Module::Runtime</remote-id>
+ </upstream>
+</pkgmetadata>