summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/MusicBrainz-DiscID
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/MusicBrainz-DiscID')
-rw-r--r--dev-perl/MusicBrainz-DiscID/Manifest2
-rw-r--r--dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild48
-rw-r--r--dev-perl/MusicBrainz-DiscID/metadata.xml10
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-perl/MusicBrainz-DiscID/Manifest b/dev-perl/MusicBrainz-DiscID/Manifest
new file mode 100644
index 000000000000..2f9bfdff7399
--- /dev/null
+++ b/dev-perl/MusicBrainz-DiscID/Manifest
@@ -0,0 +1,2 @@
+DIST MusicBrainz-DiscID-0.03.tar.gz 5343 SHA256 5002f92fd8f074bccf924752ef171fa11ea2431a634ff60e520a5c3fb080573a SHA512 b3fa392a669a9370369ea7ade275edb30b15c8b15b1ebeefb567d8e183e195b255e7e087025a7ebc17b39f7d7ba9a310dfa17c616426e8d092c129c0c58ddfc8 WHIRLPOOL 75c6df0a793d759b526708ab5f36b657889ec043eeef7423c53cb117d62d8d2b9bceed4ea00daf11ed8d6de61ef341c86224212a291b8db7e6f50e9038790e32
+DIST MusicBrainz-DiscID-0.30.0-patch.tar.bz2 412 SHA256 df9f1027a62f070b5b489d71fee2ab928bdf514aaa818608eb0e563700e60bfa SHA512 79163ba28285676f585af2be0a12a6210a8869c57cad5bba1ec42121f9e1dc351ac2f51b9a702133a71fbaf1d3207e8ea153564f838ffc5d39b60268af7bf726 WHIRLPOOL 72becb03a3c0821f7f45730184aa8aac5ec0607d5c48c93de0f0b01129d5d3d45fe3fa551209002475b737f30ef1106d7e57447eed5b8b14541cd7acb1dec07d
diff --git a/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild b/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild
new file mode 100644
index 000000000000..6faaee10c237
--- /dev/null
+++ b/dev-perl/MusicBrainz-DiscID/MusicBrainz-DiscID-0.30.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NJH
+MODULE_VERSION=0.03
+inherit perl-module
+
+DESCRIPTION="Perl interface for the MusicBrainz libdiscid library"
+SRC_URI+=" http://dev.gentoo.org/~tove/distfiles/${CATEGORY}/${PN}/${P}-patch.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="test"
+
+RDEPEND=">=media-libs/libdiscid-0.2.2"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ virtual/pkgconfig
+ test? (
+ dev-perl/Test-Pod
+ virtual/perl-Test-Simple
+ )
+"
+
+SRC_TEST="do"
+PERL_RM_FILES=( t/05pod.t )
+
+src_prepare() {
+ # Quick n dirty fix but does the job.
+ ebegin 'Patching lib/MusicBrainz/DiscID.pm'
+ # There's a dangling non-ASCII character that causes perldoc to fail on
+ # parsing the .pm and hence, fail tests. We should file a bug upstream.
+ perl -i'' -npe "s/don.. specify/don't specify/g;" lib/MusicBrainz/DiscID.pm
+ eend $?
+
+ perl-module_src_prepare
+}
+
+src_install() {
+ perl-module_src_install
+
+ docinto examples
+ dodoc examples/discid.pl
+}
diff --git a/dev-perl/MusicBrainz-DiscID/metadata.xml b/dev-perl/MusicBrainz-DiscID/metadata.xml
new file mode 100644
index 000000000000..a40ce4720dfa
--- /dev/null
+++ b/dev-perl/MusicBrainz-DiscID/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>perl</herd>
+<herd>sound</herd>
+<upstream>
+<remote-id type="cpan">MusicBrainz-DiscID</remote-id>
+<remote-id type="cpan-module">MusicBrainz::DiscID</remote-id>
+</upstream>
+</pkgmetadata>