summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-DNS
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-DNS')
-rw-r--r--dev-perl/Net-DNS/Manifest2
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.740.0.ebuild46
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild46
-rw-r--r--dev-perl/Net-DNS/files/Net-DNS-0.64-ar.patch13
-rw-r--r--dev-perl/Net-DNS/files/Net-DNS-0.68-ar.patch16
-rw-r--r--dev-perl/Net-DNS/metadata.xml78
6 files changed, 201 insertions, 0 deletions
diff --git a/dev-perl/Net-DNS/Manifest b/dev-perl/Net-DNS/Manifest
new file mode 100644
index 000000000000..70ad7bb16502
--- /dev/null
+++ b/dev-perl/Net-DNS/Manifest
@@ -0,0 +1,2 @@
+DIST Net-DNS-0.74.tar.gz 200829 SHA256 ef64af502e94f2d0e0a672ab951d846fd1406544eca596a86943bc8f2da19c32 SHA512 f0bb5482247c9b01dc6e704d1d6f93881b209001d5b43488c453f24b48ddbb07aefa4bb8e71d1d61f3f5d81ad918627f66e56a8a14d2d9adcccf0fe1af15389d WHIRLPOOL dd15330e82b2d06867cae1461d6115b9545aaf0042e9c7e674022330870f18fbf2af4349fb3350bd755e35cdaca6437258ce39293d2f0cd6665b4ad8372babd7
+DIST Net-DNS-0.81.tar.gz 197700 SHA256 b36c8ead6edf68da5d9de2b0a22a47d7216e2d7eb52c8cde96724988f68a6d46 SHA512 594d1de98012d7f364f3e9300c0904dc09deb4589cf40cd7c1377da11f7c9203b0171d7eb1f299c3aa519c2f595e644ef960703808d4a42818706dfc7ac7bf53 WHIRLPOOL 0f24e0e53c19a387f75975ddfbc6ecb071c8e28a2b86a687cadbfd7ac218c835ad3db294a1d2f1cda9c9a2c8c45701a9cd7ba1578193f224aeed3d3f85e8df4b
diff --git a/dev-perl/Net-DNS/Net-DNS-0.740.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.740.0.ebuild
new file mode 100644
index 000000000000..fc11a4b7cdc5
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-0.740.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NLNETLABS
+MODULE_VERSION=0.74
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6 test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-SHA
+ dev-perl/Net-IP
+ virtual/perl-MIME-Base64
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ )"
+
+PATCHES=( ${FILESDIR}/${PN}-0.68-ar.patch )
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
diff --git a/dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild
new file mode 100644
index 000000000000..881772bd8f95
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=NLNETLABS
+MODULE_VERSION=0.81
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6 test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-SHA
+ dev-perl/Net-IP
+ virtual/perl-MIME-Base64
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ )"
+
+PATCHES=( ${FILESDIR}/${PN}-0.68-ar.patch )
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}
diff --git a/dev-perl/Net-DNS/files/Net-DNS-0.64-ar.patch b/dev-perl/Net-DNS/files/Net-DNS-0.64-ar.patch
new file mode 100644
index 000000000000..5f55eddbd277
--- /dev/null
+++ b/dev-perl/Net-DNS/files/Net-DNS-0.64-ar.patch
@@ -0,0 +1,13 @@
+The linker on Darwin/x86 needs archives with an index, so create one.
+
+--- Makefile.PL
++++ Makefile.PL
+@@ -260,7 +260,7 @@
+ cover
+
+ netdns$(LIB_EXT): netdns$(OBJ_EXT)
+- $(AR) '.($^O eq 'MSWin32' && $Config{'cc'} eq 'cl'?'/OUT:':'cr ').
++ $(AR) '.($^O eq 'MSWin32' && $Config{'cc'} eq 'cl'?'/OUT:':'crs ').
+ 'netdns$(LIB_EXT) netdns$(OBJ_EXT)
+
+ ';
diff --git a/dev-perl/Net-DNS/files/Net-DNS-0.68-ar.patch b/dev-perl/Net-DNS/files/Net-DNS-0.68-ar.patch
new file mode 100644
index 000000000000..cad63fadf024
--- /dev/null
+++ b/dev-perl/Net-DNS/files/Net-DNS-0.68-ar.patch
@@ -0,0 +1,16 @@
+The linker on Darwin/x86 needs archives with an index, so create one.
+
+Ported-from: files/Net-DNS-0.64-ar.patch
+
+diff -Nuar Net-DNS-0.68.orig/Makefile.PL Net-DNS-0.68/Makefile.PL
+--- Net-DNS-0.68.orig/Makefile.PL 2012-01-27 23:02:34.000000000 +0000
++++ Net-DNS-0.68/Makefile.PL 2012-02-29 09:03:14.939727214 +0000
+@@ -336,7 +336,7 @@
+ use Config qw(%Config);
+
+ sub postamble {
+- my $cr = ( $^O eq 'MSWin32' && $Config{'cc'} eq 'cl' ? '/OUT:' : 'cr ' ); # ar action
++ my $cr = ( $^O eq 'MSWin32' && $Config{'cc'} eq 'cl' ? '/OUT:' : 'crs ' ); # ar action
+
+ my $content = '
+ test_cover : pure_all
diff --git a/dev-perl/Net-DNS/metadata.xml b/dev-perl/Net-DNS/metadata.xml
new file mode 100644
index 000000000000..07fd53dc36f7
--- /dev/null
+++ b/dev-perl/Net-DNS/metadata.xml
@@ -0,0 +1,78 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-DNS</remote-id>
+ <remote-id type="cpan-module">Net::DNS</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Domain</remote-id>
+ <remote-id type="cpan-module">Net::DNS::DomainName</remote-id>
+ <remote-id type="cpan-module">Net::DNS::DomainName1035</remote-id>
+ <remote-id type="cpan-module">Net::DNS::DomainName2535</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Header</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Mailbox</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Mailbox1035</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Mailbox2535</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Nameserver</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Packet</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Parameters</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Question</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::A</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::AAAA</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::AFSDB</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::APL</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::APL::Item</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::CERT</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::CNAME</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::DHCID</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::DNAME</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::EID</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::HINFO</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::HIP</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::IPSECKEY</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::ISDN</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::KX</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::L32</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::L64</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::LOC</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::LP</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::MB</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::MG</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::MINFO</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::MR</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::MX</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NAPTR</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NID</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NIMLOC</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NS</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NSAP</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::NULL</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::OPT</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::PTR</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::PX</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::RP</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::RT</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::SOA</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::SPF</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::SRV</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::SSHFP</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::TKEY</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::TLSA</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::TSIG</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::TXT</remote-id>
+ <remote-id type="cpan-module">Net::DNS::RR::X25</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver::Base</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver::MSWin32</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver::Recurse</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver::UNIX</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver::cygwin</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Resolver::os2</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Text</remote-id>
+ <remote-id type="cpan-module">Net::DNS::Update</remote-id>
+ <remote-id type="cpan-module">Net::DNS::ZoneFile</remote-id>
+ <remote-id type="cpan-module">Net::DNS::ZoneFile::Generator</remote-id>
+ <remote-id type="cpan-module">Net::DNS::ZoneFile::Text</remote-id>
+ </upstream>
+</pkgmetadata>