summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Nmap-Parser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Nmap-Parser')
-rw-r--r--dev-perl/Nmap-Parser/Manifest2
-rw-r--r--dev-perl/Nmap-Parser/Nmap-Parser-1.300.0.ebuild23
-rw-r--r--dev-perl/Nmap-Parser/Nmap-Parser-1.310.0.ebuild23
-rw-r--r--dev-perl/Nmap-Parser/metadata.xml14
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-perl/Nmap-Parser/Manifest b/dev-perl/Nmap-Parser/Manifest
new file mode 100644
index 000000000000..e4e07a8668a5
--- /dev/null
+++ b/dev-perl/Nmap-Parser/Manifest
@@ -0,0 +1,2 @@
+DIST Nmap-Parser-1.3.tar.gz 41171 SHA256 d9932bf60de25f3d6516c08f9d280d067bc6ad1c47f6a453a53fc6431fc9da28 SHA512 aae1b3bcc13d27c27c7d91e19b8bcf96b9b52b417447bf54e08a63100877ee9253ede4f4a65ba5e3e74f6690c00947980ab6deb5e4b8d223b99d02f4b864eb19 WHIRLPOOL b19fb1246c81d2fa94c2e1493ba6c8439f3ce3f28baa332fe6c8c32be782338c8d99c9b8d0e964e9d5187f7bedad0204f69f40621ab3ec9b54c30e3cfe999d0b
+DIST Nmap-Parser-1.31.tar.gz 41123 SHA256 92290ca5962edc66bdd91ee598d04b57e81f9f44b8735866f7a27b0d0e0aecb6 SHA512 156932f4cad124579d419d18917ab0307271eded5de5aa31ad155ee6ac5923c4d86e860361546ab5431c6b9a8e38d5b4757807b3d077362f6f7db84b68e06519 WHIRLPOOL 27bcb6e812e0f26267a4cd599489d3470536c19bcf49ede3aa16558886071d962c1164c40318c73a7f8eb506cdd1106776a5bf8f569dc0d2627706ba93559445
diff --git a/dev-perl/Nmap-Parser/Nmap-Parser-1.300.0.ebuild b/dev-perl/Nmap-Parser/Nmap-Parser-1.300.0.ebuild
new file mode 100644
index 000000000000..58e863dc7c51
--- /dev/null
+++ b/dev-perl/Nmap-Parser/Nmap-Parser-1.300.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=APERSAUD
+MODULE_VERSION=1.3
+inherit perl-module
+
+DESCRIPTION="Nmap::Parser - parse nmap scan data with perl"
+HOMEPAGE="http://nmapparser.wordpress.com/ http://code.google.com/p/nmap-parser/ ${HOMEPAGE}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/perl-Storable
+ >=dev-perl/XML-Twig-3.16"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Nmap-Parser/Nmap-Parser-1.310.0.ebuild b/dev-perl/Nmap-Parser/Nmap-Parser-1.310.0.ebuild
new file mode 100644
index 000000000000..66f3cbc7f9bf
--- /dev/null
+++ b/dev-perl/Nmap-Parser/Nmap-Parser-1.310.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=APERSAUD
+MODULE_VERSION=1.31
+inherit perl-module
+
+DESCRIPTION="Nmap::Parser - parse nmap scan data with perl"
+HOMEPAGE="http://nmapparser.wordpress.com/ http://code.google.com/p/nmap-parser/ ${HOMEPAGE}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="virtual/perl-Storable
+ >=dev-perl/XML-Twig-3.16"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/Nmap-Parser/metadata.xml b/dev-perl/Nmap-Parser/metadata.xml
new file mode 100644
index 000000000000..be22f134a6e3
--- /dev/null
+++ b/dev-perl/Nmap-Parser/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Nmap-Parser</remote-id>
+ <remote-id type="cpan-module">Nmap::Parser</remote-id>
+ <remote-id type="cpan-module">Nmap::Parser::Host</remote-id>
+ <remote-id type="cpan-module">Nmap::Parser::Host::OS</remote-id>
+ <remote-id type="cpan-module">Nmap::Parser::Host::Service</remote-id>
+ <remote-id type="cpan-module">Nmap::Parser::Host::TraceHop</remote-id>
+ <remote-id type="cpan-module">Nmap::Parser::Session</remote-id>
+ </upstream>
+</pkgmetadata>