summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/OpenGL
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/OpenGL')
-rw-r--r--dev-perl/OpenGL/Manifest1
-rw-r--r--dev-perl/OpenGL/OpenGL-0.670.3.ebuild36
-rw-r--r--dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch50
-rw-r--r--dev-perl/OpenGL/metadata.xml17
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-perl/OpenGL/Manifest b/dev-perl/OpenGL/Manifest
new file mode 100644
index 000000000000..027019e97408
--- /dev/null
+++ b/dev-perl/OpenGL/Manifest
@@ -0,0 +1 @@
+DIST OpenGL-0.6703.tar.gz 671629 SHA256 62f8cdf019fbdb6d095bc5f31382d123bceb9aabbba5788ecf416282de47534c SHA512 f1902bfe8e6e1f2309b878f68e08cf8f53d2f20287f99f8a8773647d737f559fbf17ad68cb52371af09e2ac030685b1625ce4c0033ec7e6fb5f322e5980e6713 WHIRLPOOL 98d6274a8fa975fd2c31858cf06b1bf5605690217218577c531f68c355affd175663ea8bbc00bb5cd7d0a6951dc0a94d1349535590e421431ab89b41d14fe4b9
diff --git a/dev-perl/OpenGL/OpenGL-0.670.3.ebuild b/dev-perl/OpenGL/OpenGL-0.670.3.ebuild
new file mode 100644
index 000000000000..d089f1e9de0f
--- /dev/null
+++ b/dev-perl/OpenGL/OpenGL-0.670.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR="CHM"
+MODULE_VERSION=0.6703
+
+inherit perl-module eutils
+
+DESCRIPTION="Perl interface providing graphics display using OpenGL"
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ media-libs/freeglut:0=
+ x11-libs/libICE:0=
+ x11-libs/libXext:0=
+ x11-libs/libXi:0=
+ x11-libs/libXmu:0="
+DEPEND="${RDEPEND}"
+
+mydoc="Release_Notes"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.66-no-display.patch
+}
+
+src_compile() {
+ sed -i -e 's/PERL_DL_NONLAZY=1//' Makefile || die
+ perl-module_src_compile
+}
diff --git a/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
new file mode 100644
index 000000000000..6bdc334ba0b1
--- /dev/null
+++ b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
@@ -0,0 +1,50 @@
+Don't check current display for extensions, build all.
+
+diff -up OpenGL-0.62/Makefile.PL.dist OpenGL-0.62/Makefile.PL
+--- OpenGL-0.62/Makefile.PL.dist 2009-12-11 01:10:00.000000000 +0100
++++ OpenGL-0.62/Makefile.PL 2010-01-07 13:00:26.000000000 +0100
+@@ -579,9 +579,9 @@ my $build_config =
+ {
+ FILES =>
+ "Config.pm ".
+- "utils/glversion.txt ".
+- "utils/glversion$Config{exe_ext} ".
+- "utils/glversion$Config{obj_ext}"
++ "utils/glversion.txt "
++ #"utils/glversion$Config{exe_ext} ".
++ #"utils/glversion$Config{obj_ext}"
+ }
+ };
+
+@@ -790,6 +790,7 @@ sub get_extensions
+ print "GLUT not found\n";
+ }
+
++=cut
+ # Platform-specific makefiles for glversion
+ my $make_ver;
+ if ($IS_MINGW)
+@@ -848,7 +849,9 @@ sub get_extensions
+ print "get_extensions: no extensions found in $glv_file\n" if $verbose;
+ return '';
+ }
+-
++=cut
++ use Config;
++ my $gldata = { };
+
+ # Parse glext_procs.h file
+ return '' if (!open(GLEXT,"glext_procs.h"));
+@@ -867,10 +870,12 @@ sub get_extensions
+
+ # Create gl_exclude.h
+ die "Unable to write to $exc_file\n" if (!open(GLEXC,">$exc_file"));
++=cut
+ print GLEXC "// OpenGL Extension Exclusions - may be modified before building.\n";
+ print GLEXC "//\n";
+ print GLEXC "// Generated for ".$gldata->{VENDOR}.", ".$gldata->{RENDERER}."\n";
+ print GLEXC "// OpenGL v".$gldata->{VERSION}.", using ";
++=cut
+
+ # Fix GLUT flags based on results
+ if ($gldata->{GLUT} > 0)
diff --git a/dev-perl/OpenGL/metadata.xml b/dev-perl/OpenGL/metadata.xml
new file mode 100644
index 000000000000..51d5a0502876
--- /dev/null
+++ b/dev-perl/OpenGL/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<herd>perl</herd>
+<longdescription lang="en">
+ OpenGL is a Perl module that provides an interface to most of Open Graphics
+ Library, API versions 1.0, 1.1 and 1.2. There is full support for the Utility
+ Toolkit (GLUT) up to version 3 and provides some additional functionality via
+ partial support for the Utility Library (GLU). It also provides functionality
+ to use the X Window System (through X11 and GLX) as an alternative to GLUT.
+</longdescription>
+<upstream>
+ <remote-id type="cpan">OpenGL</remote-id>
+ <remote-id type="cpan-module">OpenGL</remote-id>
+</upstream>
+</pkgmetadata>