summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/PDL
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/Manifest1
-rw-r--r--dev-perl/PDL/PDL-2.4.11.ebuild116
-rw-r--r--dev-perl/PDL/files/PDL-2.4.11-fortran.patch22
-rw-r--r--dev-perl/PDL/files/PDL-2.4.11-shared-fftw.patch11
-rw-r--r--dev-perl/PDL/files/PDL-2.4.11-shared-hdf.patch36
-rw-r--r--dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch20
-rw-r--r--dev-perl/PDL/files/PDL-2.4.3-PIC.patch11
-rw-r--r--dev-perl/PDL/files/PDL-2.4.4-PIC.patch22
-rw-r--r--dev-perl/PDL/files/perldl.conf110
-rw-r--r--dev-perl/PDL/metadata.xml211
10 files changed, 560 insertions, 0 deletions
diff --git a/dev-perl/PDL/Manifest b/dev-perl/PDL/Manifest
new file mode 100644
index 000000000000..71b5fe761669
--- /dev/null
+++ b/dev-perl/PDL/Manifest
@@ -0,0 +1 @@
+DIST PDL-2.4.11.tar.gz 2859537 SHA256 c777ed2519d73ebde0d870e94931a2d2c57865abcee27dfec53f4412a2cac662 SHA512 014358b7d844a082552782f23d610d62b6f5bf5fccef30dc32ecad665501e278351cf3b33ceafe3387054d2063fc642b7bf56459944ee8c0c3d0d7cef3d78a2b WHIRLPOOL eb6623dce01e0f568ddcd2d399a8ddb394ab839b088347a51c5c73c8cacf91b726cd18f6692e50197ae9040eec9dcb4bc3fa7bb722c66ea316132764d40fa8d4
diff --git a/dev-perl/PDL/PDL-2.4.11.ebuild b/dev-perl/PDL/PDL-2.4.11.ebuild
new file mode 100644
index 000000000000..39ae207218ad
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.4.11.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CHM
+FORTRAN_NEEDED=fortran
+
+inherit perl-module eutils fortran-2
+
+DESCRIPTION="Perl Data Language for scientific computing"
+
+LICENSE="|| ( Artistic GPL-1+ ) public-domain PerlDL"
+SLOT="0"
+KEYWORDS="amd64 arm ppc x86 ~amd64-linux ~x86-linux"
+# proj support removed #497328
+IUSE="+badval doc fftw fortran gd gsl hdf netpbm pdl2 pgplot plplot threads"
+
+RDEPEND="sys-libs/ncurses
+ app-arch/sharutils
+ dev-perl/Astro-FITS-Header
+ dev-perl/File-Map
+ dev-perl/Inline
+ dev-perl/OpenGL
+ dev-perl/TermReadKey
+ || ( dev-perl/Term-ReadLine-Perl dev-perl/Term-ReadLine-Gnu )
+ virtual/perl-Data-Dumper
+ virtual/perl-Pod-Parser
+ virtual/perl-File-Spec
+ virtual/perl-File-Temp
+ dev-perl/Filter
+ virtual/perl-Storable
+ virtual/perl-Text-Balanced
+ fftw? ( sci-libs/fftw:2.1 )
+ gd? ( media-libs/gd )
+ gsl? ( sci-libs/gsl )
+ hdf? ( sci-libs/hdf )
+ netpbm? ( media-libs/netpbm virtual/ffmpeg )
+ pdl2? ( dev-perl/Devel-REPL )
+ pgplot? ( dev-perl/PGPLOT )
+ plplot? ( sci-libs/plplot )"
+
+DEPEND="${RDEPEND}
+ fortran? ( >=dev-perl/ExtUtils-F77-1.13 )"
+
+REQUIRED_USE="plplot? ( badval )"
+
+mydoc="BUGS DEPENDENCIES DEVELOPMENT Known_problems MANIFEST* Release_Notes"
+
+SRC_TEST="do"
+
+pkg_setup() {
+ perl_set_version
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.4.2-makemakerfix.patch
+ # respect user choice for fortran compiler+flags, add pic
+ epatch "${FILESDIR}"/${PN}-2.4.11-fortran.patch
+ # search for shared fftw instead of static
+ epatch "${FILESDIR}"/${PN}-2.4.11-shared-fftw.patch
+ # search for shared hdf instead of static
+ epatch "${FILESDIR}"/${PN}-2.4.11-shared-hdf.patch
+ find . -name Makefile.PL -exec \
+ sed -i -e "s|/usr|${EPREFIX}/usr|g" {} \; || die
+
+ if has_version ">=sci-libs/plplot-5.11"; then
+ sed \
+ -e 's:plplotd:plplot:g' \
+ -i Graphics/PLplot/Makefile.PL || die
+ fi
+}
+
+src_configure() {
+ sed -i \
+ -e '/USE_POGL/s/=>.*/=> 1,/' \
+ -e "/WITH_3D/s/=>.*/=> 1,/" \
+ -e "/HTML_DOCS/s/=>.*/=> $(use doc && echo 1 || echo 0),/" \
+ -e "/WITH_BADVAL/s/=>.*/=> $(use badval && echo 1|| echo 0),/" \
+ -e "/WITH_DEVEL_REPL/s/=>.*/=> $(use pdl2 && echo 1 || echo 0),/" \
+ -e "/WITH_FFTW/s/=>.*/=> $(use fftw && echo 1 || echo 0),/" \
+ -e "/WITH_GSL/s/=>.*/=> $(use gsl && echo 1 || echo 0),/" \
+ -e "/WITH_GD/s/=>.*/=> $(use gd && echo 1 || echo 0),/" \
+ -e "/WITH_HDF/s/=>.*/=> $(use hdf && echo 1 || echo 0),/" \
+ -e "/WITH_MINUIT/s/=>.*/=> $(use fortran && echo 1|| echo 0),/" \
+ -e "/WITH_PGPLOT/s/=>.*/=> $(use pgplot && echo 1 || echo 0),/" \
+ -e "/WITH_PLPLOT/s/=>.*/=> $(use plplot && echo 1 || echo 0),/" \
+ -e "/WITH_POSIX_THREADS/s/=>.*/=> $(use threads && echo 1 || echo 0),/" \
+ -e "/WITH_PROJ/s/=>.*/=> $(echo 0),/" \
+ -e "/WITH_SLATEC/s/=>.*/=> $(use fortran && echo 1|| echo 0),/" \
+ perldl.conf || die
+ perl-module_src_configure
+}
+
+src_test() {
+ MAKEOPTS+=" -j1" perl-module_src_test
+}
+
+src_install() {
+ perl-module_src_install
+ cp Doc/{scantree,mkhtmldoc}.pl "${D}"/${VENDOR_ARCH}/PDL/Doc || die
+}
+
+pkg_postinst() {
+ perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl || die
+ elog "Building perldl.db done. You can recreate this at any time"
+ elog "by running:"
+ elog "perl ${VENDOR_ARCH}/PDL/Doc/scantree.pl"
+}
+
+pkg_prerm() {
+ rm -rf "${EROOT}"/var/lib/pdl/html
+ rm -f "${EROOT}"/var/lib/pdl/{pdldoc.db,Index.pod}
+}
diff --git a/dev-perl/PDL/files/PDL-2.4.11-fortran.patch b/dev-perl/PDL/files/PDL-2.4.11-fortran.patch
new file mode 100644
index 000000000000..5cd08d7f59e4
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.11-fortran.patch
@@ -0,0 +1,22 @@
+--- Lib/Minuit/Makefile.PL
++++ Lib/Minuit/Makefile.PL
+@@ -149,7 +149,7 @@
+ ("
+
+ minuitlib/$_\$(OBJ_EXT): minuitlib/$_.f
+- $mycompiler -c $hack_64bit -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
++ \$(FC) \$(FFLAGS) -fPIC -c -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
+ " )} @minuitfiles;
+
+ if (!defined($PDL::Config{MINUIT_LIB})){
+--- Lib/Slatec/Makefile.PL
++++ Lib/Slatec/Makefile.PL
+@@ -136,7 +136,7 @@
+ ("
+
+ slatec/$_\$(OBJ_EXT): slatec/$_.f
+- $mycompiler -c $hack_64bit -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
++ \$(FC) \$(FFLAGS) -c -fPIC -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
+ " )} @slatecfiles;
+
+ }
diff --git a/dev-perl/PDL/files/PDL-2.4.11-shared-fftw.patch b/dev-perl/PDL/files/PDL-2.4.11-shared-fftw.patch
new file mode 100644
index 000000000000..859a3ff0dd3d
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.11-shared-fftw.patch
@@ -0,0 +1,11 @@
+--- Lib/FFTW/Makefile.PL.orig 2012-08-28 17:10:15.000000000 +0100
++++ Lib/FFTW/Makefile.PL 2012-08-28 17:19:35.000000000 +0100
+@@ -152,7 +152,7 @@
+ # make a list of libs from the libstring
+ my @libs = split ' ',$double_lib;
+ grep s/\-l//g, @libs;
+- grep $_ = "lib$_.a", @libs;
++ grep $_ = "lib$_.$Config{so}", @libs;
+ my %libs;
+ my $lib;
+ foreach $libdir(@libdirs){
diff --git a/dev-perl/PDL/files/PDL-2.4.11-shared-hdf.patch b/dev-perl/PDL/files/PDL-2.4.11-shared-hdf.patch
new file mode 100644
index 000000000000..3cf22a31ce72
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.11-shared-hdf.patch
@@ -0,0 +1,36 @@
+--- IO/HDF/Makefile.PL.orig 2012-06-16 18:43:24.000000000 +0100
++++ IO/HDF/Makefile.PL 2012-06-16 18:44:51.000000000 +0100
+@@ -63,20 +63,20 @@
+ # Look for the libs:
+ foreach my $libdir ( @HDF_lib_locations )
+ {
+- if (-e "$libdir/libdfalt.a" && !$found_df)
++ if (-e "$libdir/libdfalt.$Config{so}" && !$found_df)
+ {
+ $found_df = 1;
+ $hdf_lib_path = $libdir;
+ $hdf_libs = '-lmfhdfalt -ldfalt';
+- print "Found libdfalt.a at $libdir/libdfalt.a\n";
++ print "Found libdfalt.$Config{so} at $libdir/libdfalt.$Config{so}\n";
+ }
+
+- if (-e "$libdir/libdf.a" && !$found_df)
++ if (-e "$libdir/libdf.$Config{so}" && !$found_df)
+ {
+ $found_df = 1;
+ $hdf_lib_path = $libdir;
+ $hdf_libs = '-lmfhdf -ldf';
+- print "Found libdf.a at $libdir/libdf.a\n";
++ print "Found libdf.$Config{so} at $libdir/libdf.$Config{so}\n";
+ }
+
+ # Look for the szip library, which HDF >= 4.2r0 needs, but older versions don't!
+@@ -90,7 +90,7 @@
+
+ unless( defined( $hdf_lib_path ) )
+ {
+- $msg .= "Cannot find hdf library, libdf.a.\n"
++ $msg .= "Cannot find hdf library, libdf.$Config{so}.\n"
+ . "Please add the correct library path to Makefile.PL or install HDF\n";
+
+ }
diff --git a/dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch b/dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch
new file mode 100644
index 000000000000..6cf2c4009a68
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.2-makemakerfix.patch
@@ -0,0 +1,20 @@
+--- Demos/BAD2_demo.pm.PL 2006/04/20 07:42:24 1.1
++++ Demos/BAD2_demo.pm.PL 2006/04/20 07:42:32
+@@ -3,6 +3,7 @@
+ # - requires both bad-value support and PGPLOT
+ #
+
++use blib;
+ use strict;
+
+ use Config;
+--- Demos/BAD_demo.pm.PL 2006/04/20 07:42:17 1.1
++++ Demos/BAD_demo.pm.PL 2006/04/20 07:42:38
+@@ -3,6 +3,7 @@
+ # - needed since we allow bad pixel handling to be switched off
+ #
+
++use blib;
+ use strict;
+
+ use Config;
diff --git a/dev-perl/PDL/files/PDL-2.4.3-PIC.patch b/dev-perl/PDL/files/PDL-2.4.3-PIC.patch
new file mode 100644
index 000000000000..ee6db253e4c2
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.3-PIC.patch
@@ -0,0 +1,11 @@
+--- Lib/Slatec/Makefile.PL 2007-09-11 18:30:14.000000000 +0200
++++ Lib/Slatec/Makefile.PL 2007-09-11 18:28:55.000000000 +0200
+@@ -136,7 +136,7 @@
+ ("
+
+ slatec/$_\$(OBJ_EXT): slatec/$_.f
+- $mycompiler -c $hack_64bit -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
++ $mycompiler -c -fPIC -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
+ " )} @slatecfiles;
+
+ }
diff --git a/dev-perl/PDL/files/PDL-2.4.4-PIC.patch b/dev-perl/PDL/files/PDL-2.4.4-PIC.patch
new file mode 100644
index 000000000000..a0087c9f5edd
--- /dev/null
+++ b/dev-perl/PDL/files/PDL-2.4.4-PIC.patch
@@ -0,0 +1,22 @@
+--- Lib/Minuit/Makefile.PL
++++ Lib/Minuit/Makefile.PL
+@@ -149,7 +149,7 @@
+ ("
+
+ minuitlib/$_\$(OBJ_EXT): minuitlib/$_.f
+- $mycompiler -c $hack_64bit -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
++ $mycompiler -c -fPIC -o minuitlib/$_\$(OBJ_EXT) $mycflags minuitlib/$_.f
+ " )} @minuitfiles;
+
+ if (!defined($PDL::Config{MINUIT_LIB})){
+--- Lib/Slatec/Makefile.PL
++++ Lib/Slatec/Makefile.PL
+@@ -136,7 +136,7 @@
+ ("
+
+ slatec/$_\$(OBJ_EXT): slatec/$_.f
+- $mycompiler -c $hack_64bit -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
++ $mycompiler -c -fPIC -o slatec/$_\$(OBJ_EXT) $mycflags slatec/$_.f
+ " )} @slatecfiles;
+
+ }
diff --git a/dev-perl/PDL/files/perldl.conf b/dev-perl/PDL/files/perldl.conf
new file mode 100644
index 000000000000..1fe24f3db6b0
--- /dev/null
+++ b/dev-perl/PDL/files/perldl.conf
@@ -0,0 +1,110 @@
+# -*-perl-*-
+
+# PDL Configuration options
+
+# You can edit this here or say 'perl Makefile.PL PDLCONF=file'
+# or use ~/.perldl.conf
+
+# Note in general "0" means False, "1" means "True" and "undef"
+# means "Try if possible (e.g. because the library is found)"
+
+%PDL_CONFIG = (
+
+# Use posix threading to make use of multiprocessor machines
+# undef -> try if possible
+# 0 -> don't use
+# true -> force use
+
+ WITH_POSIX_THREADS => undef,
+
+ MALLOCDBG => undef,
+# {
+# include => '-I/home/csoelle/tmp',
+# libs => '-L/home/csoelle/tmp -lmymalloc',
+# define => << 'EOD',
+##define malloc(n) dbgmalloc(n,__FILE__,__LINE__)
+##define free(p) dbgfree(p)
+#EOD
+# include => '',
+# libs => '-lefence',
+# define => '',
+# },
+
+# Do we want routines to handle bad values?
+# saying no will make PDL a bit faster
+# true -> yes
+# false -> no, undef -> no
+#
+ WITH_BADVAL => 0,
+# WITH_BADVAL => 1,
+
+# if WITH_BADVAL == 1, do we use NaN/Inf to represent badvalues
+# (not convinced setting this results in faster code)
+#
+ BADVAL_USENAN => 0,
+# BADVAL_USENAN => 1,
+
+# Try to build Graphics/TriD
+ WITH_3D => undef,
+#
+# For Mesa 3.2
+#
+ OPENGL_LIBS => '-L/usr/lib -lGL -lGLU -L/usr/X11R6/lib -lXext -lX11',
+#
+# Mesa need -DGL_GLEXT_LEGACY for glPolygonOffsetEXT amoung others
+#
+ OPENGL_DEFINE => '-DGL_GLEXT_LEGACY',
+ OPENGL_INC => '-I/usr/include',
+#
+#
+# For SGI GL
+#
+# OPENGL_LIBS => '-lGL -lGLU -lXext -lX11',
+# OPENGL_INC => '',
+# OPENGL_DEFINE => '',
+#
+# Let perl try to figure it out
+# OPENGL_LIBS => undef,
+# OPENGL_INC => undef,
+# OPENGL_DEFINE => undef,
+# Whether or not to build the Karma interface module
+
+ WITH_KARMA => undef, # Leave it up to PDL to decide
+ WHERE_KARMA => undef, # you may explicitly specify directory location
+
+# Whether or not to build the PDL::Slatec module
+# 0 -> don't use
+# true -> force use
+
+ WITH_SLATEC => undef, # Leave it up to PDL to decide
+
+# Whether or not to build the PDL::GSL module
+# 0 -> don't use
+# true -> force use
+
+ WITH_GSL => undef, # Leave it up to PDL to decide
+
+# Location to search for the GSL libs
+ GSL_LIBS => [ '/lib','/usr/lib','/usr/local/lib'],
+# Location to find GSL includes:
+ GSL_INC => '-I/usr/include/gsl -I/usr/local/include',
+
+# Whether or not to build the PDL::FFTW module
+# 0 -> don't use
+# true -> force use
+
+ WITH_FFTW => undef, # Leave it up to PDL to decide
+
+# Location to search for the FFTW libs
+ FFTW_LIBS => [ '/lib','/usr/lib','/usr/local/lib'],
+# Location to find FFTW includes:
+ FFTW_INC => ['/usr/include/','/usr/local/include'],
+
+# FFTW Numeric Precision Type to link in: (double or single precision)
+ FFTW_TYPE => 'double',
+
+);
+
+1; # Return OK status on 'require'
+
+
diff --git a/dev-perl/PDL/metadata.xml b/dev-perl/PDL/metadata.xml
new file mode 100644
index 000000000000..25f13ee54dc2
--- /dev/null
+++ b/dev-perl/PDL/metadata.xml
@@ -0,0 +1,211 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>perl</herd>
+ <longdescription lang="en">
+ The Perl Data Language gives standard perl the ability to compactly
+ store and speedily manipulate the large N-dimensional data arrays
+ which are the bread and butter of scientific computing. The idea
+ is to turn perl in to a free, array-oriented, numerical language
+ in the same sense as commercial packages like IDL and MatLab. One
+ can write simple perl expressions to manipulate entire numerical
+ arrays all at once.
+</longdescription>
+ <use>
+ <flag name="badval">Enable bad values support</flag>
+ <flag name="hdf">Enable HDF (version 4) format support</flag>
+ <flag name="netpbm">Enable NETPBM and MPEG support</flag>
+ <flag name="pdl2">Build pdf2 shell (requires Devel-REPL)</flag>
+ <flag name="pgplot">Enable PGPLOT plotting capabilities</flag>
+ <flag name="plplot">Enable plplot plotting capabilities</flag>
+ </use>
+ <upstream>
+ <remote-id type="cpan">PDL</remote-id>
+ <remote-id type="cpan-module">C::StructObj</remote-id>
+ <remote-id type="cpan-module">C::StructType</remote-id>
+ <remote-id type="cpan-module">C::Type</remote-id>
+ <remote-id type="cpan-module">C::Var</remote-id>
+ <remote-id type="cpan-module">Inline::MakePdlppInstallable</remote-id>
+ <remote-id type="cpan-module">Inline::Pdlpp</remote-id>
+ <remote-id type="cpan-module">NullHandle</remote-id>
+ <remote-id type="cpan-module">PDL</remote-id>
+ <remote-id type="cpan-module">PDL::Basic</remote-id>
+ <remote-id type="cpan-module">PDL::Bench</remote-id>
+ <remote-id type="cpan-module">PDL::CallExt</remote-id>
+ <remote-id type="cpan-module">PDL::Char</remote-id>
+ <remote-id type="cpan-module">PDL::Constants</remote-id>
+ <remote-id type="cpan-module">PDL::Core::Dev</remote-id>
+ <remote-id type="cpan-module">PDL::Dbg</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::Cartography_demo</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::General</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::PGPLOT_OO_demo</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::PGPLOT_demo</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::Routines</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::Transform_demo</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::TriD1</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::TriD2</remote-id>
+ <remote-id type="cpan-module">PDL::Demos::TriDGallery</remote-id>
+ <remote-id type="cpan-module">PDL::DiskCache</remote-id>
+ <remote-id type="cpan-module">PDL::Doc</remote-id>
+ <remote-id type="cpan-module">PDL::Doc::Perldl</remote-id>
+ <remote-id type="cpan-module">PDL::Exporter</remote-id>
+ <remote-id type="cpan-module">PDL::Filter::Gaussian</remote-id>
+ <remote-id type="cpan-module">PDL::Filter::LinPred</remote-id>
+ <remote-id type="cpan-module">PDL::Filter::LinSmooth</remote-id>
+ <remote-id type="cpan-module">PDL::Filter::Linear</remote-id>
+ <remote-id type="cpan-module">PDL::Filter::SavGol</remote-id>
+ <remote-id type="cpan-module">PDL::Fit::LM</remote-id>
+ <remote-id type="cpan-module">PDL::Fit::Linfit</remote-id>
+ <remote-id type="cpan-module">PDL::Fit::Polynomial</remote-id>
+ <remote-id type="cpan-module">PDL::Func</remote-id>
+ <remote-id type="cpan-module">PDL::GraphEvolver</remote-id>
+ <remote-id type="cpan-module">PDL::GraphEvolverOLD</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics2D</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::LUT</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::Limits</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::Limits::DSet</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::OpenGL::OO</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::OpenGL::Perl::OpenGL</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::PGPLOT</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::PGPLOT::Window</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::PGPLOTOptions</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::State</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::ArcBall</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::ArcBowl</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::ArcCone</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Basic</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::BoundingBox</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::ButtonControl</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::ContourPolygonize</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Contours</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Control3D</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::CylindricalEquidistantAxes</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Description</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::EuclidAxes</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::EventHandler</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::GL::Window</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::GObject</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::GObject_Lattice</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::GPObject</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::GoBoard</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Graph</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Image</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Labels</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Lattice</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::LineStrip</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Lines</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::LinesFOOOLD</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Logo</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Material</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::MathGraph</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Mesh</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::OOGL</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Object</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::OneTransformation</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Points</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::PolarStereoAxes</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Polygonize</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::QuaterController</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Quaternion</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::SCLattice</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::SLattice</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::SLattice_S</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::STrigrid</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::STrigrid_S</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Scale</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::ScaleController</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::SimpleController</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::SimpleScaler</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Spheres</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::StupidPolygonize</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Surface</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Transformation</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Translation</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::VRML</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::VRML::Parameter</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::VRML::URL</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::VRMLObject</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::ViewPort</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::TriD::Window</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::VRML</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::VRML::Protos</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::VRMLNode</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::VRMLPdlNode</remote-id>
+ <remote-id type="cpan-module">PDL::Graphics::VRMLProto</remote-id>
+ <remote-id type="cpan-module">PDL::IO::Dicom</remote-id>
+ <remote-id type="cpan-module">PDL::IO::Dumper</remote-id>
+ <remote-id type="cpan-module">PDL::IO::FITS</remote-id>
+ <remote-id type="cpan-module">PDL::IO::FastRaw</remote-id>
+ <remote-id type="cpan-module">PDL::IO::FlexRaw</remote-id>
+ <remote-id type="cpan-module">PDL::IO::HDF</remote-id>
+ <remote-id type="cpan-module">PDL::IO::Pic</remote-id>
+ <remote-id type="cpan-module">PDL::Interpolate</remote-id>
+ <remote-id type="cpan-module">PDL::Interpolate::Slatec</remote-id>
+ <remote-id type="cpan-module">PDL::Lite</remote-id>
+ <remote-id type="cpan-module">PDL::LiteF</remote-id>
+ <remote-id type="cpan-module">PDL::Lvalue</remote-id>
+ <remote-id type="cpan-module">PDL::Matrix</remote-id>
+ <remote-id type="cpan-module">PDL::MyInlineMod</remote-id>
+ <remote-id type="cpan-module">PDL::NiceSlice</remote-id>
+ <remote-id type="cpan-module">PDL::Opt::Simplex</remote-id>
+ <remote-id type="cpan-module">PDL::Options</remote-id>
+ <remote-id type="cpan-module">PDL::PP</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Access</remote-id>
+ <remote-id type="cpan-module">PDL::PP::BackCodeThreadLoop</remote-id>
+ <remote-id type="cpan-module">PDL::PP::BadAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::BadSwitch</remote-id>
+ <remote-id type="cpan-module">PDL::PP::BadVarAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Block</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Code</remote-id>
+ <remote-id type="cpan-module">PDL::PP::ComplexThreadLoop</remote-id>
+ <remote-id type="cpan-module">PDL::PP::GenericLoop</remote-id>
+ <remote-id type="cpan-module">PDL::PP::GentypeAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Ind</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Loop</remote-id>
+ <remote-id type="cpan-module">PDL::PP::MacroAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::NaNSupport</remote-id>
+ <remote-id type="cpan-module">PDL::PP::OtherAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::PDLStateBadAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::PPBadAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::PdlAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::PdlDimsObj</remote-id>
+ <remote-id type="cpan-module">PDL::PP::PdlParObj</remote-id>
+ <remote-id type="cpan-module">PDL::PP::PhysPointerAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::PointerAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::ReSizeAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::InsertName</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::MakeComp</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::Returns</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::Returns::EmptyString</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::Returns::NULL</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::Returns::One</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::Returns::Zero</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::Substitute</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Rule::Substitute::Usual</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Signature</remote-id>
+ <remote-id type="cpan-module">PDL::PP::SimpleThreadLoop</remote-id>
+ <remote-id type="cpan-module">PDL::PP::SizeAccess</remote-id>
+ <remote-id type="cpan-module">PDL::PP::ThreadLoop</remote-id>
+ <remote-id type="cpan-module">PDL::PP::TypeConv</remote-id>
+ <remote-id type="cpan-module">PDL::PP::Types</remote-id>
+ <remote-id type="cpan-module">PDL::Perldl2::Plugin::CleanErrors</remote-id>
+ <remote-id type="cpan-module">PDL::Perldl2::Plugin::NiceSlice</remote-id>
+ <remote-id type="cpan-module">PDL::Perldl2::Plugin::PDLCommands</remote-id>
+ <remote-id type="cpan-module">PDL::Perldl2::Plugin::PrintControl</remote-id>
+ <remote-id type="cpan-module">PDL::Perldl2::Profile::Perldl2</remote-id>
+ <remote-id type="cpan-module">PDL::Perldl2::Script</remote-id>
+ <remote-id type="cpan-module">PDL::Pod::Parser</remote-id>
+ <remote-id type="cpan-module">PDL::Pod::Select</remote-id>
+ <remote-id type="cpan-module">PDL::Pod::Usage</remote-id>
+ <remote-id type="cpan-module">PDL::PodParser</remote-id>
+ <remote-id type="cpan-module">PDL::Reduce</remote-id>
+ <remote-id type="cpan-module">PDL::Transform::Cartography</remote-id>
+ <remote-id type="cpan-module">StrHandle</remote-id>
+ <remote-id type="cpan-module">SymTab</remote-id>
+ <remote-id type="cpan-module">Win32::DDE::Netscape</remote-id>
+ <remote-id type="cpan-module">XS</remote-id>
+ </upstream>
+</pkgmetadata>