summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Path-Tiny
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Path-Tiny')
-rw-r--r--dev-perl/Path-Tiny/Manifest2
-rw-r--r--dev-perl/Path-Tiny/Path-Tiny-0.44.0.ebuild35
-rw-r--r--dev-perl/Path-Tiny/Path-Tiny-0.61.0.ebuild40
-rw-r--r--dev-perl/Path-Tiny/metadata.xml9
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-perl/Path-Tiny/Manifest b/dev-perl/Path-Tiny/Manifest
new file mode 100644
index 000000000000..efc985dec345
--- /dev/null
+++ b/dev-perl/Path-Tiny/Manifest
@@ -0,0 +1,2 @@
+DIST Path-Tiny-0.044.tar.gz 48394 SHA256 57af7c250b4778c5045ec94ecb833796d74499e350a5bb0b816c97f2d7925f1a SHA512 a3a09254bbdc0d9dce7037ae4fb2c7bdbea29c19379337ea2f8ea6973e63a89961be5d058a571bcdb9810cbe95f7e9301207457725bda4f9536ecb93460f25e6 WHIRLPOOL b536b874c1d6b0522380c6ce4eebdc52033f9adcb6d377a1f0cd1b5c908c17e6816a0942fc153a81d85958467c6bd4a1d17122d087eed32d72e26696a24f8289
+DIST Path-Tiny-0.061.tar.gz 71937 SHA256 e8290aac8c0623eea1b20b4a9d9a1be08db7f5a92ea51a514677964f3fa01cca SHA512 36efc16e8dc2046f4a0c458be464be54769ec721d09201970d7f4d9c87acb03b91f16b673e63fc8212574f47bad31f59006cc50eb242f071d271294408c397a0 WHIRLPOOL c0bf53e78b82a8f9351698de875dad339c821e3dccf5f7ee8add3ed7d3d11baacf43e5442d8481d1cdefce94da89e2d80eff28dbbaa1c6a5d6519e51a647d375
diff --git a/dev-perl/Path-Tiny/Path-Tiny-0.44.0.ebuild b/dev-perl/Path-Tiny/Path-Tiny-0.44.0.ebuild
new file mode 100644
index 000000000000..1e1eec02625e
--- /dev/null
+++ b/dev-perl/Path-Tiny/Path-Tiny-0.44.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DAGOLDEN
+MODULE_VERSION=0.044
+inherit perl-module
+
+DESCRIPTION="File path utility"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Unicode-UTF8-0.580.0
+ >=virtual/perl-File-Path-2.70.0
+ >=virtual/perl-File-Temp-0.180.0
+ >=virtual/perl-File-Spec-3.400.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ dev-perl/Devel-Hide
+ dev-perl/Test-Deep
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Path-Tiny/Path-Tiny-0.61.0.ebuild b/dev-perl/Path-Tiny/Path-Tiny-0.61.0.ebuild
new file mode 100644
index 000000000000..eac3d980f204
--- /dev/null
+++ b/dev-perl/Path-Tiny/Path-Tiny-0.61.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DAGOLDEN
+MODULE_VERSION=0.061
+inherit perl-module
+
+DESCRIPTION="File path utility"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Unicode-UTF8-0.580.0
+ virtual/perl-Carp
+ >=virtual/perl-Digest-1.30.0
+ >=virtual/perl-Digest-SHA-5.450.0
+ virtual/perl-Exporter
+ >=virtual/perl-File-Path-2.70.0
+ >=virtual/perl-File-Spec-3.400.0
+ >=virtual/perl-File-Temp-0.190.0
+ virtual/perl-if
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ dev-perl/Devel-Hide
+ dev-perl/Test-Deep
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/Path-Tiny/metadata.xml b/dev-perl/Path-Tiny/metadata.xml
new file mode 100644
index 000000000000..963e8ddcd494
--- /dev/null
+++ b/dev-perl/Path-Tiny/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>perl</herd>
+<upstream>
+<remote-id type="cpan">Path-Tiny</remote-id>
+<remote-id type="cpan-module">Path::Tiny</remote-id>
+</upstream>
+</pkgmetadata>