summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/RPC-XML
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/RPC-XML')
-rw-r--r--dev-perl/RPC-XML/Manifest2
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.770.0-r1.ebuild49
-rw-r--r--dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild52
-rw-r--r--dev-perl/RPC-XML/metadata.xml36
4 files changed, 139 insertions, 0 deletions
diff --git a/dev-perl/RPC-XML/Manifest b/dev-perl/RPC-XML/Manifest
new file mode 100644
index 000000000000..e48a9c0524ae
--- /dev/null
+++ b/dev-perl/RPC-XML/Manifest
@@ -0,0 +1,2 @@
+DIST RPC-XML-0.77.tar.gz 205679 SHA256 e38c5d131e8c29f41ca39ac1e4b7abd33ed1c9b417e0d8ac1c24a056ce7e6f5a SHA512 960625a387da279bab93d09f8b62d4e4f3e01a008abcc5503de3661171c1a4ffd4db9a4c10c4882e77bc7d12bb14071ca875c1988a3d3126fdf6ee70d68e80c9 WHIRLPOOL aca53100c4e905eba8ad4ea763058c6e63401d6de14be5c79450143eea3167f8d335eb3ff47789396612099bce4b6eed0aeb2d2b39a3158c161a37b66f15a9dc
+DIST RPC-XML-0.78.tar.gz 207243 SHA256 a2c02724a29f8f3183e396d1ca69fa76650cd913334d6d429a094321f588ec6a SHA512 160c5e699d3de78fe61a2d7a307e094261054cc4936d2b909fd0d29af77ca57aa76cd62f421a714c39feb1b46f1d81b9561551884dfb7e4dc6ab560c8e3e2822 WHIRLPOOL 5c72f81b60a53ad3fe51001bb86a978a0eef8a09ef0302f54c84c4b32b89a99bcbeceed756ac4c667e4fe3716e5f3eee69327db73332651a485134e8d0f1e318
diff --git a/dev-perl/RPC-XML/RPC-XML-0.770.0-r1.ebuild b/dev-perl/RPC-XML/RPC-XML-0.770.0-r1.ebuild
new file mode 100644
index 000000000000..60553220bd21
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.770.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJRAY
+MODULE_VERSION=0.77
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+SRC_TEST="do"
+
+RDEPEND="
+ >=dev-perl/libwww-perl-5.834.0
+ >=dev-perl/XML-LibXML-1.850.0
+ >=dev-perl/XML-Parser-2.310.0
+ dev-perl/net-server
+ >=virtual/perl-Scalar-List-Utils-1.200.0
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}"
+
+pkg_postinst() {
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}
diff --git a/dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild b/dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild
new file mode 100644
index 000000000000..4e81efa84886
--- /dev/null
+++ b/dev-perl/RPC-XML/RPC-XML-0.780.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=RJRAY
+MODULE_VERSION=0.78
+inherit perl-module
+
+DESCRIPTION="An implementation of XML-RPC"
+
+SLOT="0"
+LICENSE="|| ( Artistic-2 LGPL-2.1 )"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="test"
+
+SRC_TEST="do"
+
+RDEPEND="
+ >=virtual/perl-File-Spec-0.800.0
+ >=dev-perl/libwww-perl-5.834.0
+ >=virtual/perl-Module-Load-0.240.0
+ >=virtual/perl-Scalar-List-Utils-1.200.0
+ >=dev-perl/XML-LibXML-1.850.0
+ >=dev-perl/XML-Parser-2.310.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( >=virtual/perl-Test-Simple-0.940.0 )
+"
+
+pkg_postinst() {
+ SETWARN=0
+ has_version '=www-servers/apache-2*' && HAVE_APACHE2=1
+ has_version '>=www-apache/mod_perl-2.0' && HAVE_MP2=2
+
+ [ -n "${HAVE_APACHE2}" ] && SETWARN=1
+ [ -n "${HAVE_MP2}" ] && SETWARN=1
+
+ if [ "${SETWARN}" == "1" ]; then
+ ewarn "Apache2 or mod_perl2 were detected."
+ ewarn ""
+ ewarn "NOTE FROM THE AUTHOR OF RPC-XML"
+ ewarn ""
+ ewarn "At present, this package does not work with Apache2 and the soon-to-be"
+ ewarn "mod_perl2. The changes to the API for location handlers are too drastic to"
+ ewarn "try and support both within the same class (I tried, using the compatibility"
+ ewarn "layer). Also, mp2 does not currently provide support for <Perl> sections, which"
+ ewarn "are the real strength of the Apache::RPC::Server class."
+ fi
+}
diff --git a/dev-perl/RPC-XML/metadata.xml b/dev-perl/RPC-XML/metadata.xml
new file mode 100644
index 000000000000..bdb6e6df34e1
--- /dev/null
+++ b/dev-perl/RPC-XML/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">RPC-XML</remote-id>
+ <remote-id type="cpan-module">Apache::RPC::Server</remote-id>
+ <remote-id type="cpan-module">Apache::RPC::Status</remote-id>
+ <remote-id type="cpan-module">RPC::XML</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Client</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Function</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Method</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Parser</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Parser::XMLLibXML</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Parser::XMLParser</remote-id>
+ <remote-id type="cpan-module">RPC::XML::ParserFactory</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Procedure</remote-id>
+ <remote-id type="cpan-module">RPC::XML::Server</remote-id>
+ <remote-id type="cpan-module">RPC::XML::array</remote-id>
+ <remote-id type="cpan-module">RPC::XML::base64</remote-id>
+ <remote-id type="cpan-module">RPC::XML::boolean</remote-id>
+ <remote-id type="cpan-module">RPC::XML::datatype</remote-id>
+ <remote-id type="cpan-module">RPC::XML::datetime_iso8601</remote-id>
+ <remote-id type="cpan-module">RPC::XML::double</remote-id>
+ <remote-id type="cpan-module">RPC::XML::fault</remote-id>
+ <remote-id type="cpan-module">RPC::XML::i4</remote-id>
+ <remote-id type="cpan-module">RPC::XML::i8</remote-id>
+ <remote-id type="cpan-module">RPC::XML::int</remote-id>
+ <remote-id type="cpan-module">RPC::XML::nil</remote-id>
+ <remote-id type="cpan-module">RPC::XML::request</remote-id>
+ <remote-id type="cpan-module">RPC::XML::response</remote-id>
+ <remote-id type="cpan-module">RPC::XML::simple_type</remote-id>
+ <remote-id type="cpan-module">RPC::XML::string</remote-id>
+ <remote-id type="cpan-module">RPC::XML::struct</remote-id>
+ </upstream>
+</pkgmetadata>