summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/SQL-Statement
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/SQL-Statement')
-rw-r--r--dev-perl/SQL-Statement/Manifest1
-rw-r--r--dev-perl/SQL-Statement/SQL-Statement-1.405.0-r1.ebuild37
-rw-r--r--dev-perl/SQL-Statement/metadata.xml60
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-perl/SQL-Statement/Manifest b/dev-perl/SQL-Statement/Manifest
new file mode 100644
index 000000000000..4e5db3e30c1a
--- /dev/null
+++ b/dev-perl/SQL-Statement/Manifest
@@ -0,0 +1 @@
+DIST SQL-Statement-1.405.tar.gz 138703 SHA256 239094b6f18c36d174a7a9aa73c13cbaf9fec83d68dce5a2226a6120bb673026 SHA512 e7aa4cd9c300d3638e07e078c09d0e551fe799311b871f1a669efd4bf3f4675068895f86d15b852aa0230decacc3f019ad55a2972d0d298813ca189e9b57281b WHIRLPOOL 65602df50ef0f81a79a76bad4ea2cb37fb45d9235740e0c46a2f7ce2c044f23217d21fd6d59cd50a6422e9eda1b3ca5779823d3d76997957a658b44d566bec46
diff --git a/dev-perl/SQL-Statement/SQL-Statement-1.405.0-r1.ebuild b/dev-perl/SQL-Statement/SQL-Statement-1.405.0-r1.ebuild
new file mode 100644
index 000000000000..ed350fb6654d
--- /dev/null
+++ b/dev-perl/SQL-Statement/SQL-Statement-1.405.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=REHSACK
+MODULE_VERSION=1.405
+inherit perl-module
+
+DESCRIPTION="Small SQL parser and engine"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-perl/DBI-1.616
+ >=dev-perl/Clone-0.30
+ >=dev-perl/Params-Util-0.35
+ virtual/perl-Scalar-List-Utils"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST="do"
+
+pkg_setup() {
+ export SQL_STATEMENT_WARN_UPDATE=sure
+
+ if has_version "<=dev-perl/SQL-Statement-1.20" ; then
+ ewarn "Changes include (1.22):"
+ ewarn " * behavior for unquoted identifiers modified to lower case them"
+ ewarn " * IN and BETWEEN operators are supported native"
+ fi
+}
diff --git a/dev-perl/SQL-Statement/metadata.xml b/dev-perl/SQL-Statement/metadata.xml
new file mode 100644
index 000000000000..676bab7ce3c6
--- /dev/null
+++ b/dev-perl/SQL-Statement/metadata.xml
@@ -0,0 +1,60 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">SQL-Statement</remote-id>
+ <remote-id type="cpan-module">SQL::Dialects::ANSI</remote-id>
+ <remote-id type="cpan-module">SQL::Dialects::AnyData</remote-id>
+ <remote-id type="cpan-module">SQL::Dialects::CSV</remote-id>
+ <remote-id type="cpan-module">SQL::Dialects::Role</remote-id>
+ <remote-id type="cpan-module">SQL::Eval</remote-id>
+ <remote-id type="cpan-module">SQL::Eval::Table</remote-id>
+ <remote-id type="cpan-module">SQL::Parser</remote-id>
+ <remote-id type="cpan-module">SQL::Statement</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Aggregate</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::ColumnValue</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::ConstantTerm</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Function</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Function::NumericEval</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Function::StrConcat</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Function::SubString</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Function::Trim</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Function::UserFunc</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Functions</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::GetInfo</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Group</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Limit</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::ANSI::Is</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::And</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Between</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Clike</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Contains</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Equal</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Equality</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Greater</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::GreaterEqual</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Is</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Like</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Lower</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::LowerEqual</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Neg</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::NotEqual</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Or</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Regexp</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Operation::Rlike</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Order</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Param</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Placeholder</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::RAM</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::RAM::Table</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Table</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::TempTable</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Term</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::TermFactory</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Util</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Util::Column</remote-id>
+ <remote-id type="cpan-module">SQL::Statement::Util::Function</remote-id>
+ </upstream>
+</pkgmetadata>