summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Template-Plugin-Latex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Template-Plugin-Latex')
-rw-r--r--dev-perl/Template-Plugin-Latex/Manifest2
-rw-r--r--dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-2.170.0-r1.ebuild28
-rw-r--r--dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-3.60.0.ebuild30
-rw-r--r--dev-perl/Template-Plugin-Latex/files/Makefile.patch15
-rw-r--r--dev-perl/Template-Plugin-Latex/metadata.xml8
5 files changed, 83 insertions, 0 deletions
diff --git a/dev-perl/Template-Plugin-Latex/Manifest b/dev-perl/Template-Plugin-Latex/Manifest
new file mode 100644
index 000000000000..042aaf114404
--- /dev/null
+++ b/dev-perl/Template-Plugin-Latex/Manifest
@@ -0,0 +1,2 @@
+DIST Template-Latex-2.17.tar.gz 12875 SHA256 f973f2779768d29cf46f794a58700037dfe401fd7f3721b0d23cbfddbb4c16f1 SHA512 19fe8e2a7dc51ec734c25d2d4fb3a01df3751be49d9b4c0ee90e792b321079e28ce29656b08f80e6205f6edad5e7f5ff91335fcb9821373e729ddb5482a7c1d6 WHIRLPOOL 57f8a024e86a0e3b142f9fba6d40f8aa99b11318107dc2feb0a0bf16433f66f8e022ee52b11e1d7b8da6b485102fc574a4eeb8ae35e0f17f3cfcdd7e34634dac
+DIST Template-Plugin-Latex-3.06.tar.gz 20487 SHA256 8d083ea7f465df817b173bf51ab4f8ab7e00063cf701f1c477a411d2225337bd SHA512 13baa205d2095eb25fb746bfd03dd9f75d7c48cf775cc0b2d5874e9e6a76f69971925729709136dc53276b210855dbc7bf71d79bb0aa3dd28c8383c8569a7441 WHIRLPOOL 4c4f8d8f610a0bdae276779675eb8aad793478f9b5890803fdc8e9b6036087c37b28bdf478bebfbb272cb31d27f305df26883f166086d171d01f7b94ded5438c
diff --git a/dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-2.170.0-r1.ebuild b/dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-2.170.0-r1.ebuild
new file mode 100644
index 000000000000..cd192e0f79b9
--- /dev/null
+++ b/dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-2.170.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ANDREWF
+MODULE_VERSION=2.17
+MY_PN=Template-Latex
+MY_P=${MY_PN}-${MODULE_VERSION}
+S=${WORKDIR}/${MY_P}
+inherit perl-module eutils
+
+DESCRIPTION="Template::Latex - Latex support for the Template Toolkit"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Template-Toolkit-2.15
+ virtual/perl-File-Spec
+ virtual/latex-base"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Harness )"
+
+SRC_TEST="do"
+PATCHES=( "${FILESDIR}/Makefile.patch" )
diff --git a/dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-3.60.0.ebuild b/dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-3.60.0.ebuild
new file mode 100644
index 000000000000..47cfcaf8ed12
--- /dev/null
+++ b/dev-perl/Template-Plugin-Latex/Template-Plugin-Latex-3.60.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=EINHVERFR
+MODULE_VERSION=3.06
+inherit perl-module eutils
+
+DESCRIPTION="LaTeX support for the Template Toolkit"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/LaTeX-Driver
+ dev-perl/LaTeX-Encode
+ dev-perl/LaTeX-Table
+ >=dev-perl/Template-Toolkit-2.16
+ virtual/latex-base
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Harness )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Template-Plugin-Latex/files/Makefile.patch b/dev-perl/Template-Plugin-Latex/files/Makefile.patch
new file mode 100644
index 000000000000..9464d14d400d
--- /dev/null
+++ b/dev-perl/Template-Plugin-Latex/files/Makefile.patch
@@ -0,0 +1,15 @@
+--- Makefile.PL.orig 2006-07-12 09:37:17.753171250 +0200
++++ Makefile.PL 2006-07-12 09:38:54.031188250 +0200
+@@ -41,9 +41,9 @@
+
+ #------------------------------------------------------------------------
+
+-our $LATEX = ttprompt('latex path', find_program($ENV{PATH}, "latex"));
+-our $PDFLATEX = ttprompt('pdflatex path', find_program($ENV{PATH}, "pdflatex"));
+-our $DVIPS = ttprompt('dvips path', find_program($ENV{PATH}, "dvips"));
++our $LATEX = '/usr/bin/latex';
++our $PDFLATEX = '/usr/bin/pdflatex';
++our $DVIPS = '/usr/bin/dvips';
+
+ fix_file(catfile('lib','Template','Latex.pm'), '$LATEX', $LATEX);
+ fix_file(catfile('lib','Template','Latex.pm'), '$PDFLATEX', $PDFLATEX);
diff --git a/dev-perl/Template-Plugin-Latex/metadata.xml b/dev-perl/Template-Plugin-Latex/metadata.xml
new file mode 100644
index 000000000000..b93a14a2b765
--- /dev/null
+++ b/dev-perl/Template-Plugin-Latex/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Template-Latex</remote-id>
+ </upstream>
+</pkgmetadata>