summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Template-XML
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Template-XML')
-rw-r--r--dev-perl/Template-XML/Manifest1
-rw-r--r--dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild26
-rw-r--r--dev-perl/Template-XML/files/bug-144689-branch-2.17.patch13
-rw-r--r--dev-perl/Template-XML/metadata.xml23
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-perl/Template-XML/Manifest b/dev-perl/Template-XML/Manifest
new file mode 100644
index 000000000000..ef63879182bb
--- /dev/null
+++ b/dev-perl/Template-XML/Manifest
@@ -0,0 +1 @@
+DIST Template-XML-2.17.tar.gz 26496 SHA256 a73b242ef20870187e1bbd0ceed864e65f7cec1b5fd40aae086182676d4cad85 SHA512 bc835332655b444b67337e0351cdb246f108a35df5010bf4cfee918f1603106a02a8e1534ecccf9fd34b4e7e02123b00edc2701a0382b665d06c6002c5f4be4d WHIRLPOOL 16df19c2f1b7a07d3cbd44581e5d8ded4fbcf33436877a723cb43a0b77292713df3761d0ffb53ba4cec9a5cdf314d096d5a059cd4edd00205db4f92b4f163348
diff --git a/dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild b/dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild
new file mode 100644
index 000000000000..66f389cddf3e
--- /dev/null
+++ b/dev-perl/Template-XML/Template-XML-2.170.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ABW
+MODULE_VERSION=2.17
+inherit perl-module
+
+DESCRIPTION="XML plugins for the Template Toolkit"
+
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-perl/Template-Toolkit-2.15-r1
+ dev-perl/XML-DOM
+ dev-perl/XML-Parser
+ dev-perl/XML-RSS
+ dev-perl/XML-Simple
+ dev-perl/XML-XPath"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/bug-144689-branch-2.17.patch" )
+SRC_TEST="do"
diff --git a/dev-perl/Template-XML/files/bug-144689-branch-2.17.patch b/dev-perl/Template-XML/files/bug-144689-branch-2.17.patch
new file mode 100644
index 000000000000..c9c5c1cca0b7
--- /dev/null
+++ b/dev-perl/Template-XML/files/bug-144689-branch-2.17.patch
@@ -0,0 +1,13 @@
+--- Template-XML-2.17/lib/Template/Plugin/XML/LibXML.pm 2007-02-09
+09:48:07.000000000 -0600
++++ Template-XML-2.17-fixed/lib/Template/Plugin/XML/LibXML.pm 2007-02-19
+17:22:29.000000000 -0600
+@@ -112,7 +112,7 @@
+ eval { $parser->$method($args->{$method}) };
+
+ # if there's a problem throw a Tempalte::Exception
+- $self->throw("option '$method' not supported") if $@;
++ $class->throw("option '$method' not supported") if $@;
+ }
+
+ # parse
diff --git a/dev-perl/Template-XML/metadata.xml b/dev-perl/Template-XML/metadata.xml
new file mode 100644
index 000000000000..34ea84e6e2e5
--- /dev/null
+++ b/dev-perl/Template-XML/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Template-XML</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::DOM</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::File</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::RSS</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::Simple</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::Style</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::View</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::View::Element</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::View::Parser</remote-id>
+ <remote-id type="cpan-module">Template::Plugin::XML::XPath</remote-id>
+ <remote-id type="cpan-module">XML::DOM::Element</remote-id>
+ <remote-id type="cpan-module">XML::DOM::Node</remote-id>
+ <remote-id type="cpan-module">XML::XPath::Node::Comment</remote-id>
+ <remote-id type="cpan-module">XML::XPath::Node::Element</remote-id>
+ <remote-id type="cpan-module">XML::XPath::Node::Text</remote-id>
+ </upstream>
+</pkgmetadata>