summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Test-Warn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Test-Warn')
-rw-r--r--dev-perl/Test-Warn/Manifest2
-rw-r--r--dev-perl/Test-Warn/Test-Warn-0.240.0-r1.ebuild24
-rw-r--r--dev-perl/Test-Warn/Test-Warn-0.300.0.ebuild25
-rw-r--r--dev-perl/Test-Warn/metadata.xml11
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-perl/Test-Warn/Manifest b/dev-perl/Test-Warn/Manifest
new file mode 100644
index 000000000000..22f300295524
--- /dev/null
+++ b/dev-perl/Test-Warn/Manifest
@@ -0,0 +1,2 @@
+DIST Test-Warn-0.24.tar.gz 11804 SHA256 b4f6b60c158cb8405861ddd045247c31d75d8cd89cab77ef608f999a39ab218b SHA512 58a7531b510d01f7ac12ab5170955dc55dcdf346766917c94375ee9ec89a536602f1f99d730441358a4a64b4d76cc073ebd7b113347bceec086f663bec2a7ae2 WHIRLPOOL c9ff708d4a47d43079da0d13a55cd2761bffc35425bd616f68a344019d47f39c35513c5d7b87d086e2cbecf947e06e8cad90549e7ff6df085b70597175e1ebe6
+DIST Test-Warn-0.30.tar.gz 11281 SHA256 8197555b94189d919349a03f7058f83861f145af9bee59f505bfe47562144e41 SHA512 23d01f3ec91d7e57200d768ff85aee8ef0df3fd16bf1f12ce56722334e73b1335236c1b1c5e6e72d46cf0b32a6049c085f84ff9ec19e93210a587e64c477979e WHIRLPOOL a7d697594da8e255bb04cae2b4391b7b4a722dffa02eb0d1e2966ee520585b6c8a41796b149f46da384991976066a8978e47f033a34b4807b01f104b95108d6b
diff --git a/dev-perl/Test-Warn/Test-Warn-0.240.0-r1.ebuild b/dev-perl/Test-Warn/Test-Warn-0.240.0-r1.ebuild
new file mode 100644
index 000000000000..c4fd0ee41a89
--- /dev/null
+++ b/dev-perl/Test-Warn/Test-Warn-0.240.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CHORNY
+MODULE_VERSION=0.24
+inherit perl-module
+
+DESCRIPTION="Perl extension to test methods for warnings"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-perl/Sub-Uplevel-0.12
+ dev-perl/Tree-DAG_Node
+ virtual/perl-Test-Simple
+ virtual/perl-File-Spec"
+DEPEND="test? ( ${RDEPEND}
+ dev-perl/Test-Pod )"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-Warn/Test-Warn-0.300.0.ebuild b/dev-perl/Test-Warn/Test-Warn-0.300.0.ebuild
new file mode 100644
index 000000000000..5ea2d74adfc8
--- /dev/null
+++ b/dev-perl/Test-Warn/Test-Warn-0.300.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=CHORNY
+MODULE_VERSION=0.30
+inherit perl-module
+
+DESCRIPTION="Perl extension to test methods for warnings"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="test"
+
+RDEPEND=">=dev-perl/Sub-Uplevel-0.12
+ dev-perl/Tree-DAG_Node
+ virtual/perl-Test-Simple
+ virtual/perl-File-Spec"
+DEPEND="test? ( ${RDEPEND}
+ dev-perl/Test-Pod )"
+
+SRC_TEST="do"
diff --git a/dev-perl/Test-Warn/metadata.xml b/dev-perl/Test-Warn/metadata.xml
new file mode 100644
index 000000000000..0d6baa3c4d68
--- /dev/null
+++ b/dev-perl/Test-Warn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Test-Warn</remote-id>
+ <remote-id type="cpan-module">Test::Warn</remote-id>
+ <remote-id type="cpan-module">Test::Warn::Categorization</remote-id>
+ <remote-id type="cpan-module">Test::Warn::DAG_Node_Tree</remote-id>
+ </upstream>
+</pkgmetadata>