summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Text-Unaccent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Text-Unaccent')
-rw-r--r--dev-perl/Text-Unaccent/Manifest1
-rw-r--r--dev-perl/Text-Unaccent/Text-Unaccent-1.80.0-r1.ebuild19
-rw-r--r--dev-perl/Text-Unaccent/files/text-unaccent_size_t.diff27
-rw-r--r--dev-perl/Text-Unaccent/metadata.xml9
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/Text-Unaccent/Manifest b/dev-perl/Text-Unaccent/Manifest
new file mode 100644
index 000000000000..62796d9b6200
--- /dev/null
+++ b/dev-perl/Text-Unaccent/Manifest
@@ -0,0 +1 @@
+DIST Text-Unaccent-1.08.tar.gz 84476 SHA256 278e6efc9b24f3699c961efb36ebe602a3408b541572017dee131d152728732b SHA512 d2c6a308904d0f1d5cd05a9fd29436f54292ea537f2ad8f44b4ebc0523302db64bb087aeac1f8e51c093e71b205c6c4fd9649cf2c8cbf8b50266c0aa200917c8 WHIRLPOOL aadbb837dacc8c396c19ead92414cef08695be2119f176d367f0c6a1da59d1ed42cacbb67d6d816a085605f2540ca7a9db1770b08f7a4292ee5cb0977a9c7656
diff --git a/dev-perl/Text-Unaccent/Text-Unaccent-1.80.0-r1.ebuild b/dev-perl/Text-Unaccent/Text-Unaccent-1.80.0-r1.ebuild
new file mode 100644
index 000000000000..94e25ee09138
--- /dev/null
+++ b/dev-perl/Text-Unaccent/Text-Unaccent-1.80.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=LDACHARY
+MODULE_VERSION=1.08
+inherit perl-module
+
+DESCRIPTION="Removes accents from a string"
+
+LICENSE="|| ( GPL-2 GPL-3 )" #GPL-2+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+SRC_TEST="do"
+PATCHES=( "${FILESDIR}"/text-unaccent_size_t.diff )
diff --git a/dev-perl/Text-Unaccent/files/text-unaccent_size_t.diff b/dev-perl/Text-Unaccent/files/text-unaccent_size_t.diff
new file mode 100644
index 000000000000..5bd45f6f2ad6
--- /dev/null
+++ b/dev-perl/Text-Unaccent/files/text-unaccent_size_t.diff
@@ -0,0 +1,27 @@
+diff -ur Text-Unaccent-1.08/unac.c Text-Unaccent-1.08-mod/unac.c
+--- Text-Unaccent-1.08/unac.c 2004-10-17 12:00:36.000000000 -0700
++++ Text-Unaccent-1.08-mod/unac.c 2006-08-24 22:37:35.000000000 -0700
+@@ -13881,9 +13881,9 @@
+ *out_lengthp = 0;
+ } else {
+ char* utf16 = 0;
+- int utf16_length = 0;
++ size_t utf16_length = 0;
+ char* utf16_unaccented = 0;
+- int utf16_unaccented_length = 0;
++ size_t utf16_unaccented_length = 0;
+
+ if(convert(charset, utf16be(), in, in_length, &utf16, &utf16_length) < 0) {
+ return -1;
+diff -ur Text-Unaccent-1.08/Unaccent.xs Text-Unaccent-1.08-mod/Unaccent.xs
+--- Text-Unaccent-1.08/Unaccent.xs 2004-12-29 03:45:18.000000000 -0800
++++ Text-Unaccent-1.08-mod/Unaccent.xs 2006-08-24 22:35:57.000000000 -0700
+@@ -35,7 +35,7 @@
+ #include "unac.h"
+
+ static char* buffer;
+-static int buffer_length;
++static size_t buffer_length;
+
+ static void unac_debug_print(const char* message, void* data)
+ {
diff --git a/dev-perl/Text-Unaccent/metadata.xml b/dev-perl/Text-Unaccent/metadata.xml
new file mode 100644
index 000000000000..c66773654bd6
--- /dev/null
+++ b/dev-perl/Text-Unaccent/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Text-Unaccent</remote-id>
+ <remote-id type="cpan-module">Text::Unaccent</remote-id>
+ </upstream>
+</pkgmetadata>