summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/XML-LibXML
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/XML-LibXML')
-rw-r--r--dev-perl/XML-LibXML/Manifest1
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-2.12.100.ebuild59
-rw-r--r--dev-perl/XML-LibXML/metadata.xml44
3 files changed, 104 insertions, 0 deletions
diff --git a/dev-perl/XML-LibXML/Manifest b/dev-perl/XML-LibXML/Manifest
new file mode 100644
index 000000000000..9c1ba807d5d9
--- /dev/null
+++ b/dev-perl/XML-LibXML/Manifest
@@ -0,0 +1 @@
+DIST XML-LibXML-2.0121.tar.gz 464562 SHA256 ec431011cb37a04640fd2316f64d0405a274eece2c6f3847f7fbd336eb1c0dc9 SHA512 1833d1e14d8a3b361bcacde910807a56e21cd08204f3fa58888a8c9219bd9228bfdc211af8f74b91ceda3135b4e72cbc60ef1d783afbe0febd100117904f29f1 WHIRLPOOL 8168fcb40e9cfd7d9802f443124a1a38419b5e74b5560b95cfb66f4bc37110a2ac11515b365c4c90bd6007cb5a98c0045bc460566e7f52f758958019953411fe
diff --git a/dev-perl/XML-LibXML/XML-LibXML-2.12.100.ebuild b/dev-perl/XML-LibXML/XML-LibXML-2.12.100.ebuild
new file mode 100644
index 000000000000..8da3f7cb612a
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-2.12.100.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=SHLOMIF
+MODULE_VERSION=2.0121
+inherit perl-module
+
+DESCRIPTION="Perl binding for libxml2"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/XML-SAX-0.120.0
+ >=dev-libs/libxml2-2.6.21
+ >=dev-perl/XML-NamespaceSupport-1.70.0
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-LeakTrace
+ )
+"
+
+SRC_TEST="do"
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}
diff --git a/dev-perl/XML-LibXML/metadata.xml b/dev-perl/XML-LibXML/metadata.xml
new file mode 100644
index 000000000000..e4232c704e27
--- /dev/null
+++ b/dev-perl/XML-LibXML/metadata.xml
@@ -0,0 +1,44 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">XML-LibXML</remote-id>
+ <remote-id type="cpan-module">XML::LibXML</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Attr</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::AttributeHash</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Boolean</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::CDATASection</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Comment</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Common</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Devel</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Document</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::DocumentFragment</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Dtd</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Element</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::ErrNo</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Error</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::InputCallback</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Literal</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::NamedNodeMap</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Namespace</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Node</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::NodeList</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Number</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::PI</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Pattern</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Reader</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::RegExp</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::RelaxNG</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::SAX</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::SAX::AttributeNode</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::SAX::Builder</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::SAX::Generator</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::SAX::Parser</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Schema</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::Text</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::XPathContext</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::XPathExpression</remote-id>
+ <remote-id type="cpan-module">XML::LibXML::_SAXParser</remote-id>
+ </upstream>
+</pkgmetadata>