summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/XML-SAX
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/XML-SAX')
-rw-r--r--dev-perl/XML-SAX/Manifest1
-rw-r--r--dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild50
-rw-r--r--dev-perl/XML-SAX/files/encodings.patch11
-rw-r--r--dev-perl/XML-SAX/metadata.xml19
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-perl/XML-SAX/Manifest b/dev-perl/XML-SAX/Manifest
new file mode 100644
index 000000000000..2e1e65424c20
--- /dev/null
+++ b/dev-perl/XML-SAX/Manifest
@@ -0,0 +1 @@
+DIST XML-SAX-0.99.tar.gz 46703 SHA256 32b04b8e36b6cc4cfc486de2d859d87af5386dd930f2383c49347050d6f5ad84 SHA512 f0c55efee4e3010deb474377394f9635bd8adc50108b562aeef54a2eef312cf87fb240d0495b5a5bd0c4cd5251db1bc74ba6cb549614708b1627f330959735e1 WHIRLPOOL 4f5c6d8c582652ac943ad974025727c0dfeb67a7be2c53005e695307077bb5ad7d7b440963b84404a61e8b8509f13565b87bec3471ce402aad4b519689dadfc4
diff --git a/dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild b/dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild
new file mode 100644
index 000000000000..65d6937af54f
--- /dev/null
+++ b/dev-perl/XML-SAX/XML-SAX-0.990.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=GRANTM
+MODULE_VERSION=0.99
+inherit perl-module eutils
+
+DESCRIPTION="Perl module for using and building Perl SAX2 XML parsers, filters, and drivers"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-perl/XML-SAX-Base
+ >=dev-perl/XML-NamespaceSupport-1.40.0
+ >=dev-libs/libxml2-2.4.1
+"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i \
+ -e 's/if (\$write_ini_ok)/if (0 \&\& $write_ini_ok)/' \
+ Makefile.PL || die
+ epatch "${FILESDIR}"/encodings.patch
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::SAX::PurePerl
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}
diff --git a/dev-perl/XML-SAX/files/encodings.patch b/dev-perl/XML-SAX/files/encodings.patch
new file mode 100644
index 000000000000..0608024d0be8
--- /dev/null
+++ b/dev-perl/XML-SAX/files/encodings.patch
@@ -0,0 +1,11 @@
+--- SAX/PurePerl/EncodingDetect.pm.orig 2006-05-08 12:08:40.000000000 -0400
++++ SAX/PurePerl/EncodingDetect.pm 2006-05-08 12:14:23.000000000 -0400
+@@ -93,7 +93,7 @@ sub encoding_detect {
+ return;
+ }
+
+- warn("Unable to recognise encoding of this document");
++ #warn("Unable to recognise encoding of this document");
+ return;
+ }
+
diff --git a/dev-perl/XML-SAX/metadata.xml b/dev-perl/XML-SAX/metadata.xml
new file mode 100644
index 000000000000..1d4aefa3a393
--- /dev/null
+++ b/dev-perl/XML-SAX/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">XML-SAX</remote-id>
+ <remote-id type="cpan-module">XML::SAX</remote-id>
+ <remote-id type="cpan-module">XML::SAX::DocumentLocator</remote-id>
+ <remote-id type="cpan-module">XML::SAX::ParserFactory</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl::DebugHandler</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl::Exception</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl::Productions</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl::Reader</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl::Reader::Stream</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl::Reader::String</remote-id>
+ <remote-id type="cpan-module">XML::SAX::PurePerl::Reader::URI</remote-id>
+ </upstream>
+</pkgmetadata>