summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/module-info
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/module-info')
-rw-r--r--dev-perl/module-info/Manifest1
-rw-r--r--dev-perl/module-info/metadata.xml13
-rw-r--r--dev-perl/module-info/module-info-0.350.0-r1.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/module-info/Manifest b/dev-perl/module-info/Manifest
new file mode 100644
index 000000000000..d76b96cbfb44
--- /dev/null
+++ b/dev-perl/module-info/Manifest
@@ -0,0 +1 @@
+DIST Module-Info-0.35.tar.gz 55112 SHA256 ab073d10d67a25b0e6a3f8efa95de9e3d6fbe043538bf524a88a0e1fc3ebfb64 SHA512 87d68f575f97db8579675a8187cf746e74409266c0ac9454ad41380e6e0ee9566632d368098c0b00b54128aacb27bc43c774ea78a047964bb6a14f6a06c681aa WHIRLPOOL 7589e5ca17f0a2b01f1428d778e717e49544baa541711aed92cd8d3e6234cf4535df4346d5c3b8973af4b5893615f5a65279a906bd9d5a233cba882b2b2e163d
diff --git a/dev-perl/module-info/metadata.xml b/dev-perl/module-info/metadata.xml
new file mode 100644
index 000000000000..12cf4d854049
--- /dev/null
+++ b/dev-perl/module-info/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Module-Info</remote-id>
+ <remote-id type="cpan-module">B::Module::Info</remote-id>
+ <remote-id type="cpan-module">Module::Info</remote-id>
+ <remote-id type="cpan-module">Module::Info::Safe</remote-id>
+ <remote-id type="cpan-module">Module::Info::Unsafe</remote-id>
+ <remote-id type="cpan-module">Module::Info::_version</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-perl/module-info/module-info-0.350.0-r1.ebuild b/dev-perl/module-info/module-info-0.350.0-r1.ebuild
new file mode 100644
index 000000000000..5bcc7b615cef
--- /dev/null
+++ b/dev-perl/module-info/module-info-0.350.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_PN=Module-Info
+MODULE_AUTHOR=MBARBON
+MODULE_VERSION=0.35
+inherit perl-module
+
+DESCRIPTION="Information about Perl modules"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="do"