summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/rename
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/rename')
-rw-r--r--dev-perl/rename/Manifest2
-rw-r--r--dev-perl/rename/metadata.xml8
-rw-r--r--dev-perl/rename/rename-1.800.0-r1.ebuild22
-rw-r--r--dev-perl/rename/rename-1.900.0.ebuild22
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-perl/rename/Manifest b/dev-perl/rename/Manifest
new file mode 100644
index 000000000000..eb890a2df1aa
--- /dev/null
+++ b/dev-perl/rename/Manifest
@@ -0,0 +1,2 @@
+DIST rename-1.8.tar.gz 5582 SHA256 7e43895de8d8d0c68d8ca7564fd005b04cbfc437e742d61af52f29a156168a75 SHA512 2090cfb007cc78a8daa946a4d2e8671bc5081dce1374aac304f96559e053e5b8fc970ba7acb86a5dbf256cabf88cb75cd27dfe2f5823cc0440b7eeea452a9b0c WHIRLPOOL 6fb559b932aa2a4b54dacbeb89ae99d901257e0aae93c0ee4722e7f5dc27fdcc71f8fff66d9ca92e4265919c8009303225cb0aeaaa02a8a17bed590a1701ac9f
+DIST rename-1.9.tar.gz 5942 SHA256 17c5744f10d335a9d3674ed011ff26d3e840f25290c7f86c1d63d05771677ea0 SHA512 f6977d6b1698d7da6b2b5ef262cd13a4c4739e4f468d164ba6876ecabfd7bc44532eddb9350aa61e9fb154138ef38ea8323e3768c7d3d611ce7ee49b1561c4d0 WHIRLPOOL f95ebd255612b6707d6f2cb5cdaab9a3af12dfc84860a454900f15436d448c2b36d7a3acf3cc28188992443fa91b7de184691bf2d9d94cbb75cb9567b16153e6
diff --git a/dev-perl/rename/metadata.xml b/dev-perl/rename/metadata.xml
new file mode 100644
index 000000000000..b8e0935db396
--- /dev/null
+++ b/dev-perl/rename/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">rename</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-perl/rename/rename-1.800.0-r1.ebuild b/dev-perl/rename/rename-1.800.0-r1.ebuild
new file mode 100644
index 000000000000..58743fd86fd9
--- /dev/null
+++ b/dev-perl/rename/rename-1.800.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PEDERST
+MODULE_VERSION=1.8
+inherit perl-module
+
+DESCRIPTION="A filename renaming utility based on perl regular expression"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_install() {
+ perl-module_src_install
+
+ mv -vf "${D}"/usr/bin/rename "${D}"/usr/bin/perl-rename
+ mv -vf "${D}"/usr/share/man/man1/rename.1 "${D}"/usr/share/man/man1/perl-rename.1
+}
diff --git a/dev-perl/rename/rename-1.900.0.ebuild b/dev-perl/rename/rename-1.900.0.ebuild
new file mode 100644
index 000000000000..a330b1c20d8d
--- /dev/null
+++ b/dev-perl/rename/rename-1.900.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PEDERST
+MODULE_VERSION=1.9
+inherit perl-module
+
+DESCRIPTION="A filename renaming utility based on perl regular expression"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_install() {
+ perl-module_src_install
+
+ mv -vf "${D}"/usr/bin/rename "${D}"/usr/bin/perl-rename || die
+ mv -vf "${D}"/usr/share/man/man1/rename.1 "${D}"/usr/share/man/man1/perl-rename.1 || die
+}