summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-12 17:57:08 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-12 17:57:46 -0400
commit711eea5c97051a9945a89eea54010f8f861db0ca (patch)
tree654a8c8ea4e3bd7727c5a456ecdbf722b5b10445 /dev-php/PEAR-Net_Sieve
parentdev-util/artifactory-bin: version bump (diff)
downloadgentoo-711eea5c97051a9945a89eea54010f8f861db0ca.tar.gz
gentoo-711eea5c97051a9945a89eea54010f8f861db0ca.tar.bz2
gentoo-711eea5c97051a9945a89eea54010f8f861db0ca.zip
dev-php/PEAR-Net_Sieve: new version v1.5.2 from the Roundcube team.
The Net_Sieve upstream project has been abandoned in favor of another package, Horde_ManageSieve. Roundcube still uses Net_Sieve, so the Roundcube team has forked this package and updated it for php7. The old maintainer of Net_Sieve did not want to let the Roundcube people take over maintenance (and the old Net_Sieve truly is dead), so in this case it seems acceptable to let Roundcube usurp upstream for Net_Sieve. In the past, the Roundcube team has taken over maintenance of other related PEAR mail packages. The PEAR eclass has been dropped from the ebuild, which now uses EAPI=6. In the future this can be renamed without the "PEAR" prefix. Gentoo-Bug: 586624 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-php/PEAR-Net_Sieve')
-rw-r--r--dev-php/PEAR-Net_Sieve/Manifest1
-rw-r--r--dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_Sieve/Manifest b/dev-php/PEAR-Net_Sieve/Manifest
index 2848ab0c8350..dbf252582858 100644
--- a/dev-php/PEAR-Net_Sieve/Manifest
+++ b/dev-php/PEAR-Net_Sieve/Manifest
@@ -1,2 +1,3 @@
+DIST 1.5.2.tar.gz 16332 SHA256 07d6b4dff6cf67fd022fd521c4a2555a0e0e82ee2804fe8eb14624524586a6a4 SHA512 672d2f6f4c3241f748fbdebd804f2186dd2a5f8b7be6a75cb9187ed16e61502e4a338bfaa1815190b74ab534cb7277b534b0542309098797fcb63582dc81bdbe WHIRLPOOL 065bb5629de459b884d63a5411ffa6bc10eab8c195e41623cf923afb22eb56201c16799f15dc1477e3e97ca34d1216fe9be49645c717f4058ddb8e98271e5848
DIST Net_Sieve-1.3.2.tgz 14895 SHA256 dd2bca102e9cbc8dad42d32f6799894e065e91eacb0d186546abf3de644d776c SHA512 0eb9a514f0af11b21d308ac7e9531be4a3b3f668d2ce8b8f153cd32920297df93618729851809bbe5837aaaa5f948c26477013c7a351cd9fba1ff0c0ec22f34d WHIRLPOOL 37d35423cdef4311defeffba928a4129315beee7d24838264e59d8612ae2d1d32ba148e69668d0d7e00acfed5840367b2cb5651f4f57f15e926c55efef218d83
DIST Net_Sieve-1.3.3.tgz 15109 SHA256 53666be373739b7b98dfd9538d6d8aaa7e45f51c191fc034b2675e8f12297db6 SHA512 3fd41c7f60ce1ba89ecdf0d2cbeed61e7ceb53d1218dc2b4079267235da9b17a478eaf85ecf4e0449122ec866ad1a0b579f1a7484b37681081dcabe261fc7213 WHIRLPOOL e08aae13555ee24f8fae3659d3ed54dc67946215ba7da5ce3e9d68f2756232e6220769f7a40a78b31f7b9d72ac55484221bfd860211162d4354e200394aa3edd
diff --git a/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2.ebuild b/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2.ebuild
new file mode 100644
index 000000000000..ff35a1330101
--- /dev/null
+++ b/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+
+DESCRIPTION="An API for talking to sieve (RFC 3028) servers"
+HOMEPAGE="https://github.com/roundcube/${MY_PN}"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="sasl"
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Net_Socket
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ # Install into "Net" for backwards compatibility (that's where PEAR
+ # used to put things).
+ insinto /usr/share/php/Net
+ doins Sieve.php
+}