summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-bbcode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-bbcode')
-rw-r--r--dev-php/pecl-bbcode/Manifest1
-rw-r--r--dev-php/pecl-bbcode/metadata.xml11
-rw-r--r--dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r1.ebuild32
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-php/pecl-bbcode/Manifest b/dev-php/pecl-bbcode/Manifest
new file mode 100644
index 000000000000..25816095ad50
--- /dev/null
+++ b/dev-php/pecl-bbcode/Manifest
@@ -0,0 +1 @@
+DIST bbcode-1.0.3b1.tgz 47205 SHA256 c588adbc08b0d5b0df68d14e719202d3d4c22a8a0201b786927bec471ed61da7 SHA512 b631beaa062375499fdbf6129c6a7ef8151aa9f2d4e61794c56e48c218abd027b890db7b29a1c768c2d94decdb9a1194277b1da85471014b9cc09597cea7d689 WHIRLPOOL 666fb84497c7efd97023cac110f2bf545e6126663fa65cd306d2d7650d2782ea5064dc6a46ff599f94518ffc9cd10e6480568c7d4702f45baaea71eb458e1841
diff --git a/dev-php/pecl-bbcode/metadata.xml b/dev-php/pecl-bbcode/metadata.xml
new file mode 100644
index 000000000000..89ceacf36dc5
--- /dev/null
+++ b/dev-php/pecl-bbcode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+<longdescription>
+This is a quick and efficient BBCode Parsing Library.It provides various tag types,
+high speed one pass parsing, callback system, tag position restriction.
+It will force closing BBCode tags in the good order, and closing terminating tags
+at the end of the string this is in order to ensure HTML Validity in all cases.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r1.ebuild b/dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r1.ebuild
new file mode 100644
index 000000000000..7d57f022219f
--- /dev/null
+++ b/dev-php/pecl-bbcode/pecl-bbcode-1.0.3_beta1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="bbcode"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="TODO"
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+MY_PV="${PV/_beta/b}"
+PECL_PKG_V="${PECL_PKG}-${MY_PV}"
+S="${WORKDIR}/${PECL_PKG_V}"
+
+inherit php-ext-pecl-r2
+
+KEYWORDS="~amd64 ~x86"
+
+FILENAME="${PECL_PKG_V}.tgz"
+SRC_URI="http://pecl.php.net/get/${FILENAME}"
+HOMEPAGE="http://pecl.php.net/${PECL_PKG}"
+
+DESCRIPTION="A quick and efficient BBCode Parsing Library"
+LICENSE="PHP-3.01 BSD"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""