summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-03-06 23:24:15 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-03-07 00:17:19 +0000
commitd975b18b5a8c6739e9914bdff3e2fb8fdb268b46 (patch)
treed8bcb4ee7fef54c66a46177c0696be3ab405048a /dev-python/HeapDict
parentdev-python/sortedcollections: initial import (diff)
downloadgentoo-d975b18b5a8c6739e9914bdff3e2fb8fdb268b46.tar.gz
gentoo-d975b18b5a8c6739e9914bdff3e2fb8fdb268b46.tar.bz2
gentoo-d975b18b5a8c6739e9914bdff3e2fb8fdb268b46.zip
dev-python/HeapDict: initial import
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python/HeapDict')
-rw-r--r--dev-python/HeapDict/HeapDict-1.0.0.ebuild20
-rw-r--r--dev-python/HeapDict/Manifest1
-rw-r--r--dev-python/HeapDict/metadata.xml15
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/HeapDict/HeapDict-1.0.0.ebuild b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
new file mode 100644
index 000000000000..793540461792
--- /dev/null
+++ b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Heap with decrease-key and increase-key operations"
+HOMEPAGE="http://stutzbachenterprises.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/HeapDict/Manifest b/dev-python/HeapDict/Manifest
new file mode 100644
index 000000000000..b88ed73ec0e5
--- /dev/null
+++ b/dev-python/HeapDict/Manifest
@@ -0,0 +1 @@
+DIST HeapDict-1.0.0.tar.gz 7713 SHA256 40c9e3680616cfdf942f77429a3a9e0a76f31ce965d62f4ffbe63a83a5ef1b5a SHA512 1210acd3a6f3e091132d8b87963ec46c81d3141e1788c2a127fe348a9052d73225036aeabffc6a2089c7811b8571a43477055b746df6b128a645123862076bb5 WHIRLPOOL ad5ea24622e8a78688ee6a7e4e0bca188fbccf477d521fc42b223319ca610fd7c255c0ad817e31e0c0ef429645e71bc650089bd16e45698a4df1d16b97613927
diff --git a/dev-python/HeapDict/metadata.xml b/dev-python/HeapDict/metadata.xml
new file mode 100644
index 000000000000..a59ab0464cae
--- /dev/null
+++ b/dev-python/HeapDict/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ heapdict implements the MutableMapping ABC, meaning it works pretty much like a regular Python dict.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">HeapDict</remote-id>
+ <remote-id type="github">dask/zict</remote-id>
+ </upstream>
+</pkgmetadata>