summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-12-10 22:23:34 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-12-10 22:30:47 -0600
commitf218efbf113022b7bd647c596b427ec91c016d78 (patch)
tree0db1e9c75e01058cf271a48ded0a60497154ed2f /dev-python/aiosmtpd
parentsys-apps/portage: version bump to 2.3.18 (diff)
downloadgentoo-f218efbf113022b7bd647c596b427ec91c016d78.tar.gz
gentoo-f218efbf113022b7bd647c596b427ec91c016d78.tar.bz2
gentoo-f218efbf113022b7bd647c596b427ec91c016d78.zip
dev-python/aiosmtpd: 1.0 for mailman-3.1.1
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index 35bdebd8ba99..725fae4abd87 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -1 +1,2 @@
+DIST aiosmtpd-1.0.tar.gz 49930 BLAKE2B 7c8f845746b51e2b77f2ff00de2c88c3a090a4cd65e55fa69fc371f8ac5a2966c31e3e7184188a1b4af1f5c3d22b7af5655c5673d199b9920865ddf56c119a06 SHA512 874b3505dd35cbb176cba058a8816329eb4177db705b10c3883f88d76e3f587efc35543812fd36a03f453c8c1ee359bb3f0239d8a246908c5c17b59be134d933
DIST aiosmtpd-1.1.tar.gz 50722 BLAKE2B c7d21eea7816a758fb69061c0f1c4c5dbb7bd28a6daddc436211e4d8066380847255af537904ad5c09badb813269d0bc4b54dbb527b7b0c717d498c9475c8c2d SHA512 b61df616f2e14d1da67ac05149543bf48b14a31d44437d9a1dd11b166b98b56220c00e7c55e18d4fd99872d724e23f272922dd3548150632a189d9cb9b652883
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
new file mode 100644
index 000000000000..8595ce17c0db
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 python3_5 python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="http://aiosmtpd.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/atpublic[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ rm -r examples
+ distutils-r1_python_prepare_all
+}