summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-09-17 07:28:13 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-09-17 08:24:51 +0200
commit9909e1dd8315f693f9d7032f7bf7cb26e0d2c150 (patch)
treecbc5ce6502d07f0ed44b205f3b55f1ca8c6962bc /dev-python/alembic
parentdev-ruby/sshkit: add 1.11.3 (diff)
downloadgentoo-9909e1dd8315f693f9d7032f7bf7cb26e0d2c150.tar.gz
gentoo-9909e1dd8315f693f9d7032f7bf7cb26e0d2c150.tar.bz2
gentoo-9909e1dd8315f693f9d7032f7bf7cb26e0d2c150.zip
dev-python/alembic: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-0.8.8.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index d65cc147c013..f3894ad8f66a 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -4,3 +4,4 @@ DIST alembic-0.8.4.tar.gz 950696 SHA256 8507fc12ccc99321da2fa117dde4b5d8664ff5ef
DIST alembic-0.8.5.tar.gz 959286 SHA256 de8ca3b1d806cd39bf8a21d90f5c5822a2173b721ec20f868da38edd45b58cb2 SHA512 bc60363cc1dc4ee7dbc0b788f7ec638e3338b83dcca5858432bff1672c7bf5bbe8ba7522d80002140e8075017f1d5861ffb69b9c027790adc1b589484ad7448e WHIRLPOOL 4e2089237c427455c75e297f628af461f6a5fbf0195d48f531e419541878c525ce7d38da58964fde91e957c9ebdbba54372c9bae684cc4716d546d9c8105b2c2
DIST alembic-0.8.6.tar.gz 961323 SHA256 53403da066ef90cbc5a3f801f3dd39bbbfbc41b0a84eb8c1c806243b7e2c6466 SHA512 0537f8679d060db0b7cf6d92540d2016d05cb792e2d0984f235c0975baf4aab23cf0667a2ef21c7e8d7f8a580c0f7ee46b0e05932049323c40f7490e66150277 WHIRLPOOL 58aba9f8f0b9af9c1061c2b075c94ee2adbe0c5a3de183b70ade4bd54bc7c238a89f21b3c173bccf57a94472883300be03b3813e0d75fac51bba31f65f237a3f
DIST alembic-0.8.7.tar.gz 968161 SHA256 7fb8a456d6c47fe24b87e02acb405b2094545f9b574beb80105a64fe9b335a45 SHA512 929ae344106d2ea31d7a47cee48917825e26eb0b2b817e915bb10e142823e825a989c91d90865bad63a48e344fd0f14de97a09f45568720bd257633c437ca21e WHIRLPOOL 0b83049223d8b86251b8bdba592d3f1e4d606e370d86c0e7739d7166b99a01a55bda1c1dfed5587f6b94463f3ec98120091ebbaa883fd702770326bc4bf0a914
+DIST alembic-0.8.8.tar.gz 970125 SHA256 cd6f2192ca2307bfe2a2a61f8a261420addc59a09a6379a6550e0a15693b0b8a SHA512 201de14a204c30aa7d7b935a698931b48961111f90d20b1732d6657516be37d82b40eb0ae6cb4bb465ba57ea30922fb32bd26e9d0f61f1d56870182e31bf43a0 WHIRLPOOL 9f9899f153fe43bd3b9382fc3a61811edd1ad1e9ab386a62f40b4994667f19cd3d4719f2682fb2e152ab7abee83cbc90ef3d3bab13e7387a2d73409e8ac2ad3b
diff --git a/dev-python/alembic/alembic-0.8.8.ebuild b/dev-python/alembic/alembic-0.8.8.ebuild
new file mode 100644
index 000000000000..1fc1aaada289
--- /dev/null
+++ b/dev-python/alembic/alembic-0.8.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5)
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test doc"
+
+# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
+# because it shatters the testsuite. If 'someone' cares to adhere to correct form
+# and edit to -0.7.3, feel free, and then pick up the pieces.
+RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ rm tests/test_script_consumption.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}