summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 19:17:07 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 19:17:27 +0200
commit1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f (patch)
tree36e71ade2fa58477efdf6e74260e6ab35a80e046 /dev-python/argh
parentdev-python/iocapture: Initial import, test dep for argh (diff)
downloadgentoo-1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f.tar.gz
gentoo-1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f.tar.bz2
gentoo-1ba13926cb2af0826dfd0154f82cfa9a91f0cc5f.zip
dev-python/argh: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/argh')
-rw-r--r--dev-python/argh/Manifest1
-rw-r--r--dev-python/argh/argh-0.26.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/argh/Manifest b/dev-python/argh/Manifest
index 7090900a63cd..6ce472af5464 100644
--- a/dev-python/argh/Manifest
+++ b/dev-python/argh/Manifest
@@ -1,3 +1,4 @@
DIST argh-0.25.0.tar.gz 30865 SHA256 f55f004a9077db0abc50e8ef5c0e0d0e3573b4a1c8365439c8186ca69197ff33 SHA512 76d4a1451e7f7bb759525b4e0f7dd5fcae4528b92e2866c3d543519df0394fb8de88511869ac04e2f160ac8ae150c1f0c7d348848af2039a26f71b7179555a69 WHIRLPOOL 4fd748081b2973a87f3d425f7468e2cc03edbf64dcff785e6080829ea9728c931f236cfbb2bc6eb6599a2480adabc9448d6bdd57e9a6bb8f8af825ab1fdf2053
DIST argh-0.26.0.tar.gz 32238 SHA256 3417619f76d18cbb2d19fae4ad27a8ecf1432b22fdf8834df77cf1a1c86716a4 SHA512 be6c52b6e7b438152c145e9ce303f7ba9d44713cb0c68b2526ea725a99522f848c8afceded43da889e335656bc38f69bc4cb1dc7cb39ae238eda55083c9e9076 WHIRLPOOL b589fccf8d31d5aa543c1da9418804461acfa58b08d272cb03ea03080fc808ffc3a810cb487f0c02a94c9a47e1a392bde684850b9f8fc8bfd9b59f74309fb2ab
DIST argh-0.26.1.tar.gz 32261 SHA256 06a7442cb9130fb8806fe336000fcf20edf1f2f8ad205e7b62cec118505510db SHA512 8c286434b13fe72eca7c35313581921f49ab8934e0c791bd230ed775067507dc492b73b76c9ec521161395aeb8d1cfedc71e3251bba8f68d2227c3cf56c326bf WHIRLPOOL b33570b453f11deecddd1ec6eb2901647f24ec9c78e499ed14b97950ef09fcc4d3842a69ef802e14a218c9c376d386c5f5ec724a93af47141b1d07c9d57761da
+DIST argh-0.26.2.tar.gz 32913 SHA256 e9535b8c84dc9571a48999094fda7f33e63c3f1b74f3e5f3ac0105a58405bb65 SHA512 90382900d5cec9629dacb4459a2c9491d1425b66fa3f90d7cbf511dec846a99dbb9424f3e08f0c006da48fbf9c067078705be70b314700541fd800630e4b1707 WHIRLPOOL 1bf82170a097584f92e6a59f5a0a0d97544cc7dfc909e847faa6c84de0ee782d51601d09aec14ef99a70c39699d6b1686562b3ca71cb39d20fdd179c57e81201
diff --git a/dev-python/argh/argh-0.26.2.ebuild b/dev-python/argh/argh-0.26.2.ebuild
new file mode 100644
index 000000000000..f5245a0616e2
--- /dev/null
+++ b/dev-python/argh/argh-0.26.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple argparse wrapper"
+HOMEPAGE="http://packages.python.org/argh/"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+LICENSE="LGPL-3"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/iocapture[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy)
+ ${RDEPEND}
+ )"
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}