summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-02-18 18:50:33 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-02-18 19:05:23 +0000
commitdd405d6fe3d6502c6403a15112e6d924f5913732 (patch)
treeb0529a088c0c7afe6b3f7a22acc8e881dd05189b /dev-python/astropy
parentmedia-gfx/luminance-hdr: remove old (diff)
downloadgentoo-dd405d6fe3d6502c6403a15112e6d924f5913732.tar.gz
gentoo-dd405d6fe3d6502c6403a15112e6d924f5913732.tar.bz2
gentoo-dd405d6fe3d6502c6403a15112e6d924f5913732.zip
dev-python/astropy: removed old
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/astropy-1.0.4.ebuild84
-rw-r--r--dev-python/astropy/files/astropy-9999-system-pytest.patch16
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/astropy/astropy-1.0.4.ebuild b/dev-python/astropy/astropy-1.0.4.ebuild
deleted file mode 100644
index a9ca39d03ede..000000000000
--- a/dev-python/astropy/astropy-1.0.4.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Core functionality for performing astrophysics with Python"
-HOMEPAGE="http://astropy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- >=dev-libs/expat-2.1.0:0=
- dev-python/configobj[${PYTHON_USEDEP}]
- <dev-python/numpy-1.10[${PYTHON_USEDEP}]
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=sci-astronomy/erfa-1.2:0=
- >=sci-astronomy/wcslib-4.25:0=
- >=sci-libs/cfitsio-3.350:0=
- sys-libs/zlib:0="
-DEPEND="${RDEPEND}
- dev-python/astropy-helpers[${PYTHON_USEDEP}]
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? (
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- media-gfx/graphviz
- )
- test? (
- dev-libs/libxml2[${PYTHON_USEDEP}]
- dev-python/h5py[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/${P}-disable_helper.patch"
- "${FILESDIR}/${P}-system-six.patch"
- "${FILESDIR}/${P}-system-pytest.patch"
- "${FILESDIR}/${P}-system-configobj.patch"
- )
-
-python_prepare_all() {
- export mydistutilsargs="--offline"
- rm -r ${PN}_helpers || die
- cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
- rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
-
- echo "[build]" >> setup.cfg
- echo "use_system_libraries=1" >> setup.cfg
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- python_export_best
- VARTEXFONTS="${T}"/fonts \
- MPLCONFIGDIR="${BUILD_DIR}" \
- PYTHONPATH="${BUILD_DIR}"/lib \
- esetup.py build_sphinx
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/astropy/files/astropy-9999-system-pytest.patch b/dev-python/astropy/files/astropy-9999-system-pytest.patch
deleted file mode 100644
index 19b321d2a019..000000000000
--- a/dev-python/astropy/files/astropy-9999-system-pytest.patch
+++ /dev/null
@@ -1,16 +0,0 @@
- astropy/tests/helper.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/astropy/tests/helper.py b/astropy/tests/helper.py
-index 97d2617..a75db15 100644
---- a/astropy/tests/helper.py
-+++ b/astropy/tests/helper.py
-@@ -42,7 +42,7 @@ __all__ = ['raises', 'enable_deprecations_as_exceptions', 'remote_data',
- 'pickle_protocol', 'generic_recursive_equality_test']
-
-
--if os.environ.get('ASTROPY_USE_SYSTEM_PYTEST') or '_pytest' in sys.modules:
-+if True or os.environ.get('ASTROPY_USE_SYSTEM_PYTEST') or '_pytest' in sys.modules:
- import pytest
-
- else: