summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2016-06-09 16:28:24 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2016-06-09 17:23:36 +0000
commit2fdf0732a95aedb28d32507e260c959db0675f9a (patch)
tree78c3e8bac130ef3072b87162210cf204feb03638 /dev-python/astroquery
parentdev-python/aplpy: drop old (diff)
downloadgentoo-2fdf0732a95aedb28d32507e260c959db0675f9a.tar.gz
gentoo-2fdf0732a95aedb28d32507e260c959db0675f9a.tar.bz2
gentoo-2fdf0732a95aedb28d32507e260c959db0675f9a.zip
dev-python/astroquery: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/astroquery')
-rw-r--r--dev-python/astroquery/Manifest1
-rw-r--r--dev-python/astroquery/astroquery-0.3.2.ebuild60
-rw-r--r--dev-python/astroquery/metadata.xml9
3 files changed, 65 insertions, 5 deletions
diff --git a/dev-python/astroquery/Manifest b/dev-python/astroquery/Manifest
index e68dfc9f7452..0f04dd09c76d 100644
--- a/dev-python/astroquery/Manifest
+++ b/dev-python/astroquery/Manifest
@@ -1 +1,2 @@
DIST astroquery-0.3.1.tar.gz 2786634 SHA256 ad67bf4f31bc9e0c45621a19f7200d701ff7b5df2d78e9ba7095e65a2f69c50d SHA512 e92f10dcdc4ced5c6841b35b7afc0ae645231810ae2951a04cc1c014819096bfd9296b1bc6d0f925a59e64e9011ec3f2436e36d0ec2181d271eb0aeba80906c8 WHIRLPOOL ac91041f9bce69945000ded78a39992d724ce7a32937c4803daa51556c2b8ef4984c8da5b6ae1ae4b1e1747ae6ce83d13ee180bbe361b0aaa9ae6a7900010000
+DIST astroquery-0.3.2.tar.gz 2391386 SHA256 06a03e38bdc8e193f8729f1b3c0ae7e2fb364187e2215d7ad2a20aef44feff3d SHA512 445d1578cd8c86cdfdfba4cc25868c31884ef764b4617da982e24403d9d071cc80e54bd431a50da433f2775ee4dbf747129268b244448cbac4438a21fd16ddad WHIRLPOOL c7227cf827d88d02b093bbf34e6b009053fa6b6dab49258e7c677fc2fec9228e39379c255ccca9b89cae932be97279107eae8a2bf292888d7f5697f8c62678a4
diff --git a/dev-python/astroquery/astroquery-0.3.2.ebuild b/dev-python/astroquery/astroquery-0.3.2.ebuild
new file mode 100644
index 000000000000..51c8a0a93427
--- /dev/null
+++ b/dev-python/astroquery/astroquery-0.3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of packages to access online astronomical resources"
+HOMEPAGE="https://github.com/astropy/astroquery"
+SRC_URI="https://github.com/astropy/astroquery/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+DOCS=( README.rst )
+
+RDEPEND="
+ dev-python/astropy[${PYTHON_USEDEP}]
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/aplpy[${PYTHON_USEDEP}]
+ dev-python/pyregion[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -i -e '/auto_use/s/True/False/' setup.cfg || die
+ sed -i -e "s/= 'APLpy'/= 'aplpy'/" astroquery/conftest.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_compile_all() {
+ if use doc; then
+ python_setup
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astroquery/metadata.xml b/dev-python/astroquery/metadata.xml
index 224276aae91b..ebe241d95c8a 100644
--- a/dev-python/astroquery/metadata.xml
+++ b/dev-python/astroquery/metadata.xml
@@ -6,12 +6,11 @@
<name>Gentoo Astronomy Project</name>
</maintainer>
<longdescription lang="en">
- Astroquery is a package containing a collection of tools to use
- online astronomical databases. It integrates with Astropy and aims
- to support many services with a uniform API.
- </longdescription>
+ Astroquery is a package containing a collection of tools to use
+ online astronomical databases. It integrates with Astropy and aims
+ to support many services with a uniform API.
+ </longdescription>
<upstream>
- <remote-id type="pypi">astroquery</remote-id>
<remote-id type="github">astropy/astroquery</remote-id>
</upstream>
</pkgmetadata>