summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-05-27 17:34:40 +0200
committerDavid Seifert <soap@gentoo.org>2017-05-27 17:36:03 +0200
commit1388b94c2e3bb1463199f270814a4ef0fb9acffb (patch)
tree778e45aaafb512263fb5ed644d020de5a6b83fdc /dev-python/autopep8/autopep8-1.3.2.ebuild
parentdev-python/autopep8: Version bump to 1.3.1 (diff)
downloadgentoo-1388b94c2e3bb1463199f270814a4ef0fb9acffb.tar.gz
gentoo-1388b94c2e3bb1463199f270814a4ef0fb9acffb.tar.bz2
gentoo-1388b94c2e3bb1463199f270814a4ef0fb9acffb.zip
dev-python/autopep8: Version bump to 1.3.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/autopep8/autopep8-1.3.2.ebuild')
-rw-r--r--dev-python/autopep8/autopep8-1.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/autopep8/autopep8-1.3.2.ebuild b/dev-python/autopep8/autopep8-1.3.2.ebuild
new file mode 100644
index 000000000000..32c6043fa952
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.python.org/pypi/autopep8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pydiff-0.1.2[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Prevent UnicodeDecodeError with LANG=C
+ sed -e "/é/d" -i MANIFEST.in || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}