summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/babelfish
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/babelfish')
-rw-r--r--dev-python/babelfish/Manifest3
-rw-r--r--dev-python/babelfish/babelfish-0.4.0.ebuild26
-rw-r--r--dev-python/babelfish/babelfish-0.5.1.ebuild26
-rw-r--r--dev-python/babelfish/babelfish-0.5.3.ebuild26
-rw-r--r--dev-python/babelfish/babelfish-9999.ebuild26
-rw-r--r--dev-python/babelfish/metadata.xml12
6 files changed, 119 insertions, 0 deletions
diff --git a/dev-python/babelfish/Manifest b/dev-python/babelfish/Manifest
new file mode 100644
index 000000000000..c99b2e078e45
--- /dev/null
+++ b/dev-python/babelfish/Manifest
@@ -0,0 +1,3 @@
+DIST babelfish-0.4.0.tar.gz 89386 SHA256 1c22bf70ecc61d0ebe637edc3868dfb146dc5a458be353b20386406e28a18710 SHA512 f9e2cf8ec367cead528d99019fc1e597a94b6654cd2b5c39ba3e2deb9e579bd8af54f463510f709c5c540911e01ed830511f833fe2400bd7ec6a70cd05ee642f WHIRLPOOL 0034705cf62bde3851e9edc4cc63316c4874c404c65fd0ff33937acb1fc4da29e54ad03aa8e11ecf98bcf0f8bc5f2c1b89be7963f63611a481650dfc709e73ab
+DIST babelfish-0.5.1.tar.gz 89683 SHA256 bd78ecacc684aac8939c2937fe25c85179123940997943381ae9c22e37bf964f SHA512 24f192867ba5e34fbe5f5f90cae479b095577b6b6a0a0f6e778f68130b0010c382e204cb1da15f062929ce231f3f9a5bb5c7e4c01a4a2dcbf975e884a25e4210 WHIRLPOOL 3f0dc56b981ac2ec59bb4ba88f27419de0e7276fbd05e845c76f46081afb2561e6852081a1be6f0df36a9fe110419c49679d8e4255ca4e1b37e6689133b05114
+DIST babelfish-0.5.3.tar.gz 90579 SHA256 4fbdd172d0feec0861ccf9ed8e36abb09d36c88c216eeedca2661fec5b103c73 SHA512 c419f8d881ba9995f45f212b7182d2f95a28b5fd911933a1c10768506682068abc7ea0394d6ef6dc337be47f601ae479582571c6d1753870671dec77e67156a9 WHIRLPOOL f64268ca394f19be03a67aa38de7dade7b0d17219c2d5b4db994d6e0d32f067b899a8aaa548fa5cbcb067efd67b7a123407d9d69d081521cf09b13d51857812c
diff --git a/dev-python/babelfish/babelfish-0.4.0.ebuild b/dev-python/babelfish/babelfish-0.4.0.ebuild
new file mode 100644
index 000000000000..0be5e03193af
--- /dev/null
+++ b/dev-python/babelfish/babelfish-0.4.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.python.org/pypi/babelfish"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/babelfish/babelfish-0.5.1.ebuild b/dev-python/babelfish/babelfish-0.5.1.ebuild
new file mode 100644
index 000000000000..c3f6b28af6ad
--- /dev/null
+++ b/dev-python/babelfish/babelfish-0.5.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.python.org/pypi/babelfish"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/babelfish/babelfish-0.5.3.ebuild b/dev-python/babelfish/babelfish-0.5.3.ebuild
new file mode 100644
index 000000000000..c3f6b28af6ad
--- /dev/null
+++ b/dev-python/babelfish/babelfish-0.5.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.python.org/pypi/babelfish"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/babelfish/babelfish-9999.ebuild b/dev-python/babelfish/babelfish-9999.ebuild
new file mode 100644
index 000000000000..1466a6dabaf8
--- /dev/null
+++ b/dev-python/babelfish/babelfish-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+EGIT_REPO_URI="https://github.com/Diaoul/babelfish.git"
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python library to work with countries and languages"
+HOMEPAGE="https://github.com/Diaoul/babelfish https://pypi.python.org/pypi/babelfish"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/babelfish/metadata.xml b/dev-python/babelfish/metadata.xml
new file mode 100644
index 000000000000..9c1f37903127
--- /dev/null
+++ b/dev-python/babelfish/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nikoli@gmx.us</email>
+ </maintainer>
+ <herd>proxy-maintainers</herd>
+ <upstream>
+ <remote-id type="pypi">babelfish</remote-id>
+ <remote-id type="github">Diaoul/babelfish</remote-id>
+ </upstream>
+</pkgmetadata>