summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/backports-shutil_get_terminal_size
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/backports-shutil_get_terminal_size')
-rw-r--r--dev-python/backports-shutil_get_terminal_size/Manifest1
-rw-r--r--dev-python/backports-shutil_get_terminal_size/backports-shutil_get_terminal_size-1.0.0-r1.ebuild33
-rw-r--r--dev-python/backports-shutil_get_terminal_size/metadata.xml12
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/backports-shutil_get_terminal_size/Manifest b/dev-python/backports-shutil_get_terminal_size/Manifest
new file mode 100644
index 000000000000..2377e96f8d1a
--- /dev/null
+++ b/dev-python/backports-shutil_get_terminal_size/Manifest
@@ -0,0 +1 @@
+DIST backports.shutil_get_terminal_size-1.0.0.tar.gz 4279 SHA256 713e7a8228ae80341c70586d1cc0a8caa5207346927e23d09dcbcaf18eadec80 SHA512 b74341c6616f9aace5abcc7fd657fc33801b558b6227c533002ccaf588734490b465a4a27d2bdc8047a385771afdcded610edef832dfa5ef24632f4541729050 WHIRLPOOL a04b702aba3b9892ca5b86b284e6945e1980e135946c04abef2b95a3e12a230eb7c99b20418a4dc21f8c3f7b20715daa75d89d61fbea248d788f0aef5326cd07
diff --git a/dev-python/backports-shutil_get_terminal_size/backports-shutil_get_terminal_size-1.0.0-r1.ebuild b/dev-python/backports-shutil_get_terminal_size/backports-shutil_get_terminal_size-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..4e9b2fd6b7af
--- /dev/null
+++ b/dev-python/backports-shutil_get_terminal_size/backports-shutil_get_terminal_size-1.0.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="backports.shutil_get_terminal_size"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A backport of the get_terminal_size function from Python 3.3's shutil"
+HOMEPAGE="https://pypi.python.org/pypi/backports.shutil_get_terminal_size/ https://github.com/chrippa/backports.shutil_get_terminal_size"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/backports[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}
+
+python_install() {
+ distutils-r1_python_install
+
+ # main namespace provided by dev-python/backports
+ rm "${ED}$(python_get_sitedir)"/backports/__init__.py* || die
+}
diff --git a/dev-python/backports-shutil_get_terminal_size/metadata.xml b/dev-python/backports-shutil_get_terminal_size/metadata.xml
new file mode 100644
index 000000000000..d3339604a9fc
--- /dev/null
+++ b/dev-python/backports-shutil_get_terminal_size/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ <name>Justin Lecher</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">backports.shutil_get_terminal_size</remote-id>
+ <remote-id type="github">chrippa/backports.shutil_get_terminal_size</remote-id>
+ </upstream>
+</pkgmetadata>