summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-06-28 23:08:53 +0200
committerPacho Ramos <pacho@gentoo.org>2018-06-28 23:08:53 +0200
commit6e45abc3a1ef597bfd69734b20d6a31291624394 (patch)
tree79152694e37e9e474c7a156fb61fe1256a20090c /dev-python/bokeh
parentdev-ada/xmlada: xmlada-2018 does not work with gnat_2016 (diff)
downloadgentoo-6e45abc3a1ef597bfd69734b20d6a31291624394.tar.gz
gentoo-6e45abc3a1ef597bfd69734b20d6a31291624394.tar.bz2
gentoo-6e45abc3a1ef597bfd69734b20d6a31291624394.zip
dev-python/bokeh: Drop old
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/bokeh')
-rw-r--r--dev-python/bokeh/bokeh-0.12.4.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/bokeh/bokeh-0.12.4.ebuild b/dev-python/bokeh/bokeh-0.12.4.ebuild
deleted file mode 100644
index 13a916ab9c62..000000000000
--- a/dev-python/bokeh/bokeh-0.12.4.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Statistical and interactive HTML plots for Python"
-HOMEPAGE="https://bokeh.pydata.org/en/latest/
- https://github.com/bokeh/bokeh
- https://pypi.org/project/bokeh/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="examples test"
-
-RDEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- >=net-libs/nodejs-4.1
- >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
- test? (
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/boto[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/flake8[${PYTHON_USEDEP}]
- dev-python/pandas[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/flexx[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/selenium[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- )
-"
-
-python_compile() {
- esetup.py build --build-js
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- py.test -m 'not (js or examples or integration)' -vv || die
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}