summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/cangjie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/cangjie')
-rw-r--r--dev-python/cangjie/Manifest2
-rw-r--r--dev-python/cangjie/cangjie-1.1.ebuild35
-rw-r--r--dev-python/cangjie/cangjie-1.2.ebuild37
-rw-r--r--dev-python/cangjie/files/cangjie-1.2-cython-022.patch25
-rw-r--r--dev-python/cangjie/metadata.xml14
5 files changed, 113 insertions, 0 deletions
diff --git a/dev-python/cangjie/Manifest b/dev-python/cangjie/Manifest
new file mode 100644
index 000000000000..7960a881f1a8
--- /dev/null
+++ b/dev-python/cangjie/Manifest
@@ -0,0 +1,2 @@
+DIST cangjie-1.1.tar.xz 221460 SHA256 97391213ec80f885a5dc8fb9e61f3ab511e8106f3dc924535af41822c0c8ac6f SHA512 ef1acd9fcfb8f3da94fa282c173bd82ed7f827f9b33921689e2a811fc9268dfdc25bec6f53ac448cea85b220790f5816c0ee0e4ed95750afab4312850cc14df2 WHIRLPOOL f28aaef1ae982e9cddb85477c1bbc4d4fad4753fe663d4d25cf593f011c1b3305947795683520152a26e42a60d9aeb09e61cdd71704a4a4af9a716cb1634c771
+DIST cangjie-1.2.tar.xz 221524 SHA256 bc9115904f65581a11e43044c83e999e583468d1bb98c04b33ea059205e07c10 SHA512 4cc3e0e4a77b671c93fe39f17c970d458d6d935c1efa33f9d8de0a0311ed6c3a444fd41431d553f70f3e96065f8136801128d8b16c86d0340c78ab560bd9e63f WHIRLPOOL 72f3b532bf149df0740fc9d3fd137416cb29a0db81285fd67cd51d3a47d34fd2a32655302a912d5caf8666ef55550d2f84242021163bfff12d5734b2d820f13c
diff --git a/dev-python/cangjie/cangjie-1.1.ebuild b/dev-python/cangjie/cangjie-1.1.ebuild
new file mode 100644
index 000000000000..573d32aa4e6e
--- /dev/null
+++ b/dev-python/cangjie/cangjie-1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="The Python bindings to libcangjie"
+HOMEPAGE="http://cangjians.github.io"
+SRC_URI="http://cangjians.github.io/downloads/pycangjie/cangjie-${PV}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ app-i18n/libcangjie
+ dev-python/cython
+ >=dev-python/cython-0.14"
+RDEPEND="app-i18n/libcangjie
+ ${PYTHON_DEPS}"
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+}
diff --git a/dev-python/cangjie/cangjie-1.2.ebuild b/dev-python/cangjie/cangjie-1.2.ebuild
new file mode 100644
index 000000000000..c7c5167a33f3
--- /dev/null
+++ b/dev-python/cangjie/cangjie-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="The Python bindings to libcangjie"
+HOMEPAGE="http://cangjians.github.io"
+SRC_URI="https://github.com/Cangjians/pycangjie/releases/download/v${PV}/cangjie-${PV}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${PYTHON_DEPS}
+ app-i18n/libcangjie
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+RDEPEND="app-i18n/libcangjie
+ ${PYTHON_DEPS}"
+
+PATCHES=( "${FILESDIR}/${P}-cython-022.patch" )
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+}
diff --git a/dev-python/cangjie/files/cangjie-1.2-cython-022.patch b/dev-python/cangjie/files/cangjie-1.2-cython-022.patch
new file mode 100644
index 000000000000..ac2695c9e139
--- /dev/null
+++ b/dev-python/cangjie/files/cangjie-1.2-cython-022.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile.am b/Makefile.am
+index 6762b97..c0cc699 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -47,19 +47,19 @@ pkgpyexecdir = $(pyexecdir)/cangjie
+
+ src/cangjie/_core.c: src/cangjie/_core.pyx src/cangjie/_core.pxd
+ $(MKDIR_P) src/cangjie
+- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/_core.pyx
++ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/_core.pyx
+
+ src/cangjie/errors.c: src/cangjie/errors.pyx src/cangjie/_core.pxd
+ $(MKDIR_P) src/cangjie
+- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/errors.pyx
++ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/errors.pyx
+
+ src/cangjie/filters.c: src/cangjie/filters.pyx src/cangjie/_core.pxd
+ $(MKDIR_P) src/cangjie
+- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/filters.pyx
++ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/filters.pyx
+
+ src/cangjie/versions.c: src/cangjie/versions.pyx src/cangjie/_core.pxd
+ $(MKDIR_P) src/cangjie
+- $(CYTHON) -3 --verbose -o $@ $(srcdir)/src/cangjie/versions.pyx
++ $(CYTHON) -3 --verbose -o $@ -I $(srcdir)/src/cangjie $(srcdir)/src/cangjie/versions.pyx
diff --git a/dev-python/cangjie/metadata.xml b/dev-python/cangjie/metadata.xml
new file mode 100644
index 000000000000..a99f2d36aae1
--- /dev/null
+++ b/dev-python/cangjie/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cjk</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>brendan@horan.hk</email>
+ <name>Brendan Horan</name>
+ <description>Proxy - Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Cangjians/pycangjie</remote-id>
+ </upstream>
+</pkgmetadata>