summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-24 19:44:55 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-24 19:45:04 +0200
commit4ffe26a218da60b670a507acb4490cd44d42e324 (patch)
treef3df761135677cd70ff12dacae5117e08f0dc0f5 /dev-python/capturer
parentdev-java/jamvm: Sort out patch naming convention. Fixes bug 563988. (diff)
downloadgentoo-4ffe26a218da60b670a507acb4490cd44d42e324.tar.gz
gentoo-4ffe26a218da60b670a507acb4490cd44d42e324.tar.bz2
gentoo-4ffe26a218da60b670a507acb4490cd44d42e324.zip
dev-python/capturer: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/capturer')
-rw-r--r--dev-python/capturer/Manifest1
-rw-r--r--dev-python/capturer/capturer-2.1.1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/capturer/Manifest b/dev-python/capturer/Manifest
index a4a8ea3a5228..02c9a8e41d0e 100644
--- a/dev-python/capturer/Manifest
+++ b/dev-python/capturer/Manifest
@@ -1 +1,2 @@
+DIST capturer-2.1.1.tar.gz 17404 SHA256 6d892baca28c32ba912d96dfc5d40972090437d7d8d1738453969a0700a272e4 SHA512 44442da3cfffaff0b5bf4ec71c189d8a5f3436d5e13f2b20a3c26ff02f740144cabf7c7de7a2dd606f056a262f71d7092cdb677062e2ea912f542da2011f00f7 WHIRLPOOL b50ccc40be42508255390bcd0a52e610ffcc9ce7d59a39c426937e81d85e3c1c009b4f0ddc057a44e0b591d54d0c55e70c35740f095f514313b3bd3f414d15b5
DIST capturer-2.1.tar.gz 17380 SHA256 6837c34651d50615e20281a1cc73a2b363bb7b7c9451003d08ea481a58a6bbb8 SHA512 30325a4908b63cdc63439fe2dab360f37db1f335d44ba10cf03294513cf2ffd6688843659d16b6c96bca44440fbbf607b8b20c5031ee99b8973a26460e37ff72 WHIRLPOOL 47a3f37e200c4c7100baba4acc0dd3bf443e634b4d85d25e50e09a7db28477966a0247c85e0365d0b53d74c5247d4d0fcfc455ca77e5d0c743f410e61d6c588f
diff --git a/dev-python/capturer/capturer-2.1.1.ebuild b/dev-python/capturer/capturer-2.1.1.ebuild
new file mode 100644
index 000000000000..d51e02660bf6
--- /dev/null
+++ b/dev-python/capturer/capturer-2.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.org/ https://pypi.python.org/pypi/capturer https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Test fails only ebuild, but works manually
+# Can't find out what it is
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}