summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-04-29 10:34:33 +0100
committerJustin Lecher <jlec@gentoo.org>2017-04-29 19:49:13 +0100
commit6f1701df906ce878421ca05934a4f66aad23ecfe (patch)
treef923571f1c0a05e242fda4c3f06450a9eb8c94fe /dev-python/capturer
parentdev-python/verboselogs: Version Bump and Py3.6 support (diff)
downloadgentoo-6f1701df906ce878421ca05934a4f66aad23ecfe.tar.gz
gentoo-6f1701df906ce878421ca05934a4f66aad23ecfe.tar.bz2
gentoo-6f1701df906ce878421ca05934a4f66aad23ecfe.zip
dev-python/capturer: Version Bump and Py3.6 support
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/capturer')
-rw-r--r--dev-python/capturer/Manifest1
-rw-r--r--dev-python/capturer/capturer-2.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/capturer/Manifest b/dev-python/capturer/Manifest
index 02c9a8e41d0e..a6af0800cc05 100644
--- a/dev-python/capturer/Manifest
+++ b/dev-python/capturer/Manifest
@@ -1,2 +1,3 @@
DIST capturer-2.1.1.tar.gz 17404 SHA256 6d892baca28c32ba912d96dfc5d40972090437d7d8d1738453969a0700a272e4 SHA512 44442da3cfffaff0b5bf4ec71c189d8a5f3436d5e13f2b20a3c26ff02f740144cabf7c7de7a2dd606f056a262f71d7092cdb677062e2ea912f542da2011f00f7 WHIRLPOOL b50ccc40be42508255390bcd0a52e610ffcc9ce7d59a39c426937e81d85e3c1c009b4f0ddc057a44e0b591d54d0c55e70c35740f095f514313b3bd3f414d15b5
DIST capturer-2.1.tar.gz 17380 SHA256 6837c34651d50615e20281a1cc73a2b363bb7b7c9451003d08ea481a58a6bbb8 SHA512 30325a4908b63cdc63439fe2dab360f37db1f335d44ba10cf03294513cf2ffd6688843659d16b6c96bca44440fbbf607b8b20c5031ee99b8973a26460e37ff72 WHIRLPOOL 47a3f37e200c4c7100baba4acc0dd3bf443e634b4d85d25e50e09a7db28477966a0247c85e0365d0b53d74c5247d4d0fcfc455ca77e5d0c743f410e61d6c588f
+DIST capturer-2.3.tar.gz 18380 SHA256 3e4a1edbe96275e33bdf5836fe5c244202bc7acbc675dce73b0f082240cacb69 SHA512 267c6238ab143894f3d74002334b99e3d1a59a3bf30f5ad04d6f1a81c9439b1369fe161859f86924280e3b9e47536e53a0a80045acda9ae471ded7d751e01470 WHIRLPOOL 59d84da0b34740381ff138d8179a75f025b3ecb2714ff1255a4cef294d8ec42fea81fd02d392874d0b09bd1d0ed00186fbb9db1e7a431c7a4d5d4ebdabbc8a38
diff --git a/dev-python/capturer/capturer-2.3.ebuild b/dev-python/capturer/capturer-2.3.ebuild
new file mode 100644
index 000000000000..52d6f3a24dc7
--- /dev/null
+++ b/dev-python/capturer/capturer-2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.org/ https://pypi.python.org/pypi/capturer https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/humanfriendly-2.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+# Test fails only ebuild, but works manually
+# Can't find out what it is
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}