summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-20 10:28:19 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-20 11:33:39 +0200
commitbb3abd1953f918dfa668c6d524eadf75d80cdd8e (patch)
tree03c4b2432fe3ae22110edf230dcd0f58038f61e2 /dev-python/click
parentdev-python/setuptools: Version Bump (diff)
downloadgentoo-bb3abd1953f918dfa668c6d524eadf75d80cdd8e.tar.gz
gentoo-bb3abd1953f918dfa668c6d524eadf75d80cdd8e.tar.bz2
gentoo-bb3abd1953f918dfa668c6d524eadf75d80cdd8e.zip
dev-python/click: Add pypy3 support
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/click')
-rw-r--r--dev-python/click/click-4.1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/click/click-4.1.ebuild b/dev-python/click/click-4.1.ebuild
index 9b842ec288b2..d7025a48c942 100644
--- a/dev-python/click/click-4.1.ebuild
+++ b/dev-python/click/click-4.1.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
@@ -14,10 +15,10 @@ HOMEPAGE="http://click.pocoo.org/ https://pypi.python.org/pypi/click"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE="doc examples test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
"
@@ -37,7 +38,7 @@ python_test() {
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
+ use doc && local HTML_DOCS=( docs/_build/html/. )
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
}