summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-01 08:40:32 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-01 09:03:13 +0200
commit5587422114688eb5148b7bf0965674e60c7ed159 (patch)
treeb1c2a377f36fe3ccc394657116001afdb822a018 /dev-python/cython
parentsci-biology/rebase: Cleaned old (diff)
downloadgentoo-5587422114688eb5148b7bf0965674e60c7ed159.tar.gz
gentoo-5587422114688eb5148b7bf0965674e60c7ed159.tar.bz2
gentoo-5587422114688eb5148b7bf0965674e60c7ed159.zip
dev-python/cython: Version Bump
Package-Manager: portage-2.2.22 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/cython')
-rw-r--r--dev-python/cython/Manifest1
-rw-r--r--dev-python/cython/cython-0.23.3.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/cython/Manifest b/dev-python/cython/Manifest
index f8c9951ab15d..29077287b6c7 100644
--- a/dev-python/cython/Manifest
+++ b/dev-python/cython/Manifest
@@ -1,2 +1,3 @@
DIST Cython-0.22.tar.gz 1584483 SHA256 14307e7a69af9a0d0e0024d446af7e51cc0e3e4d0dfb10d36ba837e5e5844015 SHA512 856220fa579e272ac38dcef091760f527431ff3b98df9af6e68416fcf77d9659ac5abe5c7dee41331f359614637a4ff452033085335ee499830ed126ab584267 WHIRLPOOL d9919e1fe33f7ea02833c485e10667d8470d7c69901b2419c6c4c1d464f9ef2444795e14903cc66b6fee40ec5a4c20308c331ad93fd8818f207d0a21cccf9b2b
DIST Cython-0.23.2.tar.gz 1627642 SHA256 85a8713db65d9ad3e7e2f01e6ac424d4ae2a40349f1391b2b0f494ccb7e0fda7 SHA512 ae1d20f3efc2ae9eeb73d1d536895992280b4b3222bd6911bae886971cb222c98a581a770c48d65ec1fa40cfa7b7639580fe86e4986b5fba5c9257d351dfc1a3 WHIRLPOOL c019b43508104f0ce9375b1eed740d9bf4ba9bdff66fccbc4b272f61a9899327d1e3a1026215f4014db89aefb0f69caafd4e055271cd67500b95ad3fb3ab5263
+DIST Cython-0.23.3.tar.gz 1628634 SHA256 590274ac8dbd1e62cc79d94eb2e2f4ae60cea91a9f8d50b8697d39aba451e82e SHA512 93d02fb7009fe005a91ccf83a3428c449e46c4ff913993e71affdee5a4155d932dcf93238fb85194f44c8b5dd7acd3e3dd83e86b407e4c41e6895abf1f3499ae WHIRLPOOL aa3a289f10608628991b368e9a6bda0821c5f957d1536963e7336ee81e04f554bb7fcce8c2bab429bde1ef7d1490a75770a45caec83d809aaf41f60b36f37924
diff --git a/dev-python/cython/cython-0.23.3.ebuild b/dev-python/cython/cython-0.23.3.ebuild
new file mode 100644
index 000000000000..ea5a078b2b07
--- /dev/null
+++ b/dev-python/cython/cython-0.23.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 flag-o-matic toolchain-funcs
+
+MY_PN="Cython"
+MY_P="${MY_PN}-${PV/_/}"
+
+DESCRIPTION="A Python to C compiler"
+HOMEPAGE="http://www.cython.org/ https://pypi.python.org/pypi/Cython"
+SRC_URI="http://www.cython.org/release/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+RDEPEND=""
+# On testing, setuptools invokes an error in running the testsuite cited in a number of recent bugs
+# spanning several packages. This bug has been fixed in the recent release of version 9.1
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-9.1[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV%_*}"
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS="${CFLAGS}"
+ local CXXFLAGS="${CXXFLAGS}"
+ append-flags -fno-strict-aliasing
+ fi
+
+ # Python gets confused when it is in sys.path before build.
+ local PYTHONPATH=
+ export PYTHONPATH
+
+ distutils-r1_python_compile
+}
+
+python_compile_all() {
+ use doc && unset XDG_CONFIG_HOME && emake -C docs html
+}
+
+python_test() {
+ tc-export CC
+ "${PYTHON}" runtests.py -vv --work-dir "${BUILD_DIR}"/tests \
+ || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGES.rst README.txt ToDo.txt USAGE.txt )
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( Demos/. )
+ distutils-r1_python_install_all
+}