summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-03-02 09:33:03 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-03-02 09:33:26 +0100
commitea5a43ab8d11a58410c4542c25cdd83c632688d1 (patch)
tree02fa67d43d706df152177f2c0b69e23a9721dd30 /dev-python/dbusmock
parentdev-java/jcs: remove last-rited package (diff)
downloadgentoo-ea5a43ab8d11a58410c4542c25cdd83c632688d1.tar.gz
gentoo-ea5a43ab8d11a58410c4542c25cdd83c632688d1.tar.bz2
gentoo-ea5a43ab8d11a58410c4542c25cdd83c632688d1.zip
dev-python/dbusmock: version bump to 0.18.2
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org> Bug: https://bugs.gentoo.org/659878 Bug: https://bugs.gentoo.org/656912 Bug: https://bugs.gentoo.org/636414 Bug: https://bugs.gentoo.org/649552 Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/dbusmock')
-rw-r--r--dev-python/dbusmock/Manifest1
-rw-r--r--dev-python/dbusmock/dbusmock-0.18.2.ebuild45
-rw-r--r--dev-python/dbusmock/files/0.18.2-disable-polkitd-tests.patch13
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/dbusmock/Manifest b/dev-python/dbusmock/Manifest
index 2cc879332225..d8da470bc7dc 100644
--- a/dev-python/dbusmock/Manifest
+++ b/dev-python/dbusmock/Manifest
@@ -1 +1,2 @@
DIST dbusmock-0.16.9.tar.gz 71014 BLAKE2B d1c0853cfd06848f1d10afdd8de764814054a44080b44e1ac2ef3a1658a538f1e4c7f5936d65658c16da33ccbc2e94f35d2746f200fc6791f645e1eccc55f6fd SHA512 3aa91f6ede054ed3d3a69f68f3886094e881d266a8f09c7d08a34d10b080a77facde8aae01e75232472c2e643574fe897dae2c3588f5ad9ecf4ec4e67f404f54
+DIST dbusmock-0.18.2.tar.gz 72031 BLAKE2B 44b46f05e48f1178fe95e44c83899bbef5bc64dcee856be1b332890893a5b901a03c236ad9a8cc6cf2ece83efbf5ec798551320a098736ff95c13951333ffaa3 SHA512 2421cea872e1d84db639cae0d6cc10c4b80ccf64903b7b3f437cb58ad8e3d957c30c871f9666a7a7774808b4b56d6116959ea03fdc8b575ed98023b77b61c8a0
diff --git a/dev-python/dbusmock/dbusmock-0.18.2.ebuild b/dev-python/dbusmock/dbusmock-0.18.2.ebuild
new file mode 100644
index 000000000000..8a4c34721766
--- /dev/null
+++ b/dev-python/dbusmock/dbusmock-0.18.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Easily create mock objects on D-Bus for software testing"
+HOMEPAGE="https://github.com/martinpitt/python-dbusmock"
+SRC_URI="https://github.com/martinpitt/${MY_PN}/releases/download/${PV}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-17.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/0.18.2-disable-polkitd-tests.patch
+)
+
+python_test() {
+ nosetests --verbose || die "tests fail under ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( NEWS README.rst )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dbusmock/files/0.18.2-disable-polkitd-tests.patch b/dev-python/dbusmock/files/0.18.2-disable-polkitd-tests.patch
new file mode 100644
index 000000000000..2f17c233a3f7
--- /dev/null
+++ b/dev-python/dbusmock/files/0.18.2-disable-polkitd-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/test_polkitd.py b/tests/test_polkitd.py
+index f47fdfa..975878b 100644
+--- a/tests/test_polkitd.py
++++ b/tests/test_polkitd.py
+@@ -25,7 +25,7 @@ p.communicate()
+ have_pkcheck = (p.returncode == 0)
+
+
+-@unittest.skipUnless(have_pkcheck, 'pkcheck not installed')
++@unittest.skip
+ class TestPolkit(dbusmock.DBusTestCase):
+ '''Test mocking polkitd'''
+