summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/deform
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/deform')
-rw-r--r--dev-python/deform/Manifest2
-rw-r--r--dev-python/deform/deform-0.9.8.ebuild41
-rw-r--r--dev-python/deform/deform-0.9.9.ebuild41
-rw-r--r--dev-python/deform/metadata.xml9
4 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/deform/Manifest b/dev-python/deform/Manifest
new file mode 100644
index 000000000000..41580168f61d
--- /dev/null
+++ b/dev-python/deform/Manifest
@@ -0,0 +1,2 @@
+DIST deform-0.9.8.tar.gz 1336542 SHA256 fd4a4f216d939423a4fe5ef86ec9523b0f5f048cc37a7c9beed3d8316a06a094 SHA512 561fb7bdeefa848c2eeac3a36a13116409be0b9c90ef515fc9a3ac8f31e071767a155734a104ac261794caf35d0aacd434f243f19ffe4321fdabac3d9ccec789 WHIRLPOOL 4fd24743b0b01a279a193b6b24a4743d03c2bf7fa272f58953343e497f35fd1c835f3e0c9fd53ec9bdfdbe239d754ca927458b16696acc1b79c06c0fcc6f295e
+DIST deform-0.9.9.tar.gz 1336829 SHA256 a0ddbeba3ed5f4b061a2c83423e00a421003600868d71021816897dfa1d4b77a SHA512 f0f615415696adba8add8f37c7ab8b8d213ec6d1eb68e2322961cef46df9e381b2368515b524d71eed110a33aa8a7f0aee8302e39b4d6a8871a0eb78108aca11 WHIRLPOOL fa3a2462ae3f9d5ec81305c15efb2ceca0335dde12f3ef801933caf306dcfd3c95d989f2c61e940a757b9a029e5a090fa05435b24b5d18b3665bdbfc6975c602
diff --git a/dev-python/deform/deform-0.9.8.ebuild b/dev-python/deform/deform-0.9.8.ebuild
new file mode 100644
index 000000000000..d612d9b59596
--- /dev/null
+++ b/dev-python/deform/deform-0.9.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Another form generation library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/deform/en/latest/ http://pypi.python.org/pypi/deform https://github.com/Pylons/deform"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# tests require zope.deprecation
+RESTRICT="test"
+
+RDEPEND=">=dev-python/translationstring-1.1[${PYTHON_USEDEP}]
+ >=dev-python/colander-1.0_alpha1[${PYTHON_USEDEP}]
+ >=dev-python/peppercorn-0.4[${PYTHON_USEDEP}]
+ >=dev-python/chameleon-1.2.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup:4[${PYTHON_USEDEP}] )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.txt COPYRIGHT.txt README.txt )
+
+src_install() {
+ distutils-r1_src_install
+
+ # Install only the .rst source, as sphinx processing requires
+ # a theme only available from git that contains hardcoded
+ # references to files on https://static.pylonsproject.org/ (so
+ # the docs would not actually work offline). Install the
+ # source, which is somewhat readable.
+ docinto docs
+ dodoc docs/*.rst || die
+}
diff --git a/dev-python/deform/deform-0.9.9.ebuild b/dev-python/deform/deform-0.9.9.ebuild
new file mode 100644
index 000000000000..406b8a4cf99c
--- /dev/null
+++ b/dev-python/deform/deform-0.9.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit distutils-r1
+
+DESCRIPTION="Another form generation library"
+HOMEPAGE="http://docs.pylonsproject.org/projects/deform/en/latest/ http://pypi.python.org/pypi/deform https://github.com/Pylons/deform"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+# tests require zope.deprecation
+RESTRICT="test"
+
+RDEPEND=">=dev-python/translationstring-1.1[${PYTHON_USEDEP}]
+ >=dev-python/colander-1.0_alpha1[${PYTHON_USEDEP}]
+ >=dev-python/peppercorn-0.4[${PYTHON_USEDEP}]
+ >=dev-python/chameleon-1.2.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/beautifulsoup:4[${PYTHON_USEDEP}] )"
+
+# Include COPYRIGHT.txt because the license seems to require it.
+DOCS=( CHANGES.txt COPYRIGHT.txt README.txt )
+
+src_install() {
+ distutils-r1_src_install
+
+ # Install only the .rst source, as sphinx processing requires
+ # a theme only available from git that contains hardcoded
+ # references to files on https://static.pylonsproject.org/ (so
+ # the docs would not actually work offline). Install the
+ # source, which is somewhat readable.
+ docinto docs
+ dodoc docs/*.rst || die
+}
diff --git a/dev-python/deform/metadata.xml b/dev-python/deform/metadata.xml
new file mode 100644
index 000000000000..7751d9e184f7
--- /dev/null
+++ b/dev-python/deform/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">deform</remote-id>
+ <remote-id type="github">Pylons/deform</remote-id>
+ </upstream>
+</pkgmetadata>