summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-05 19:16:21 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-05 20:45:03 +0100
commitf7f009edf9735f365252178909d0bfbb7e0b66cf (patch)
treea5d05c98eb2da1f6ae5c740e26a4fae446b13681 /dev-python/dexml
parentprofiles/prefix/sunos/solaris: mask portage-utils-0.60 on 9 and 10, bug #573902 (diff)
downloadgentoo-f7f009edf9735f365252178909d0bfbb7e0b66cf.tar.gz
gentoo-f7f009edf9735f365252178909d0bfbb7e0b66cf.tar.bz2
gentoo-f7f009edf9735f365252178909d0bfbb7e0b66cf.zip
dev-python/dexml: New package, ebuild written by me
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/dexml')
-rw-r--r--dev-python/dexml/Manifest1
-rw-r--r--dev-python/dexml/dexml-0.5.1.ebuild27
-rw-r--r--dev-python/dexml/metadata.xml16
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/dexml/Manifest b/dev-python/dexml/Manifest
new file mode 100644
index 000000000000..945861d03044
--- /dev/null
+++ b/dev-python/dexml/Manifest
@@ -0,0 +1 @@
+DIST dexml-0.5.1.tar.gz 24359 SHA256 6ba83883ead5cc74ce8198daecc657b60bf9cdb3887b484a92dcde55c10e2cdf SHA512 b8ac2b9f875ac7cf699eb9ee17adb8678ed8d4a796130bbb60f05431207adb68f490b7a7a41600acbc16a3cc08d55f22d91a13e53fe3d835a322709ee3446c9f WHIRLPOOL 93d44efcf71fa7ffe91bdb95c287f5004c3abab1a2a5b7f95c26d5e4f0382896970ae05c8f19e56db6c821a90120ab3548be177fbb7c92ace306d58d3969853f
diff --git a/dev-python/dexml/dexml-0.5.1.ebuild b/dev-python/dexml/dexml-0.5.1.ebuild
new file mode 100644
index 000000000000..0493c422775a
--- /dev/null
+++ b/dev-python/dexml/dexml-0.5.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Dead-simple Object-XML mapper for Python"
+HOMEPAGE="http://packages.python.org/dexml http://pypi.python.org/pypi/dexml"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ esetup.py test
+}
diff --git a/dev-python/dexml/metadata.xml b/dev-python/dexml/metadata.xml
new file mode 100644
index 000000000000..513b30532c29
--- /dev/null
+++ b/dev-python/dexml/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">dexml</remote-id>
+ <doc>http://pythonhosted.org/dexml/</doc>
+ <maintainer status="unknown">
+ <email>ryan@rfk.id.au</email>
+ <name>Ryan Kelly</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>