summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2016-08-25 06:39:18 +0200
committerJohann Schmitz <ercpe@gentoo.org>2016-08-25 06:39:18 +0200
commit3e8ef749a93eb7c98bfe28d97434cac559957c0f (patch)
tree0d40cb1ac74e24b8a8fe8a5e57877ebb21922dc0 /dev-python/django-debug-toolbar
parentdev-python/python-sqlparse: Version bump to 0.2.1 (diff)
downloadgentoo-3e8ef749a93eb7c98bfe28d97434cac559957c0f.tar.gz
gentoo-3e8ef749a93eb7c98bfe28d97434cac559957c0f.tar.bz2
gentoo-3e8ef749a93eb7c98bfe28d97434cac559957c0f.zip
dev-python/django-debug-toolbar: Version bump to 1.5
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-1.5.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index 80da15c9a8a5..3747b4d7222b 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,2 +1,3 @@
DIST django-debug-toolbar-1.3.2.tar.gz 316106 SHA256 3cb9128c17a672864b0daa16065c9d80ff910cbc3b344a3e5d82eb0fb30a185c SHA512 d1428f1f729a190ddbf3a260bc428d7a78421519be60c7f07ad3e7f3498414d4ac0ec64d5772fcf89d6521f83bd9226fae104c43b4f0ad4deaf7cfb427d24b1c WHIRLPOOL f088dc6c4fb766a9e38b2f736a66126bdb75bd3cd7762c8ba06650b401639a644831e848012bd001cbd8ffdaad6b823303765f5f44d8bc79688f2d9b7da4592d
DIST django-debug-toolbar-1.4.tar.gz 315912 SHA256 08a6070bed7a64a4d9e57d2acc6bd2a854e6b1ee78482fc6f47c5c7db6d139d7 SHA512 639b1608f51abdc395d1dd853d7f549a53f616734398bbb76a002e8cde5cc15379d7a0dbedb1d5d388ec1af2338a69d6a56a53390f189b01ecc178c6ef3cea79 WHIRLPOOL a29c4d3831228af98eb51449f3a9f01de1b5c1627a022a527c47c238f5de22ec254127fc92a6cdfe34bc5d3fa9d5b119f8b1240ab8bcdf06ba6d0150f9a3eac2
+DIST django-debug-toolbar-1.5.tar.gz 315928 SHA256 10024b7850e4274f1d5762668da18ee05670054be43e497c8d8b12f7c655bee3 SHA512 9a421b80016bdaee8dd3ba2a9b7c3b788b54a4f464cdd5697e36536268e4d3d926bf77088a715e87f192dc8a20a100d8adac68c9c26a1191a5343e377240bf64 WHIRLPOOL 438beaa6b40ff3c91093203a26ffaac545056c4c74963254c1a86bd0fbf0d021744fd5c41e07eeb79b98adda4b92d7b2e261a6222032c417ae8180856de3bfee
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-1.5.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-1.5.ebuild
new file mode 100644
index 000000000000..9d1fb386b14d
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-1.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display debug information"
+HOMEPAGE="
+ https://pypi.python.org/pypi/django-debug-toolbar/
+ https://github.com/django-debug-toolbar/django-debug-toolbar/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/django-1.8[${PYTHON_USEDEP}]
+ >=dev-python/python-sqlparse-0.2.0[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # Prevent non essential d'loading by intersphinx
+ sed -e 's:intersphinx_mapping:_&:' -i docs/conf.py || die
+
+ # This prevents distutils from installing 'tests' package, rm magic no more needed
+ sed -e "/find_packages/s:'tests':'tests.\*', 'tests':" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}