summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-01-10 05:21:05 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-01-10 05:26:41 +0000
commit18dac8ffa2683a38e973649aafbeebf9d151eba1 (patch)
tree036ae6bee826788461accfd8a9b334d841b3d5ba /dev-python/dynd-python
parentdev-libs/libdynd: fix the git version mangling (diff)
downloadgentoo-18dac8ffa2683a38e973649aafbeebf9d151eba1.tar.gz
gentoo-18dac8ffa2683a38e973649aafbeebf9d151eba1.tar.bz2
gentoo-18dac8ffa2683a38e973649aafbeebf9d151eba1.zip
dev-python/dynd-python: version bump
rework of the git forced commit tag Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/dynd-python')
-rw-r--r--dev-python/dynd-python/Manifest3
-rw-r--r--dev-python/dynd-python/dynd-python-0.6.5.ebuild75
-rw-r--r--dev-python/dynd-python/dynd-python-0.6.6.ebuild73
-rw-r--r--dev-python/dynd-python/dynd-python-0.7.2.ebuild58
-rw-r--r--dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch14
-rw-r--r--dev-python/dynd-python/metadata.xml12
6 files changed, 63 insertions, 172 deletions
diff --git a/dev-python/dynd-python/Manifest b/dev-python/dynd-python/Manifest
index 97437440fdff..ef8a3219c7ea 100644
--- a/dev-python/dynd-python/Manifest
+++ b/dev-python/dynd-python/Manifest
@@ -1,2 +1 @@
-DIST dynd-python-0.6.5.tar.gz 231313 SHA256 63552c19d7da7a6dd417d75de45af61aa70f336e09d48fea0f5f9f571b41785d SHA512 46af19bc26c8f410ac26d4e756a726a56f2d852bfa21dca03c4c47210ed9074a7e017bdd2ecb1de3d00af37815b4a20885cd7945af4c8536941e9106bcf49f12 WHIRLPOOL 7a8941b0b678f4cf83eea7906ef060afa60a3d3168ca1a375ba8349b26cdba2437624150b8494d8f26bbb80f4cf4a8ca30685fb38aa9088b62e7df927dcdc8e0
-DIST dynd-python-0.6.6.tar.gz 233618 SHA256 cfd71413832c8c44f8357268ffce99f013184c339bfda5a9186610e57f32644d SHA512 c6be9acf0a4dd2446d613cc0c251b56fcd529fac733ecd63d0450806d7f4af2191ef4e861d015177140ca997464b591562a9f478ea83638516fab8552ee88c06 WHIRLPOOL b60e3d774fab77df19788b6eb8f812a19126a109ca7158de7eed2ffbacb3da7866935c39da985323dba3e79817225732d4ebd27d584913709ab527dbf05781ad
+DIST dynd-python-0.7.2.tar.gz 184981 SHA256 b86f9e25d0fc9dd9ed89181cbfc0085c767fb3170e0d708767986d00063e96f3 SHA512 e51df7b368b1f6869338cb12a2f093064b1e7531ef674a83dbc7b9cc1dc6143cbe12cb37273bcc01e7b1066eda541b3b15473bc01e88fd9a8d1b594f6f37eaba WHIRLPOOL 11591748f2da74bc0ba803b58f5557f647ce52d890e5621b9fc834ed27a41cf71038690656948a4f4cf9791023887ba4efee25acdd3286db8424094f02acddb4
diff --git a/dev-python/dynd-python/dynd-python-0.6.5.ebuild b/dev-python/dynd-python/dynd-python-0.6.5.ebuild
deleted file mode 100644
index 373dc80cf7c8..000000000000
--- a/dev-python/dynd-python/dynd-python-0.6.5.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit cmake-utils python-r1
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=e5578b6b862c025dd757f77aaae69be48cde5613
-
-DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
-HOMEPAGE="https://github.com/ContinuumIO/dynd-python"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-
-IUSE="doc test"
-
-RDEPEND="
- ~dev-libs/libdynd-${PV}
- >=dev-python/numpy-1.5[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=dev-python/cython-0.19[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.6.2-out-of-git-versioning.patch )
-
-src_prepare() {
- cmake-utils_src_prepare
- # each relase comes with a different set...
- # remove forced strong flags
- sed -i \
- -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
- -e "s|@DYND_VERSION@|${PV}|" \
- -e 's|-g -fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_SEPARATE_LIBDYND=ON
- -DDYND_INSTALL_LIB=ON
- $(cmake-utils_use test DYND_BUILD_TESTS)
- )
- python_foreach_impl cmake-utils_src_configure
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
- use doc && emake -C doc html
-}
-
-src_test() {
- testing() {
- cmake-utils_src_make DESTDIR="${WORKDIR}-test-${EPYTHON}" install
- cd "${WORKDIR}-test-${EPYTHON}"/$(python_get_sitedir) || die
- ${PYTHON} -c 'import dynd; dynd.test()' || die
- }
- python_foreach_impl testing
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
- dodoc README.md
- use doc && dohtml -r doc/build/html/*
-}
diff --git a/dev-python/dynd-python/dynd-python-0.6.6.ebuild b/dev-python/dynd-python/dynd-python-0.6.6.ebuild
deleted file mode 100644
index 7fe0f304b286..000000000000
--- a/dev-python/dynd-python/dynd-python-0.6.6.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5} )
-
-inherit cmake-utils python-r1
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=d7ec36c6f1beb0621d6037ab0953db7e4c1b9150
-
-DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
-HOMEPAGE="https://github.com/ContinuumIO/dynd-python"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- ~dev-libs/libdynd-${PV}
- >=dev-python/numpy-1.5[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- >=dev-python/cython-0.19[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.6.2-out-of-git-versioning.patch )
-
-src_prepare() {
- cmake-utils_src_prepare
- # each relase comes with a different set...
- # remove forced strong flags
- sed -i \
- -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
- -e "s|@DYND_VERSION@|${PV}|" \
- -e 's|-g -fomit-frame-pointer||' \
- -e 's|-Werror||g' \
- CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_SEPARATE_LIBDYND=ON
- -DDYND_INSTALL_LIB=ON
- $(cmake-utils_use test DYND_BUILD_TESTS)
- )
- python_foreach_impl cmake-utils_src_configure
-}
-
-src_compile() {
- python_foreach_impl cmake-utils_src_make
- use doc && emake -C doc html
-}
-
-src_test() {
- testing() {
- cmake-utils_src_make DESTDIR="${WORKDIR}-test-${EPYTHON}" install
- cd "${WORKDIR}-test-${EPYTHON}"/$(python_get_sitedir) || die
- ${PYTHON} -c 'import dynd; dynd.test()' || die
- }
- python_foreach_impl testing
-}
-
-src_install() {
- python_foreach_impl cmake-utils_src_install
- dodoc README.md
- use doc && dohtml -r doc/build/html/*
-}
diff --git a/dev-python/dynd-python/dynd-python-0.7.2.ebuild b/dev-python/dynd-python/dynd-python-0.7.2.ebuild
new file mode 100644
index 000000000000..3ab41b4f24a2
--- /dev/null
+++ b/dev-python/dynd-python/dynd-python-0.7.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+# change each new dynd version, to avoid git in tree dependency
+DYND_PYTHON_GIT_SHA1=8cdef57e71c784d7fe1f3f97a2ce2ce5727a89f1
+
+DESCRIPTION="Python exposure of multidimensionnal array library libdynd"
+HOMEPAGE="http://libdynd.org/"
+SRC_URI="https://github.com/libdynd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ ~dev-libs/libdynd-${PV}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+src_prepare() {
+ default
+ # remove the version mangling from git stuff it requires a git clone
+ # rather force set it a configure time
+ sed -e "/--dirty/s/ver =.*/ver = 'v${PV}'/" \
+ -e '/--always/d' \
+ -i setup.py || die
+ sed -e "s/get_git.*/set(DYND_PYTHON_GIT_SHA1 ${DYND_PYTHON_GIT_SHA1})/" \
+ -e "s/git_describe.*/set(DYND_PYTHON_VERSION_STRING v${PV})/" \
+ -e 's|-g -fomit-frame-pointer||' \
+ -e 's|-Werror||g' \
+ -i CMakeLists.txt || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ cd "${BUILD_DIR}/lib" || die
+ PYTHONPATH=${BUILD_DIR}/lib nosetests -v || die
+}
+
+src_install() {
+ use doc && HTML_DOCS=( docs/build/html/. )
+ distutils-r1_src_install
+}
diff --git a/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch b/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
deleted file mode 100644
index 29c3541b3274..000000000000
--- a/dev-python/dynd-python/files/dynd-python-0.6.2-out-of-git-versioning.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- CMakeLists.txt.orig 2014-05-12 14:00:52.000000000 +0400
-+++ CMakeLists.txt 2014-05-12 14:03:39.000000000 +0400
-@@ -86,8 +86,9 @@
- endif()
-
- # Get the git revision
--get_git_head_revision("${CMAKE_CURRENT_SOURCE_DIR}" GIT_REFSPEC DYND_PYTHON_GIT_SHA1)
--git_describe("${CMAKE_CURRENT_SOURCE_DIR}" DYND_PYTHON_VERSION_STRING --dirty --always --match "v*")
-+SET(DYND_PYTHON_GIT_SHA1 "@DYND_PYTHON_GIT_SHA1@")
-+SET(DYND_PYTHON_VERSION_STRING "@DYND_PYTHON_VERSION@")
-+
- message(STATUS "DyND-Python version: ${DYND_PYTHON_VERSION_STRING}")
- configure_file(
- "${CMAKE_CURRENT_SOURCE_DIR}/src/git_version.cpp.in"
diff --git a/dev-python/dynd-python/metadata.xml b/dev-python/dynd-python/metadata.xml
index 4205da1fae58..67e99838f6fd 100644
--- a/dev-python/dynd-python/metadata.xml
+++ b/dev-python/dynd-python/metadata.xml
@@ -5,15 +5,11 @@
<email>sci@gentoo.org</email>
<name>Gentoo Science Project</name>
</maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
<longdescription lang="en">
- DyND-Python, a component of the Blaze project, is the Python
- exposure of the DyND dynamic multi-dimensional array library.
-</longdescription>
+ DyND-Python, a component of the Blaze project, is the Python
+ exposure of the DyND dynamic multi-dimensional array library.
+ </longdescription>
<upstream>
- <remote-id type="github">ContinuumIO/dynd-python</remote-id>
+ <remote-id type="github">libdynd/dynd-python</remote-id>
</upstream>
</pkgmetadata>