summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger (asterix) <m.mairkeimberger@gmail.com>2016-09-10 19:11:13 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-11 10:54:27 +0200
commit9a43a68d2f2ee5d2ede657921b356fec4a489c77 (patch)
tree6d7905172dc5729be312f542b2db0eb39b22a349 /dev-python/enable
parentdev-python/dynd-python: remove unused patch (diff)
downloadgentoo-9a43a68d2f2ee5d2ede657921b356fec4a489c77.tar.gz
gentoo-9a43a68d2f2ee5d2ede657921b356fec4a489c77.tar.bz2
gentoo-9a43a68d2f2ee5d2ede657921b356fec4a489c77.zip
dev-python/enable: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/2291 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/enable')
-rw-r--r--dev-python/enable/files/enable-3.3.0-nofreetype.patch127
-rw-r--r--dev-python/enable/files/enable-4-rogue-tests.patch47
2 files changed, 0 insertions, 174 deletions
diff --git a/dev-python/enable/files/enable-3.3.0-nofreetype.patch b/dev-python/enable/files/enable-3.3.0-nofreetype.patch
deleted file mode 100644
index 56000986dff5..000000000000
--- a/dev-python/enable/files/enable-3.3.0-nofreetype.patch
+++ /dev/null
@@ -1,127 +0,0 @@
---- Enable-3.3.0.orig/enthought/kiva/agg/setup.py 2010-02-25 13:15:07.000000000 -0500
-+++ Enable-3.3.0/enthought/kiva/agg/setup.py 2010-03-21 14:55:37.000000000 -0500
-@@ -4,59 +4,6 @@
- import re
- import platform
-
--freetype2_sources =['autofit/autofit.c',
-- 'base/ftbase.c','base/ftsystem.c','base/ftinit.c',
-- 'base/ftglyph.c','base/ftmm.c','base/ftbdf.c',
-- 'base/ftbbox.c','base/ftdebug.c','base/ftxf86.c',
-- 'base/fttype1.c',
-- 'bdf/bdf.c',
-- 'cff/cff.c',
-- 'cid/type1cid.c',
-- 'lzw/ftlzw.c',
-- 'pcf/pcf.c','pfr/pfr.c',
-- 'psaux/psaux.c',
-- 'pshinter/pshinter.c',
-- 'psnames/psnames.c',
-- 'raster/raster.c',
-- 'sfnt/sfnt.c',
-- 'smooth/smooth.c',
-- 'truetype/truetype.c',
-- 'type1/type1.c',
-- 'type42/type42.c',
-- 'winfonts/winfnt.c',
-- 'gzip/ftgzip.c',
-- 'base/ftmac.c',
-- ]
--
--freetype2_dirs = [
-- 'autofit',
-- 'base',
-- 'bdf',
-- 'cache',
-- 'cff',
-- 'cid',
-- 'gxvalid',
-- 'gzip',
-- 'lzw',
-- 'otvalid',
-- 'pcf',
-- 'pfr',
-- 'psaux',
-- 'pshinter',
-- 'psnames',
-- 'raster',
-- 'sfnt',
-- 'smooth',
-- 'tools',
-- 'truetype',
-- 'type1',
-- 'type42',
-- 'winfonts',
-- 'gzip'
-- ]
--
--
--
- def configuration(parent_package='',top_path=None):
- from numpy.distutils.misc_util import Configuration
- from numpy.distutils.system_info import dict_append, get_info
-@@ -85,45 +32,11 @@
- plat = 'x11' # use with gtk2, it's slow but reliable
- #plat = 'gdkpixbuf2'
-
--
-- #-------------------------------------------------------------------------
-- # Add the freetype library (agg 2.4 links against this)
-- #-------------------------------------------------------------------------
--
-- prefix = config.paths('freetype2/src')[0]
-- freetype_lib = 'freetype2_src'
--
-- def get_ft2_sources((lib_name, build_info), build_dir):
-- sources = [prefix + "/" + s for s in freetype2_sources]
-- if sys.platform=='darwin':
-- return sources[:]
-- return sources[:-1]
--
-- ft2_incl_dirs = ['freetype2/src/' + s for s in freetype2_dirs] \
-- + ['freetype2/include', 'freetype2/src']
-- ft2_incl_dirs = config.paths(*ft2_incl_dirs)
-- if sys.platform == 'darwin':
-- ft2_incl_dirs.append("/Developer/Headers/FlatCarbon")
--
-- config.add_library(freetype_lib,
-- sources = [get_ft2_sources],
-- include_dirs = ft2_incl_dirs,
--
-- # This macro was introduced in Freetype 2.2; if it is
-- # not defined, then the ftheader.h file (one of the
-- # primary headers) won't pull in any additional internal
-- # Freetype headers, and the library will mysteriously
-- # fail to build.
-- macros = [("FT2_BUILD_LIBRARY", None)],
--
-- depends = ['freetype2'],
-- )
--
- #-------------------------------------------------------------------------
- # Add the Agg sources
- #-------------------------------------------------------------------------
-
-- agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ft2_incl_dirs
-+ agg_include_dirs = [agg_dir+'/include',agg_dir+'/font_freetype'] + ["/usr/include/freetype2/"]
- agg_sources = [agg_dir+'/src/*.cpp',
- agg_dir+'/font_freetype/*.cpp']
- config.add_library(agg_lib,
-@@ -137,7 +50,7 @@
- if sys.platform == 'darwin':
- define_macros = [('__DARWIN__', None)]
- macros = [('__DARWIN__', None)]
-- extra_link_args = ['-framework', 'Carbon']
-+ extra_link_args = ['-framework', 'Carbon', '-Wl,-search_paths_first']
- else:
- define_macros = []
- macros = []
-@@ -191,7 +104,7 @@
-
- build_info = {}
- kiva_lib = 'kiva_src'
-- build_libraries = [kiva_lib, agg_lib, freetype_lib]
-+ build_libraries = [kiva_lib, agg_lib, "freetype"]
- if sys.platform == "win32":
- build_libraries += ["opengl32", "glu32"]
- elif sys.platform == "darwin":
diff --git a/dev-python/enable/files/enable-4-rogue-tests.patch b/dev-python/enable/files/enable-4-rogue-tests.patch
deleted file mode 100644
index f08f7b00ce36..000000000000
--- a/dev-python/enable/files/enable-4-rogue-tests.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-diff -ur enable-4.3.0.orig/enable/savage/svg/tests/test_document.py enable-4.3.0/enable/savage/svg/tests/test_document.py
---- enable/savage/svg/tests/test_document.py 2013-03-28 21:58:28.000000000 +0800
-+++ enable/savage/svg/tests/test_document.py 2013-05-14 21:23:18.641569707 +0800
-@@ -63,6 +63,7 @@
- 0
- )
-
-+ @unittest.skip("This tests accesses the internet")
- def testURLFallback(self):
- self.document.state["fill"] = "url(http://google.com) red"
- self.assertEqual(
-diff -ur enable-4.3.0.orig/enable/tests/kiva_graphics_context_test_case.py enable-4.3.0/enable/tests/kiva_graphics_context_test_case.py
---- enable/tests/kiva_graphics_context_test_case.py 2013-03-28 21:58:28.000000000 +0800
-+++ enable/tests/kiva_graphics_context_test_case.py 2013-05-14 21:24:53.897573114 +0800
-@@ -1,4 +1,3 @@
--
- import numpy as np
- import unittest
-
-@@ -8,6 +7,7 @@
- class TestGCErrors(unittest.TestCase):
- """Test some cases where a ValueError should be raised."""
-
-+ @unittest.expectedFailure
- def test_bad_image_size(self):
- arr = np.array([[1, 2], [3, 4]], dtype=np.uint8)
- gc = GraphicsContext((50, 50))
-diff -ur enable-4.3.0.orig/kiva/quartz/__init__.py enable-4.3.0/kiva/quartz/__init__.py
---- kiva/quartz/__init__.py 2013-03-28 21:58:28.000000000 +0800
-+++ kiva/quartz/__init__.py 2013-05-14 21:32:10.473588730 +0800
-@@ -2,16 +2,3 @@
- # :Copyright: 2004, Enthought, Inc.
- # :License: BSD Style
-
--from mac_context import get_mac_context
--
--
--def get_macport(dc):
-- """
-- Returns the Port or the CGContext of a wxDC (or child class) instance.
-- """
-- if 'GetCGContext' in dir(dc):
-- ptr = dc.GetCGContext()
-- return int(ptr)
-- else:
-- from macport import get_macport as _get_macport
-- return _get_macport(str(dc.this))